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Audio and video support in EXMARaLDA1 

 
1. Introduction and general recommendations 

EXMARaLDA supports the playback and display of digital audio or video files and their 

synchronisation with the transcriptions through:  

 the timeline viewer in the Partitur-Editor, 

 the Audio/Video panel in the Partitur-Editor (View > Audio/Video panel), 

 the Praat panel in the Partitur-Editor (View > Praat panel), 

 and through corresponding components in EXAKT, FOLKER and OrthoNormal. 

Audio and/or video files are associated to a recording via Transcription > Recordings… in 

the Partitur-Editor. 

If you work with video, you will still need to have an audio file in WAV format associated 

with your transcription for the timeline viewer to show you a real waveform. In that case, 

extract a WAV file from the video and associate both video and WAV file with your 

transcription, putting the video file on top of the list.  

Likewise, the Praat Panel requires a WAV file to be associated with the transcription, as do 

the functions for running a silence detection (File > New from silence detection), for 

masking audio files (Transcription > Mask audio file…), and for calling the WebMaus web 

service (CLARIN > WebMaus).  

Recommendation 1: WAV file  

Always have a WAV file associated with the transcription. If you work with video, 

extract a WAV file and associate both files, putting the video first. 

Not associating a WAV file will rob you of the possibility to visually detect pauses etc. in the timeline 

viewer and of the possibility to work with the Praat Panel and other important functions in the editor. 

In a working setup, the individual components should look as follows in the Partitur-Editor: 

 

                                                           
1 Last update: 03/03/2017, system version 1.6. for the Partitur-Editor 
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Figure 1: Timeline viewer displaying the waveform of the WAV audio file (top), audio/video panel displaying the image of the 

MPEG-1 video file (bottom left) and media files associated with the transcription (bottom right). 

Whether and how audio or video support works for a given media file can be tricky to find 

out, because it can depend on many different parameters:  

 your computer's hardware (audio and video card) 

 your operating system (Windows, MAC OS or Linux) 

 certain pieces of software which you may have or not have installed on your system 

(media frameworks like DirectShow or QuickTime and codecs for “reading” video data 

like H.264/MPEG-4) 

 the file format of your audio or video file (e.g. “.wav” or “.mov”) 

 other parameters of your audio or video file (like sampling rate, frame rate, bit rate) 

 the version of EXMARaLDA you work with (preview or official, 32bit or 64bit versions) 

 the settings you choose in EXMARaLDA (in particular, the media player in the Partitur-

Editor, via Edit > Preferences, "Media" tab) 

Please be aware: The EXMARaLDA team has spent much time on trying to understand and 

improve audio and video support, and we have answered countless support requests regarding 

this topic. We have come to the conclusion that we will not be able to provide support for 

arbitrary kinds of media setup in the future any more. Starting with version 1.6 of the Partitur-

Editor, audio and video support in EXMARaLDA is based on the following recommendation:  

Recommendation 2: Standard formats 

EXMARaLDA supports audio and video only in one of the three standard formats 

PCM-WAV (for audio), MPEG-1 (for video) and MPEG-4 (for video), as specified 

below.  

EXMARaLDA may still work with media data in other formats (such as MP3 for video or WMV for 

video), but we cannot guarantee this, nor can we offer much support in cases where EXMARaLDA 

fails to work with these other formats. If you plan to seriously work with EXMARaLDA, we absolutely 

recommend that you establish a workflow where your audio and video data are converted to one of the 

standard formats before you use them in EXMARaLDA. 

Please note that MPEG-1 video is generally not a good choice for archiving your data (since it 

is an outdated standard) or for delivering it over the web (since MPEG-4-based formats have 
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been established as a de facto standard in the WWW). We recommend it only as a “tool 

format”. In your workflow, you could use MPEG-4 as the base format and simply derive an 

MPEG-1 version for the parts where EXMARaLDA is involved. 

EXMARaLDA uses different players for audio/video playback. You can see which player is 

currently used in the lower right corner of the Partitur-Editor: 

 

Figure 2: Currently used player 

You can switch players via Edit > Preferences… (in the “Media” tab) in the Partitur-Editor. 

Please note that you'll have to restart the Partitur-Editor for a change of player to take effect. 

 

Figure 3: Switching players in the "Media" tab 

Only the “BAS Audio player”, developed by the Bavarian Archive for Speech Signals, is 

written in “pure” JAVA and thus mostly independent of the operating system it runs on. The 

BAS audio player only supports WAV audio, i.e. you cannot use it to playback video.  
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For video, EXMARaLDA uses players developed at the Max-Planck Institute for 

Psycholinguistics in the context of the ELAN tool. The “JDS player” builds on Microsoft's 

DirectShow framework and is available under Windows only. It usually works fine with 

MPEG-1 videos as well as WAV audio files. The “CocoaQT player” builds on Apple's 

QuickTime framework and is available under MAC OS only. It usually works fine with 

MPEG-1 videos, MPEG-4 videos and WAV audio files. The “MMF player” builds on 

Microsoft's Media Foundation (MMF) framework. It is worth a try if you absolutely must 

work with MPEG-4 files under Windows, but we haven't managed so far to make it work 

100% reliably. The “JMF player” builds on Sun's Java Media Framework, the development 

of which has, unfortunately, come to a standstill in 2003. It can still work okay for MPEG-1 

video files on Windows, and it is the only video player we can currently offer on Linux. 

The following table summarises the availability and properties of the different players on 

different platforms: 

 Operating System Audio Video 

 Windows MAC OS Linux WAV MPEG-1 MPEG-4 

BAS-Audio-
Player 

✔ ✔ ✔ ✔ × × 

JDS-Player ✔ × × ✔ ✔ (✔)2 

Cocoa-QT-Player × (✔)3 × ✔ ✔ ✔ 

JMF-Player (✔)4 (✔)4 (✔)4 (✔)4 (✔)4 × 
MMF-Player (✔)5 × × × × (✔)5 

Figure 4: EXMARaLDA players for different platforms and formats 

Recommendation 3: EXMARaLDA players 

If you work with audio only, the BAS audio player should work fine on all platforms. If 

you work with MPEG-1 video, choose the JDS player on Windows, the CocoaQT player 

on MAC OS. 

Further options, which we do not recommend, but do not want to discourage altogether, are to work 

with MPEG-4 files on Windows using the MMF player, to work with MPEG-4 files on MAC OS using 

the CocoaQT player or to work with MPEG-1 files on Linux using the JMF player.  

 

2. Format specifications 

2.1. WAV Audio 

The following table summarises the properties of WAV audio files as we defined them as the 

“Archive Standard” at the Archive for Spoken Language. Audio files with these properties 

usually work fine in EXMARaLDA, both with the BAS audio player and the JDS, and 

CocoaQT players.  

                                                           
2 JDS will be able to playback MPEG-4 files if a suitable codec is installed on the system. One such codec is Ffdshow/mpeg-

4: http://www.free-codecs.com/download/ffdshow.htm. 
3 The CocoaQT player will only work with Apple's Java 1.6. If you run EXMARaLDA on the MAC with Oracles Java (1.7 or 

higher), the player will be automatically switched to the BAS audio player. Video playback is thus not possible with Oracle 

Java on the Macintosh.  
4 The JMF player should be used as a last resort only. Since it is the only video player currently available on Linux, we 

cannot recommend to work with video under Linux. The JMF player under Linux requires the32bit distribution of 

EXMARaLDA.  
5 Support for MPEG-4 via the MMF player may improve in future versions of EXMARaLDA 

http://www.free-codecs.com/download/ffdshow.htm
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 WAV 

Format PCM.WAV 

Sampling rate 48kHz 

Bit rate 1536Kbps 

Bit depth 16bit 

Channels Stereo 
Figure 5: Properties of WAV audio files 

Lower sampling rates or bit depths, as well as mono recordings should also be fine. Higher 

sampling rates (e.g. 96kHz) or bit depths (e.g. 24bit) can cause problems for some of the 

players. 

Some known problems in this area are: 

 Some devices write compressed audio files with the suffix "WAV". Such compressed 

WAV files must be decompressed before they can be used in EXMARaLDA. 

 The JDS player has sometimes trouble reading WAV from “external” (network or USB) 

drives (probably because of some issue with file permissions). If you experience such 

problems, try copying the WAV file in question to your local disk and read it from there. 

 We do not recommend MP3 as a file format to work with in EXMARaLDA. However, the 

JDS and CocoaQT players should be able to play MP3. An MP3 version of the audio is 

needed when working with remote corpora in EXAKT.  

2.2. MPEG-1 and MPEG-4 Video 

The following table summarises the properties of MPEG-1 and MPEG-4 files as we defined 

them as the “Archive Standard” at the Archive for Spoken Language. Video files with the 

MPEG-1 (the “tool format”) properties work fine in EXMARaLDA with both, the JDS and 

the CocoaQT player, and they can also be okay for the JMF player. The MPEG-4 parameters 

are those which we use as a “master format”, i.e. for delivering high quality video wherever 

EXMARaLDA is not involved. We plan to improve EXMARaLDA’s MPEG-4 support for 

this specification.  
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Format/Container MPEG 1 mp4/AVC 

Encoding MPEG-PS H.264/MPEG-4 Part 10 AVC 

Resolution 352 x 288 1980x1080 

Frame rate 25-FPS 25 FPS 

Bit rate 1000kbps up to 5000Kbps 

Bit rate type constant constant 

Scan type progressive progressive 
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Format MPEG Audio AAC 

Sampling rate 48kHz 48kHz 

Bit rate 224Kbps 384Kbps 

Channels Stereo Stereo 
Figure 6: Summary of the properties for MPEG-1 and MPEG-4 files 

2.3. Transcoding 

To work with any of the three recommended formats you may have to convert data from your 

recording device (audio recorder or video camera) or from some other source (e.g. YouTube 

downloads) to one of the standard formats. As mentioned above, conversion can also be 

necessary between the standard formats, for instance when you need to extract a WAV audio 
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file from a video file or when you transform MPEG-4 “archive” videos into MPEG-1 “tool” 

videos. 

Audio conversion: is usually straightforward. We can generally recommend Audacity 

(http://www.audacityteam.org/) for this task. Audacity is free, it has a great user community 

(also among linguists), and it works on all common platforms. Audacity can convert between 

WAV files with different parameters (e.g. turn a stereo into a mono file, or reduce sampling 

rate from 96kHz to 48kHz), it can convert compressed MP3 or OGG audio into uncompressed 

WAV, and it can even be used to extract audio from some types of video files, and save it as 

WAV. It does not, however, offer any support for converting between different video formats. 

Alternatively, Praat is also quite flexible in terms of the audio formats it understands, and it 

can be used to reliably produce WAV files with the parameters specified above.  

Video conversion: there are many tools out there, some of them free, some of them with a 

commercial licence. Although many of them make a promise to be able to “convert any 

format into any other format”, the quality of the conversions can differ greatly between any 

two such tools. As a rule, you get something for your money when you use a commercial tool 

– or, conversely, we found that most free converters produce unsatisfying results (besides, 

some of the more popular ones are categorised as AdWare). At the Archive for Spoken 

German, we use the following commercial products all of which, as a rule, produce MPEG-1 

data that EXMARaLDA can handle well: 

 EDIUS (Cannopus) - http://edius.de/    

 Squeeze (Sorenson) - http://www.sorensonmedia.com/squeeze/squeeze-desktop/ 

 Magix Video Deluxe - http://www.magix.com/de/video-deluxe/  

Recommendation 4: Converters 

To convert between audio formats only, Audacity or Praat are both highly 

recommendable free tools. To convert video data, we strongly recommend to invest into 

a licence for a professional product.  

If purchasing a licence is not an option, we recommend working with the FFMEG library or tools 

which are based on that technology. Currently, X-MediaRecode (http://www.xmedia-recode.de/) is one 

such tool for which we have found few drawbacks. We explicitly discourage the use of SUPER, Format 

Factory and Freemake Video Converter.  

 

3. Trouble shooting 

You may run into one of the following problems when working with audio or video in the 

EXMARaLDA Partitur-Editor: 

(1) The audio or video file is not loaded, the Partitur-Editor displays an error message. 

 

http://www.audacityteam.org/
http://edius.de/
http://www.sorensonmedia.com/squeeze/squeeze-desktop/
http://www.magix.com/de/video-deluxe/
http://www.xmedia-recode.de/
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(2) The audio or video file is loaded, but playback is unreliable in one or more of the 

following ways: 

a) Playback does not start or stop where it should  

b) The video plays all right, but the last part of the sound can’t be heard 

c) The cursor jumps to the end of the file after an interval has been played 

The first things you should do when your media file does not work as expected is to check…  

 …if your media file is at the specified location – under Transcription > Recordings… 

files which cannot be found on the filesystem will be highlighted in red.  

 …if your media file is in one of the recommended file formats (i.e. WAV, MPEG-1, 

MPEG-4, see above) – if they are not, convert them. 

 …if you have selected a player suitable for that file format (see above) – if you just need 

audio playback, it is always worth trying to switch to the BAS Audio Player.  

If this first check does not reveal any errors, you should then verify whether your 

EXMARaLDA setup works with the recommended tool formats at all. To make this easier for 

you, we have put together a zip archive with a few test files which you can download from 

http://exmaralda.org/en/utilities/ (see “Test files for Audio and Video Support in 

EXMARaLDA”).  

http://exmaralda.org/en/utilities/
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Trouble shooting 1: Test your setup with the EXMARaLDA test files 

 Download and unpack the zip archive at http://www.exmaralda.org/files/MEDIA-TEST-

BATTERY.zip.  

 Open the transcription BECKHAMS.exb with the Partitur-Editor.  

 Check if MPEG-1 video playback works, then check if WAV audio playback works by 

selecting the WAV file in the audio/video panel.  

If your setup works with these test files, chances are that your own media file is not encoded 

according to the specifications given above.  

If your setup does not work with the test files, your system may lack the appropriate codecs, 

or the codecs on your system may be misconfigured. This can happen especially on Windows 

when you have different types of media software installed. There is an easy way to clean up 

the codecs on your system, which also helps in many cases.  

Trouble shooting 2a: Install the Combined Community Codec Pack (CCCP) 

 On Windows: Download the CCCP installer from http://www.cccp-project.net/ and run it. 

Restart your computer and try again if EXMARaLDA can open your media file.  

A similar codec pack is available for MAC OS. 

Trouble shooting 2b: Install the Perian Codec Pack (Mac OS) 

 On the Macintosh: Download the Perian Pack from http://perian.org/ and run it. Restart 

your computer and try again if EXMARaLDA can open your media file.  

If none of these troubleshooting measures helps, feel free to contact the EXMARaLDA 

support at exmaralda-support@uni-hamburg.de. Make sure you give us all the necessary 

information (such as: Which media file are you using? With which player? On which OS? 

What is going wrong? Does it also go wrong with the EXMARaLDA test files?).  
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