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Partitur-Editor（曲谱式编辑器）1是德语口语语料库工具套件 EXMARaLDA 的一个独立

组件，用于口语的转写和标注。由德国的德国语言研究院托马斯•施密特（Thomas Schmidt）

等人研发，目前最新版本是 Partitur-Editor1.5.2。Partitur 支持音频和视频的转写标注，能生

成多种数据模式的 xml 文件，与 PRAAT, ELAN, FOLK, ANVIL, Transcriber, Audacity 等软件

实现数据互操作。Partitur 有简化版 FOLKER。 

EXMARaLDA 工具组件、使用教程、演示语料库和相关技术文件标准，可登录网站

http://www.exmaralda.org/下载。登录网站 http://agd.ids-mannheim.de/folker.shtml，注册以后

可以下载 FOLKER 软件。 

Partitur 需要 Java 环境运行。初次运行程序时，系统将检查是否安装 Java，如果没有，

则提示用户并自动链接到 Java 网站下载 chromeinstall-7u25.exe 程序。用户也可以直接登陆

http://java.com/zh_CN/download/installed.jsp 网站下载。 

Partitur 可调用 praat 显示语图。启用此功能，必须先将 praat.exe 和 sendpraat.exe 两个文

件放在 Partitur 程序的同一文件夹目录下。 

第一节 基本功能简介 

一、基本概念 

1.时间轴（timeline）。也叫时间线，是一个有序的线性时刻点的集合。时间轴显示相

对应的音频或视频的时刻读数。在波形浏览器中，同时显示同步的时间轴，通过时间轴上的

时刻点，可以对媒体流中的任何片断进行精确定位搜索。 

2.事件（event）。事件是基本的转写单位。转写文本中，每一个在时间轴上有对应时

段的文本格，记录一个事件（下文称这种文本格为“事件格”）。无任何转写内容的事件格是

“空事件格”。事件可以是各种话语现象和对话语现象的分析和描述。 

3.层(tier) 。也叫轨。Partitur-Editor 也采用曲谱式层结构组织数据。层是一系列有共同

属性的事件集合，每个层必须指派一位说话人。 

4.范畴和类型(category and type)。范畴是对事件内容的概括分类，主要指基于学科分析

和研究得出的分类。如，句子”“非言语声音”“意译”“语调”等等。 

类型是对转写和标注层预先定义的分类。Partitur 规定了 3 种类型：（1）转写类型，用 t 表

示。这个类型的层，用于转写言语。每位说话人只能指派 1个转写类型的层，一个转写类型

的层只能指派 1位说话人。（2）描写类型，用 d表示。这种类型的层，用来描述非言语现象。

一位说话人可以有多个描写类型的层。例如，要分别描述说话人的面部表情、手势、体态，

就可以建立 3个层。这种类型的层，也可能没有说话人，如，背景噪声。（3）标注类型，用

a表示。这种类型的层，用来记录对转写层事件的分析结果。例如，对转写层的事件进行翻

译、解释、注音、词类标记，等等。一个转写层允许对应多个标注层。标注层的每个事件，

在转写层中都有对应的事件，不允许在转写层中无对应事件的标注层事件。 

5.段链（segment chains）。段链，也叫切割段链。它指转写层中一系列连续的事件，

也就是时间轴上的一些列连续的切割段。由于段链记录的是语言，因此可以将段链的口语文

本输出各种版式的文本，例如，像话剧剧本那样的格式。 

 

                                                             
1
 Partitur-editor 德文意思是曲谱编辑器。EXMARalDA 是 Extensible MARkup Language for Discourse 

Annotation 的缩写。FOLK 是德语 Forschungs- und Lehrkorpus 的缩写，意思是面向研究和教学的德语口语

语料库。 
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二、主界面窗口 

运行程序，打开转写文件。Partitur-Editor 主界面窗口如下图所示： 

 

界面布局： 

1 主菜单；2 工具栏；3 文本输入框；4.音频流定位；5 显示指针位置/选段时长；6 波形

缩放；7 音频时间轴；8 波形浏览器；9 播放控制按钮；10 话语事件转写格；11 转写层；12

层名。 

试比较 FOLKER 的界面布局： 

 

FOLKER 主界面略有不同：10 常用的标记符号；11 转写本显示版式模式；15 转写查错

结果显示；16 常见的切割和转写操作按钮。 
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三、主菜单命令 

表 1                       File、Edit 菜单 

 New… 新建转写（空的转写本） 

 

 

 

File 

New from wizard… 从向导创建转写 

New from speakertable… 从说话人表格创建转写 

New from timeline… 从时间轴（媒体）创建转写 

Open 打开转写 

Restore 恢复至最近保存的转写 

Save 保存 

Save as 另存为 

Error list 错误列表 

Page setup 页面设置 

Print 打印 

Output 将转写输出为多种格式的文件 

Import 导入其他软件的标注文件 

export 导出其他格式的标注文件 

exit 退出 

 
 
 
 
 
Edit 

Undo 撤销操作 

Copy 复制 

Paste 粘贴 

Cut 剪切 

Search in events… 在事件中搜索 

Find next 查找下一个 

Replace in events… 在事件中替换。（见说明） 

Go to… 定位 

EXAKT search… 精确搜索 

Selection 选中文本 

Preferences… 偏好设置 

Partitur preferences… Partitur偏好设置。详见四。 

   

表 2                        view（查看）菜单 

Keyboard 打开特殊字符键盘 

Link panel 打开链接面板 

Audio/video panel 打开音频视频播放器 

Annotation panel 打开标注面板 

Praat panel 打开praat面板 

IPA panel 打开国际音标面板 

Show toolbar 显示工具栏 

Show large text field 显示大文本字段 

Show grid 显示文本格 

Show special characters 显示特殊字符 
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Color empty events 彩色显示空事件 

Change scale constant… 改变标尺常数 

Text proportional 自动调整文本格大小 

Timeline proportional 自动调整时间轴的显示比例 

 

表 3                 Transcription（转写）菜单 

 Meta information… 元信息。如：项目名称、转写员等等。 

Speaker table… 说话人登记表,记录说话人有关信息。 

Recording… 打开并关联音频文件 

 
Structure errors… 结构错误显示。（见说明） 

Calculate annotation time… 统计每层所有事件的总时长。 

 

Segmentation errors… 切割错误。见说明。 

Export segmented 
 transcription 

导出切割段文本。 

Count segments… 统计切割段。每个方格为1个切割段。 

 
 
Wordlist… 

词表。按词汇表格式列出所有文本段。 

 Transformation… 将转写文本转换为多种显示格式。 

 Clean up… 清理。把转写中无用或多余部分清除。 

 Glue transcriptions… 将外部转写文件的内容粘合进来。 

 Chop transcription… 将当前转写拆分几个文件另存。 

 Chop audio… 将音频按转写本拆分几个部分另存。 

 ExSync event shrinker… 将ExWriter转写文本事件缩格操作。此功能

windows下无效。 

说明： 

1．结构错误 (structure errors) 

（1）时间标示异常（temporal anomaly）：切割段的起点时刻和结束时刻或且分段时长

数据没有显示或计算出错。 

（2）多个转写层同一说话人（More than one transcription tiers for one speaker）：一个层

原则上只能使用 1 个说话人标签。 

（3）孤立的转写（Orphaned transcription tier）：转写层没有指派说话人。 

  （４）孤立的标注（Orphaned annotation tier）：标注层没有关联的转写层。 

（５）标注匹配错误(Annotation mismatch)：标注层的事件始末时刻点与相关联的转写

事件的始末时刻点不一致。即：转写层的 1 个事件格，在对应的标注层中却有几个事件格；

或者转写层的几个事件格，在对应的标注层中只有 1 个事件格。 

２．切割错误（segmentation errors） 

  系统自动检查切割错误，并按以下格式列表：层序号（tier）、时间轴切割段序号（TIL）、

错误原因（error）、处理结果（processed output）。改错方法如下： 

在错误列表中选中 1 条错误，单击 go to 按钮，系统自动定位到出错的音频段和转写事

件格；修改错误，回车确认。单击刷新按钮，再选择其他错误进行修改。 

如果存在切割错误，本组其他３个命令的操作将无效。单击其他３个命令时，系统将
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弹出“切割出错．．．是否编辑错误？”的提示信息。按确认则回到错误列表状态。 

    Partitur-Editor 根据用户预先指定的 generic, HIAT, DIDA, GAT, CHAT,IPA 等方案和规则

进行查错。可在菜单命令 Edit>preferences>segmentation 中设定规则。详见本节四“偏好设

置”。 

3．格式转换（transform） 

    将当前的转写内容，转换为不同的版面显示格式。设置以下参数： 

    Transformation scenarios（转换模本）。下拉选项提供了若干转写版式模本。选中其中一

个模本，下面的参数 stylesheet（格式样本）相应变化。 

  Transform（转换结果）: （a） 基本转写（basic transcription）。按当前编辑器中正在编

辑的转写版式转换。（b）切割的转写（segmented transcription）。将当前的基本转写版式，

转换为切割段显示版式。（c）列表式转写（list-transcription）。 

segmentation（切割规则）。指定采用的切割规则，如：GENERIC, HIAT, GAT, CHAT, DIDA, 

IPA 等。此功能只在转换结果（b）（c）状态下有效。 

list unit（列表单位）。转换为切割段纵向列表的版式时，按什么单位列表。此参数只在

转换结果（c）状态下有效。 

Stylesheet（格式样本）。当前的转写本采用的版面编排格式。随上面的“转换模本”选

项变化。如果此参数留空，系统自动输出 xml 格式。也可以不使用软件整合的模本，从

EXMARaLDA 网站下载其他模本。 

Output（输出文件类型）。从下拉选项中选择将转写输出的文件格式。 

    4．清理（clean up） 

包括以下几项：（1）删除空事件。（2）删除空隙。指时间轴中无用的静音空隙。（3）

删除无用的时间轴事件。（4）平滑事件轴的细微空白。（5）细微空隙搭桥。（6）统一标识，

将时间点、说话人、层名不一致的进行统一。时间轴的清理，也可以使用 timeline 菜单命令。 

5．粘合转写（glue transcription） 

将另一个转写文件的内容粘合到当前的转写文本中。这项操作有两种粘合模式：（a）合

并方式 。将另一个文件的转写层，加在当前的转写文本中，即新加了转写层。（b）追加方

式。将另一个文件的转写层的文字内容，追加在当前转写文件的指定层的末尾，而不是增加

新的层。 

6. 拆分转写（chop transcription） 

将当前的转写按照时间轴的切割段，分成多个转写文件另存。须指定分成几个文件（至

少 1 个），存储目录，拆分后的文件名，系统将自动在文件名后面加上编号。拆分另存的文

件均为 xml 格式。 

7. 拆分音频（chop audio） 

根据转写层，将音频文件拆分为多个音频片段另存。有两种拆分方式： 

（a）按照时间轴拆分（based on the timeline）。这种拆分方式有两个选项：i)链接到一

个新的层，即：根据时间轴上的音频切割段，在当前曲谱式转写文本中，创建一个新的层与

这些音频切割段关联。ii)不链接任何层（don’t link），直接将时间轴上的每个切割段作为单

独的音频文件另存。  

（2）按层的事件拆分（based on events in a tier）。这种拆分有 3 个选项：i)链接到所选

的层，即选择一个层，将音频按照事件拆分成若干音频另存。ii)链接到一个新层，即：将音

频按照所选层的事件数量，拆分为同等数量的音频文件另寻，并创建一个新的层，与拆分后

的音频文件链接。iii)不链接，即：仅按照所选层的事件数目和顺序，拆分为同等数量的音

频文件另存。 
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表 4                        Tier（层）菜单 

Tier properties… 层属性。 

Edit tier… 编辑层 

Add tier… 新建层 

Insert tier… 插入层 

Move tier upwards 层排序上移。 

Change tier order… 更改层排序。 

Hide tier 隐藏层。 

Show all tiers 显示全部层。 

Remove empty events 删除空事件。 

     

 表 5                       Event（事件）菜单命令 

Event properties 事件属性。 

Remove 删除事件。 

Shift characters to the left 将当前事件格的文字移至左邻格。 

Shift characters to the right 将当前格的文字移至右邻格。 

Merge 合并相邻事件格。 

Split 拆分当前事件格。 

Double split 将当前事件格一分为三。 

Extend to the right 将当前格向右扩展1个事件格。 

Extend to the left 当前格向左扩展1格。 

Shrink on the right 当前格右边收缩1格。 

Shrink on the left 当前格左边收缩1格。 

Move to the right 将当前格位置右移。 

Move to the left 将当前格位置左移。 

Find next event  查找下一事件格。 

Insert pause 插入停顿。 

说明： 

事件（events）指转写的话语现象，包括言语和非言语声音等口语现象记录。每个事件

在音频流中都有对应时段。 

在曲谱式转写结构中，每行称为“层”（也叫“轨”），每层都指派 1 位说话人（层名，

层标签）。每层切割为许多小格，称为“切割段（segment）”，每个切割段同步对应音频流的

1 个片段。 

“切割段”格子里记录转写文本和标注符号。每个有转写内容的“切割格”称为 1 个“事

件”，没有内容的切割格称为空事件（empty event）。 
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表 6                       Timeline 菜单命令 

Edit timeline item 编辑指针或选段的时刻点数值 

Insert timeline item 在时间轴上插入一个事件时段。 

Remove gap 删除空隙。 

Remove all gaps 删除所有空隙。 

Remove unused timeline item 删除无用的时段。 

Make timeline consistent 时间轴时刻读数连贯化。 

Smooth timeline… 平滑时间轴。 

Anchor timeline 固定时间轴。 

Interpolate timeline… 给没有时间读数的事件插入时间值 

Remove interpolate times 移除时间插值 

Confirm timeline item(s) 确认修改过的时间轴事件段（如插值） 

Shift absolute times… 将所有事件段的绝对时间位移一个数值。 

Fine tuning mode 精确微调时间模式 

Add bookmark… 加入书签。 

Bookmark… 书签。 

说明： 

（1）时间轴上的绝对时刻读数，有几种显示方式：10进制秒数或“时:分:秒.毫秒”“分:

秒.毫秒”格式。例如： 

181.23 秒 

00:03:01.23（3 分 1.23 秒） 

03:01.230（3分 1秒 230 毫秒） 

（2）时间轴读数连贯化（make timeline consistent）。时间轴上切割的每个事件时段，

在时间上应该是按照升序连贯的。也就是，前 1时段的终点，也就是后 1时段的起点。如果

时段序号和时刻读数出现不连贯，或不是升序，则应使其连贯。 

（3）时间轴插值（interpolate timeline）。有时某个事件段在转写文本中显示出占用 1

个事件格，但这个切割格并没有分配时间，即：和前一个事件格的时间合在一起。这种情况

就需要进行时间轴上插值。插值方法有两种： 

第一种方法：线性插值，即按照前一事件格和后一事件绝对起始时间点进行加减计算，

得出该事件格的绝对时刻点。例如，前一个事件起始时刻点是 1.0 秒,后一个事件格的起始

时刻点是 4.0 秒，那么缺少时刻值的中间事件格的起始时刻点就是：1.0+(4.0-1.0)/2=2.5 秒。 

第二种方法：按字符计算插值。系统根据该事件的文字长度，自动计算出在前一个事件

起点和后一个时间起点的时间范围内，应该给缺时刻值的事件段分配多少时长。 

（4）绝对时间位移（shift absolute times）。时间轴的时刻读数是按照绝对时间计算的。

此命令可以将整个时间轴的绝对时间读数位移一个固定的时段。例如，原本的时间轴起点是

0.00 秒，设置一个 2.00 秒的位移量，则时间轴的起始点变成了 2.00，其他所有的事件段的

起始点也相应地增加 2.00 秒。当然，也可以做减少位移。 
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表 7                       Format 菜单 

Apply stylesheet 应用样表。 

Open format table… 打开格式表文件。 

Save format table as… 另存格式表 

Edit format table… 编辑格式表 

Format tier… 设置层的格式 

format tier labels… 设置层标签的格式。 

Format timeline… 设置时间轴格式。 

Format timeline items 设置时间轴事件的格式。 

Set frame end 设置边框终点 

Reformat 重置格式 

underline 设置下划线 

 

四、偏好设置（preferences） 

使用 Edit 菜单命令进行初始设置。下表是偏好设置的各种命令和操作。 

fonts Default tier font 设置默认的层文本字库 

Default general purpose font 设置通用的字库 

Underline method 在文本中添加下划线 

stylesheet Head to HTML 设置输出HTML文件头信息（元数

据和说话人）样式文件 

Speakertable to transcription 设置说话人表的样式文件 

Transcription to format table 设置转写的版式样式文件 

Free stylesheet transformation 设置格式转换的样式文件 

HIAT utterance list to HTML  

segmentation Preferred segmentation:  
GENERIC/HIAT/DIDA/GAT/ CHAT/ IPA 

设置优先使用的切割规则 

Finite state machines 设置有限状态机 

Pause notation 设置停顿标记符号 

Auto save Enable undo 
Enable auto save 

启用“撤销”菜单命令 

启用自动保存 

language 德语/瑞典语/法语/捷克语/ 

西班牙语/土耳其语 
设置软件界面语言。 

media JMFplayer/Bas-audio player/ 
Directshow player/JDS-player/ 
Quicktime player 

选择媒体播放器 

path Log file directory 设置日志文件的存储路径 

Praat directory 设置praat的路径 

menu SFB 538/632 menu 在菜单栏是否显示这三个菜单 
SiN menu 

ODT/SDT menu 

Partitur 
preferencess… 

Break/general/RTF/HTML/SVG 设置转写文本打印输出的版式和

格式 
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第二节  操作实例 

 

几种常用操作快捷键 
 

音频 

视频 

播放 

控制 

Ctrl+F4 播放 

Ctrl+F5 暂停 

Ctrl+F6 停止 

Ctrl+空格键 播放选中的音频段 

Ctrl+shift+空格键 播放选中的音频段的最后 1秒 

 

波形 

选段 

定位 

控制 

在选左/右边界附近拨动鼠标齿轮 调整选段的边界线位置 

Alt+  （鼠标先移到边界线） 向左调整选段边界线位置 

Alt+  （鼠标先移动边界线） 向右调整选段边界线位置 

Alt+shift+ 缩进选段起点线的位置 

Alt+shift+ 扩大选段起点线的位置 

Ctrl+shift+ s  移动整个选段 

波形 

缩放 

Ctrl+鼠标齿轮 横向放大/缩小音频波形 

Ctrl+shift+鼠标齿轮 纵向放大/缩小音频波形 

切割 
Ctrl+ +  添加事件 

Alt+ + 追加切分时段 

注意：个别快捷键可能因为不同的键盘设置，会出现不兼容的情况。 

 

操作示例1  新建1个转写文件 

运行 Partitur-editor 

第一步：登记元信息 

单击主菜单 Transcription > Meta information...，在弹出窗口中填写以下信息： 

项目名称 project name  

转写本标题 transcription name 

转写规则 transcription convention 

所转写的媒体文件 Referenced media file 

第二步：填写说话人信息表  

单击主菜单 Transcription > Speakertable...，在弹出窗口中填写说话人的基本信息：姓

名（或代号），性别，语言背景，等等。用户还可以自己定义其他信息，如：年龄，教育，

职业，籍贯，等等。 

第三步：编辑层属性 

单击 Tier > Edit tier... ,在弹出的窗口中，双击列表中的文本格，对其中的说话人姓名、

层名等内容进行修改，将程序初始建立的转写层，更改为用户需要的转写层。 

第四步：添加新的层 

如果是 1位说话人，还需要创建标注层和描写层。如果有 2位或多位说话人，还需要

创建 2个或多个转写层。 

单击 Tier > Add tier..., 指定层的属性： 

——选择 1位说话人。 

——选择 1个层属性：言语层为“T”, 非言语层为 “D” ，标注层为“A” 

——填写范畴代码：例如，“v”表示言语 
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如，下图是 2位说话人，每人 2层，一层是转写言语（v），另一层标注非言语(nv)。 

 
第五步：关联媒体文件 

单击 Transcription>Recording…，在弹出窗口中按 Add 添加音频文件，再按 OK 键，将媒

体文件导入。音频文件应是 wav 格式，如果只有视频文件，则不能显示声音波形。 

第六步：切割媒体流，创建事件 

先播放录音，从头至尾认真地听一遍，对整个话语的速度、节奏，说话人的话轮和分句

情况，有总体的了解。一般来说，我们以口语中相对完整的语句为单位，对媒体流进行切割。

切割的方法有两种： 

方法一： 

第 1步：在波形窗选中一段音频流 

第 2步：播放该选段，拖动边界线，调整至合适的短句位置 

第 3步：选中一个说话人的转写层 

第 4步：单击 ，新加 1个事件格/切割段 

第 5步：重复 1-4 步，直至将媒体流切割完毕。 

方法二： 

第 1步：选中 1位说话人转写层 

第 2步：将鼠标指针定位到波形的起始点 

第 3步：单击  ，系统自动生成 2秒长的事件格/切割段 

第 4步：调整波形选段边界线至合适时刻点，按回车确定 

第 5步：重复 1-4 步骤，直到整个媒体流切割完毕。 

按钮 Add event（添加事件）和 Append interval（追加时段）都可以切割音频流，并在

转写层创建同步的事件格。Add 按钮时切割用户在波形中选中的音频段，因而切割段之间可

以有空隙；Append是将音频流以2秒为时长单位进行连续切割，每个切割段之间没有空隙。 

第 7步：录入转写文本。切割完毕，即可以在事件格中录入转写文本。 

操作练习2  快速切割音频流 

习惯于一边切割音频一边输入文字的转写员，可以使用操作练习1介绍的按钮Add event

（添加事件）和Append interval（追加时段）。有的转写员习惯于先把音频流切割完毕，然

后打字输入转写文本。这时，可以使用主菜单File>New from timeline命令。具体操作如下： 

第一步：单击主菜单File>New from timeline（从时间轴创建），系统弹出是否保存转写文

件信息，选择不保存；系统弹出编辑媒体文件（Edit media file）窗口； 

第二步：单击Add按钮，将音频文件hacker.wav添加进来，按OK确定；系统弹出一个“即

时时间轴切割（Live timeline segmentation）”操作窗口。 

提示信息：按 播放音频，按空格键，在时间轴上插入切割点。下面的勾选项：

maximum interval length 设置最长切割段的时间限度（秒）。 

第三步：将指针移至音频的起始位置，按播放，仔细听播放，遇到需要切割的地方，单

击空格键，直至音频播放和切割完毕。 

第四步：微调时间轴切割点。快速切割出来的事件分界点有时并不精确，一般需要进一

步微调。这时可以在转写层上选中一个事件，播放该段音频，调整波形图上的边界线。所有
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事件的切割时点准确无误以后，就可以在事件格中输入转写文字。 

操作练习3  导入外部转写文本并与媒体流对齐 

语言调查人员通常都是用 Word 文字处理器转写和记录录音内容。Word 文档与媒体互

相割裂，两者无法关联使用。对于这种情况，可以先将 doc 文档转换为纯文本的 txt 文件，

使用 Partitur 软件的主菜单 File>import…，将文本导入,再与录音文件同步关联对齐。例如，

我们已经有一个 hacker.txt 的文本文件，里面是音频文件 hacker.wav 的话语文本。具体操

作如下： 

第一步：删除程序运行后自动建立的层； 

第二步：单击主菜单 File> Import..，系统出现导入转写文件路径框；按取消，系统出现

任意文件路径框；选中 hacker.txt 文件，按打开；出现提示信息“选择一个文本拆分器”。

系统提供了对 txt 文本的三种拆分方式： 

 Split at paragraphs (按段落标记拆分) 

 Split at non-word characters（按非单词符号拆分） 

 Split at regular expression（按常规表达式拆分） 

选择按段落标记拆分，系统将根据文本中的逗号、句号，进行分句和分段切割文本。对

于中文文本，如果每句话都有逗号或句号，导入后的文本将自动按照标点符号分割为一个一

个的事件。按非单词符号切分，系统遇到空格或其他不是单词的符号，就设置切割点。对于

英文文本，则可能按照词与词之间的空格进行切割。按常规表达式拆分，则要求用户输入表

达式。不同软件，表达式的语法格式有所不用。关于 Partitur 的表达式，请参阅网站提供的

详细教程。多数情况下，我们只用到前面两项功能。这里选择第一项。由于本例的 hacker.txt

文件里包括中文和英文，系统将它作为一个整体事件导入，没有切割为事件。因此，还需要

对这个层，进行事件切割。 

第三步： 将鼠标移至每句话末尾的标点符号后面，单击主菜单 Event>split，可将每句

话切割为一个个事件。 

第四步：单击主菜单 Transcription>Recoridng…导入音频文件，将指针移动到音频波形的

起始位置。 

第五步：单击主菜单 Timeline>easy align mode，系统弹出一个操作窗口。按播放按钮，

一边听播放，一边观察文本事件格，没说完一个事件，即可按下空格键，系统自动将音频段

和事件关联。依次操作，直至音频播放完毕。 

第六步：微调时间轴。在时间轴上切割出来的时段与事件格的起点和结束点，不一定完

全对齐，还需要进一步的微调。选中一个事件，播放录音，用鼠标齿轮调整波形段的边界线，

直至准确位置。 

操作练习 4  转写文本的版式编排 

版式编排包括：字体、字号、颜色、文本页边距、行距、行宽、左右对齐，等等。版式

设计主要使用主菜单 Format 的字命令，包括层的格式、层标签格式、事件格式、时间轴格

式，等等。还可以将设计好的转写文本格式，另存为样式模板，以后转写时就可以套用模板。

Partitur 的版式设计对整个层操起作用，不能单独改变一层内部的某各部分。例如，字体设

置为粗体，则该层所有文字都是粗体，而不能同一层中有些字是粗体，另一些字是正体。版

面设计包括以下两步： 

第 1步：设计层的版式 

先点击层名，选中一个层。单击主菜单 Format > Format tier...命令，弹出设置窗口，

设置字体、字号、颜色，等等。如下图： 
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第 2 步：设计层标签和时间轴标签版式 

设计层标签格式使用主菜单Format > Format tier labels...子命令；设计时间轴标签版式，

使用Format > Format timeline...子命令。 

 
第3步：转写文本版面整体设计 

前面是转写文本个别区域的版式设计。如果要对转写文本版面整体设计，使用主菜单

Format > Edit format table...子命令。 

第4步：保存版式 

Partitur的.exb转写文件中并不保存版式信息，排版信息作为单独的版式文件保存。使用

主菜单Format > Save format table as...子命令。 

打开转写文件后，系统使用默认的版式。如果要使用自己设计的版式，可使用主菜单

Format > Open format table...子命令打开此前保存的版式文件。 

因此，同一个转写文件，用户可以设计几种版式，分别存为几个版式文件。这样，就可以根

据不同的用途，打印出不同版式的转写文本。 

操作练习 5  创建事件（或段链）的音频/视频剪辑片段。 

对于一个已经转写的音频或视频文件，可以将转写文本的任意事件（或段链）的音频或

视频，从音频流中离析出来，另存为单独的音频或视频文件。具体操作如下： 

第一步：打开一个转写文件 

第二步：单击主菜单 View>Audio/video panel，将音频/视频面板最大化；勾选右边按钮

前面的同步复选框 sync； 

第三步：在转写文本窗事件格上面的时间轴上，选中一个事件段； 

第四步：回到音频视频面板，分别点击右边上下两个实心三角形按钮，获取所选事件的

起始时点和结束时点； 

第五步：单击面板顶端的倒三角选项按钮，选中音频文件；然后按剪刀图标按钮，选择

文件的存储路径，按确定，系统即可将该段音频剪切出来，另存为一个名为 snippet1.wav 的

音频文件。 

操作练习 6  调用 praat 查看语图 

通过调用 praat 及其通信接口程序 sendpraat 程序，同步显示音频选段的语图。具体操

作如下： 

第一步：单击主菜单 Edit>Preference…,出现偏好设置窗口； 

第二步：单击切换键 Path>Change praat directory,设置 praat 和 sendpraat 的目录，这两

个程序文件必须放在同一目录下面； 

第三步：单击主菜单 View>praat panel，弹出 praat 调用面板，勾选下面的同步选项

synchronize，单击 praat 图标，运行 praat；单击第二个按钮，将音频文件上载到 praat 中，

系统出现提示信息，按确定，即可打开语图。 

第四步：选中转写编辑器的任意事件，praat 即可同步显示该选段的语图。 


