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I. PRELIMINARY REMARKS 

This user manual describes the EXMARaLDA Partitur-Editor in its current version (1.6. of 

October 2016). If you’re using the Editor for the first time, please be kindly advised to read this 

manual and consult it while familiarising yourself with the program. Over the years we have 

learnt the importance of detailed documentation for the user. However, we have also learnt that 

updating, as well as maintaining such documentation, may be very time-consuming, especially 

considering that the EXMARaLDA user group is a multilingual one. Be advised that we now 

offer a few short english documents and video tutorials in the “Help&Support” menu on the 

EXMARaLDA website (www.exmaralda.org), which elaborate on the individual steps whilst 

working with EXMARaLDA (References to these documents have been marked in green in this 

user manual). 

 

XML, EXMARaLDA and the Partitur-Editor 

The Partitur-Editor, which is the focus of this manual, is a tool for the input and output of 

transcriptions. EXMARaLDA is an XML-based system for computer-assisted discourse 

transcription. It was developed as the foundation of a database “Multilingualism” of the 

Research Centre on Multilingualism (German: “Sonderforschungsbereich 538 

Mehrsprachigkeit”) at the University of Hamburg. It is not necessary to continuously remember 

these connections when using the Editor, but it is certainly useful to bear them in mind. More 

specifically, this means: 

 There are other options to create and edit EXMARaLDA transcriptions besides the Partitur-

Editor (i.e. with help of the transcription tools Praat, ELAN or FOLKER, with any XML-

Editor, or in a conventional text editor or word processing program as long as the “Simple 

EXMARaLDA” conventions are obeyed). 

 The main purpose of the Editor is not to supply a tool that creates “pretty” musical scores, but 

to create transcription data in a form that can further be used in computer-assisted processing 

(especially in computer-assisted queries). Nonetheless, input and output in the musical score 

format can be created with the Editor. 

 As an XML-based system, EXMARaLDA makes use of the concept of separating the logical 

and graphical structure of data. EXMARaLDA transcriptions, thus, “are not” musical scores 

and do not “consist” of tiers – these are only elements, which were made use of in reference to 

the graphical display of EXMARaLDA transcriptions on screen or on paper. EXMARaLDA 

is only familiar with elements that relate to the logical structures of the transcriptions, such as 

“events“, “time intervals“, “speakers“ etc. Thus, you can find all of these elements in the user 

controls of the Partitur-Editor. In other words: the graphical structure of a musical score does 

not have an independent meaning. It is merely one of the many possible visualisations that 

may be calculated out of the logical structure of an EXMARaLDA transcription. Due to the 

fact that this graphical structure is the result of a calculation, the Partitur-Editor is not really a 

“What you see is what you get”-kind-of-instrument. When using the Partitur-Editor, it is 

therefore helpful to keep the logical structure behind it in mind, and not only its graphical 

appearance. 

 In a nutshell: You do not need to be an expert in the field of text technology to create 

transcriptions in the Partitur-Editor, but a general understanding of the EXMARaLDA 

http://www.exmaralda.org/


EXMARaLDA Partitur-Editor – Manual  Preliminary Remarks 

 
10 

concept could prove itself as helpful. Due to the fact that this user manual does not focus on 

the concepts of EXMARaLDA, kindly note the following publications: 

Schmidt, Thomas (2002a): EXMARaLDA – ein System zur Diskurstranskription auf dem 

Computer. In: Arbeiten zur Mehrsprachigkeit (Working Papers in Multilingualism), Series 

B (34). Hamburg. 

Schmidt, Thomas (2002b): Gesprächstranskription auf dem Computer – das System 

EXMARaLDA. In: Gesprächsforschung (Online journal about verbal interaction), Volume 

3, 1-23. 

Schmidt, Thomas (2003): Visualising Linguistic Annotation as Interlinear Text. In: Arbeiten zur 

Mehrsprachigkeit (Working Papers in Multilingualism), Series B (46). Hamburg. 

Schmidt, Thomas (2005): Computergestützte Transkription – Modellierung und Visualisierung 

gesprochener Sprache mit texttechnologischen Mitteln, (Series: “Sprache, Sprechen und 

Computer”, 7). Frankfurt a. M. 

Schmidt, Thomas / Wörner, Kai (2005): Erstellen und Analysieren von Gesprächskorpora mit 

EXMARaLDA. In: Gesprächsforschung (Online journal about verbal interaction), Volume 

6, 171-195.  

Schmidt, Thomas (2009): Creating and Working with Spoken Language Corpora in 

EXMARaLDA. In: Lyding, Verena (ed.): LULCL II: Lesser Used Languages & Computer 

Linguistics II. 

 If you have further questions, i.e. whether EXMARaLDA is the right tool for your project, 

feel free to contact the Helpdesk: http://exmaralda.org/en/helpdesk-en/.  

 

“Words of Caution” 

As an additional preliminary remark, and in order to avoid misunderstandings, we would like to 

bring three important circumstances to your attention: 

EXMARaLDA is a “Work in Progress” 

After more than fifteen years of development on the Partitur-Editor, it has reached a stable state 

and is being successfully put to use in numerous projects. Nonetheless, future versions will 

expand its functionality and there may still be undiscovered errors in the current functionality. If 

you should encounter such errors or have any suggestions or feedback, we would be grateful if 

you were to send us a detailed description via e-mail (see also Help > About…). We will then try 

our best to remedy the situation. 

Software updates are published regularly, in which the errors of previous versions have been 

resolved and new functions are introduced. It is therefore advisable to work with the current 

version of the Editor, even if this means a regular new installation of the software. This manual 

is also being updated on a regular basis. If you subscribe to the EXMARaLDA mailing list, you 

will be informed about the availability of new versions regularly (visit our homepage 

http://www.exmaralda.org for more information).  

http://exmaralda.org/en/helpdesk-en/
http://www.exmaralda.org/
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The EXMARaLDA Partitur-Editor is neither the new syncWRITER, nor the new HIAT-DOS 

In some aspects the Partitur-Editor does follow the model of these two programs, but essentially 

it has a different approach: It should not only serve as an input and output instrument for 

transcriptions written in form of musical scores, but also produce data beyond that – data that is 

suitable for further extensive, computer-assisted processing. Thus, many things work differently 

than the users of syncWRITER or of HIAT-DOS may be used to. 

This manual is not a guideline for transcribing 

EXMARaLDA is a formal framework that is situated at a level of abstraction above the specific 

transcription systems like HIAT, DIDA, GAT etc. Therefore, this manual does not provide 

specific instructions on how phenomena of spoken language should be transcribed. This needs to 

be defined separately in the transcription conventions. 

Following manual for transcribing with the EXMARaLDA according to HIAT can be consulted 

for more information: 

Rehbein, Jochen / Schmidt, Thomas / Meyer, Bernd / Watzke, Franziska / Herkenrath, Annette 

(2004): Handbuch für das computergestützte Transkribieren nach HIAT. In: Arbeiten zur 

Mehrsprachigkeit (Working Papers in Multilingualism) (Series B). Hamburg. 

In addition to this HIAT-manual, the sub menu “Help&Support” on the EXMARaLDA-

Homepage (http://www.exmaralda.org) links to an extensive collection of samples for 

transcribing with the EXMARaLDA Partitur-Editor according to HIAT.  

The IDS Mannheim compiled a manual for transcribing with the EXMARaLDA Partitur-Editor 

according to DIDA and cGAT: 

Schmidt, Thomas / Schütte, Wilfried / Winterscheid, Jenny (2015): cGAT Konventionen für das 

computergestützte Transkribieren in Anlehnung an das Gesprächsanalytische 

Transkriptionssystem 2 (GAT2), Version 1.0. Mannheim: Institut für Deutsche Sprache. 

Schütte, Wilfried (2004): Transkriptionsrichtlinien für die Eingabe in EXMARaLDA (ab Version 

1.2.7) nach DIDA-Konventionen. Mannheim: Institut für Deutsche Sprache.  

For further information, please contact the IDS in Mannheim (http://www.ids-mannheim.de/). 

 

http://www.exmaralda.org/
http://www.ids-mannheim.de/
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II. USER INTERFACE 

The two main components of the interface are the musical score (1) and the oscillogram (2). If 

required, the panels discussed in the following chapter can be displayed. 

 

The oscillogram will only be displayed, if the transcription is linked to an audio or video file (via 

Transcription > Recordings…). Should the list of linked recordings not hold a .wav file, only 

a timeline will be displayed instead of the oscillogram: 

 

The buttons for playing the recording can be found between the oscillogram and the musical 

score: 

 

Their functions are (from left to right): 

1)  Determine the speed, at which the audio file is played 

1 

2 
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2)  Play the second before the selection in the oscillogram 

3)  Play the first second of the selection 

4)  Play the current selection (Shortcut: CTRL + Space) 

5)  Play the last second of the selection (Shortcut: CTRL + Shift + Space) 

6)  Play the first second after the selection 

7)  Loop the selection 

8)  Play from cursor position (Shortcut: CTRL + F4) 

9)  Pause (Shortcut: CTRL + F5) 

10)  Stop (Shortcut: CTRL + F6) 

The musical score and the oscillogram are linked to one another. Thus, if the current selection of 

the musical score is equipped with absolute time values, the start and end point of the musical 

score will coincide with the start and end point of the oscillogram selection. Conversely, the 

buttons  (“Add event”) and  (“Append interval”) can be used to insert 

events or time intervals into the musical score according to the current selection in the 

oscillogram. A detailed description can be found in the document Quickstart transcribing.   

The musical score is composed of one or more tiers. Every tier contains events that are assigned 

to one or more intervals on the timeline. 

 

A detailed description of the basic units of an EXMARaLDA transcription can be found in the 

document Understanding the basics of EXMARaLDA. 

The visual appearance of the oscillogram view (as above) can be altered by scrolling: 

 Pressing and holding the CTRL key and scrolling up or down zooms in and out of the 

display horizontally, so that a greater or smaller time unit is then shown per pixel. 
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 Pressing and holding the CTRL and the Shift keys and scrolling up/down zooms in and out 

of the display vertically so that the oscillations are increased and decreased in size. This can 

be particularly useful if the recording’s volume is too low. 

 

If the current selection in the oscillogram is connected to the musical score, the selection 

boundaries will be displayed in green and in red (consider the above examples). If the selection 

boundaries in the oscillogram are altered in this state, these alterations will also be applied to the 

connected time values in the musical score. If the oscillogram view and the musical score are not 

connected, the selection boundaries will be displayed in blue, as in here: 

 

The buttons to modify the oscillogram can be found underneath on the right hand side: 

 

The first button  (“Shift selection”) changes the current selection in such a way that the new 

starting point is the same as the previous endpoint. The length of the selection is maintained: 

  

The second button  (“Detach selection”) keeps the current selection, but detaches the 

musical score from it. The colours of the boundaries then change from green/red to blue 

(compare the graphics above). The third button  (“Assign times”) assigns the start and end 

time of the current selection in the oscillogram to the currently selected time points in the 

musical score. 

The selection boundaries in the oscillogram can be changed in the following way: 

 Clicking and pulling with the mouse 
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 Placing the cursor near one of the boundaries and scrolling thereafter moves the boundary to 

the right or left. 

 Alt +  key moves the right boundary of the selection to the right. Alt +  moves the right 

boundary to the left. Pressing Shift along with Alt and the arrow keys moves the left 

boundary of the selection. 

 Placing the cursor in the middle of the selection and scrolling thereafter moves the entire 

boundary to the right or left. 

Please consult section VIII of this manual or, alternatively, the Keyboard Shortcuts document 

in the “Help&Support” section on our website (www.exmaralda.org) for a more extensive 

overview. 

There are two possible ways to choose longer selections: 

 Using the button  (“Navigate in the recording”) above the oscillogram view to the left, 

opens a dialog that allows input of selection boundaries in numbers: 

 

 If you place the cursor in the oscillogram view and double-click on a position it sets a mark 

in. The next double-click then places a selection from the marked position up to the second 

double-click. 

 

http://www.exmaralda.org/
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III. PANELS 

 

A. Keyboard 

Keys, that may not be available on a normal keyboard, can be entered using the virtual keyboard. 

Should your keyboard be equipped with the required keys, you do not need to use the virtual 

keyboard. If the keyboard does not appear on your screen automatically, choose  

View > Keyboard to have it displayed. 

 

The scrollbar on the left hand side allows alterations in size of the keyboard symbols. 

Furthermore, most symbols are equipped with a short “tool tip” that shows both meaning and 

function. Hover over the symbol to have the “tool tip” displayed: 
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To insert a symbol into the musical score, move the cursor to that position in the musical score 

and click on the desired symbol. To choose a different character set than the one on the 

keyboard, click on the arrow and select a different keyboard from the list. Please note: 

 A number of symbols are only available in a few fonts, namely those that cover a great range 

of Unicode (e.g. “Arial Unicode MS”). The font that is used in the keyboard can be selected 

in  

  

 Edit > Preferences…. If the desired symbol appears as a square in the musical score, the tier's 

font needs to be reformatted (see also Format > Edit format table...). 

 Additional keyboard layouts can be obtained from the “Downloads/Utilities” section on the 

EXMARaLDA webseite (www.exmaralda.org). 

http://www.exmaralda.org/
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B. Link panel 

The Link panel links event descriptions to external image, audio, video and text files. Should 

the link panel not appear on your screen, choose View > Link panel to have it displayed. 

To link an event to an external file, select the event in the musical score and choose whether it's 

an image, audio, video or text file in the “Link Medium” menu. Enter the storage location of the 

file to be linked in “Link URL”. Click Browse… to open a new dialog. Here, you can search 

for the file on your computer. 

The appearance of the upper part of the link panel depends on the type of media file chosen. An 

image will be shown in the upper half of the link panel. The same applies to a linked video file. 

When linking audio and video files, the panel will display an additional player for the playback 

of these files. The content of a linked text file will be display in a preview window. 
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C. Audio/Video panel 

The Audio/Video panel plays digitised recordings and assigns absolute time values of the 

recording to points on the EXMARaLDA timeline. When working with a single audio recording, 

that does not need to be re-aligned or the like, it is not  necessaryto display the Audio/Video 

panel, but if desired, then go to View > Audio/Video panel to have it displayed. 

Depending on whether it is an audio or video file, the panel will be shown with or without a 

display. The controls are almost identical in both cases. 

Controls: 

 

Normally, the Partitur-Editor will load the first audio/video file into the currently open 

transcription that has been marked as the “Referenced media file” in the “Meta Information” 

field. Should you want to use a different audio/video file that is linked to the transcription, select 

it on the drop-down list (1). 

Depending on whether an audio or video file has been opened, the control element (2) or the 

control element (3) will be activated. 

The “camera” (2) allows you to take a snapshot of single frames from the imported video file in 

the transcription in a .png format. In order to do this, click on the desired position (time) in the 

oscillogram and click on the “camera”.  

A pop-up window will then appear and ask you to choose a storage location for the image file. 
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Should you want to select a different storage location than the one, that the program 

automatically generated, click Browse…. Please note that the file ending “.png” may not be 

changed. 

If you have added a tier for links (tier type: “L(ink)”) in your transcription and placed the cursor 

into the event of this tier, the panel will offer the option to link the event to the newly generated 

“Snapshot”. Click on “Link to transcription”. A detailed description on linking files can be 

found in the reference under III. Panels > B. Link panel. 

 

The “scissors” (3) allow you to create “audio snippets” in the .wav format in a synchronised 

transcription linked to an audio file. Place the cursor in the event, for which you would like to 

create an audio snippet, and click on the “scissors”. A pop-up window will then appear and you 

will be asked to choose a name and a storage location for the audio file. 

Should you want to select a different name or storage location than the one that the program 

automatically generated, click Browse…. Please note that the file ending “.wav” may not be 

changed. 

If you've added a tier for links in your transcription and placed the cursor into the event of this 

tier, the panel will offer the option to link the event to the newly generated “Audio snippet”. 

Click on “Link to transcription”. A detailed description into linking files can be found in the 

Reference III. Panels > B. Link panel. Please note that the embedding of media files will not 

always run smoothly. A successful linking depends on: 

 the file format of the video (we recommend .avi or .mov),  

 the performance features of the video card of your computer, and  

 the Codec settings. 

At the bottom of the panel you will find a display of five different time specifications (4): start 

and end point of the audio/video file (grey), start and end point of the current event (green), and 

the length of the current event (black). 

Please consult the Audio and Video Support document available in the “Help&Support” 

section on the EXMARaLDA homepage (www.exmaralda.org) for more information regarding 

media formats and their support in EXMARaLDA. 

http://www.exmaralda.org/
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D. Quick media open panel 

The Quick Media Open Panel supports workflows in which many small audio files are meant to 

be transcribed or annotated. The principal setup is that you have one directory with WAV audio 

files and another directory with corresponding EXMARaLDA transcription files. You can 

specify those two directories as Media Directory and Transcription Directory, respectively, by 

clicking on the Browse… buttons. As soon as a media directory has been specified, all WAV 

audio files in that directory will be listed. Double clicking on any of those WAV files will create 

a new transcription with the same file name in the transcription directory (if it isn’t already there) 

and open it in the Partitur-Editor. 
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E. Praat panel 

The Praat panel plays digitised recordings and assigns absolute time values of the recording to 

points on the EXMARaLDA timeline. Should the Praat panel not appear on your screen, select 

View > Praat panel to have it displayed.  

 

Configuration of Windows and Praat for working with EXMARaLDA: 

 The current version of Praat can be found on http://www.praat.org. There, the current version 

of Sendpraat is available as well, on http://www.fon.hum.uva.nl/praat/sendpraat.html. 

 Download both programs and save them in the same directory (e.g. C:\Programs\Praat). Then 

create the path,  

1) by either entering the directory at Edit > Preferences… in the tab “Paths” under “Praat 

Directory” – at this location praat.exe and sendpraat.exe are also stored 

 

2) or by setting up the system path so that it contains the directory: Go to the Control Panel (e.g. 

in MS Windows XP Start > Control Panel > System > Advanced > Environment Variable). 

http://www.praat.org/
http://www.fon.hum.uva.nl/praat/sendpraat.html
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Please note: The Praat panel is currently only available in MS Windows. The use of the Praat 

panel requires the installation of the programs Praat and Sendpraat on your computer and the 

system path is pointing to the directory in which these programs are located. 

If you have completed this set up, you can start the program Praat directly in the Partitur-Editor 

by selecting “Start Praat”. This will take a few seconds. Wait until the program has started 

completely and then confirm the “Starting Praat...” dialog that will be displayed in the Partitur-

Editor with OK. 

 

If the meta information of the currently loaded transcription in the Partitur-Editor holds an audio 

file as a “Referenced File”, the Praat panel will automatically insert it as a file that should be 

loaded in Praat.  

The actual loading process of the file can be done by selecting “(Re)load”. Praat will now open 

a “Long Sound” window that will display an oscillogram of the audio file: 
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Rearrange this window on the screen, so that the musical score, the Praat panel and “Long 

Sound” window are simultaneously accessible. 

 

To synchronise the Praat oscillogram with your audio file, check the box “Synchronize” in the 

Praat panel. If you now click into an event in the musical score, the corresponding oscillogram 

(including the spectrogram) snippet will be displayed in Praat. 
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F. Annotation panel 

The Annotation panel allows the systematic and consistent adding of annotations to a 

transcription. The way it functions is comparable to the functionality of the virtual keyboard;t 

consists of a compilation of symbols that can be added into the musical score by clicking on 

them. Firstly, however, the annotation panel allows these symbols to be organised hierarchically 

(i.e. in a tree structure). Secondly, the user can define categories for the annotation panel freely 

(see How to use the annotation panel for more information). Thirdly, the annotation panel can 

“intelligently” adapt itself to the annotation task by hiding certain category sets in the hierarchy, 

depending on the current selection in the musical score. 

 

Show the annotation panel via View > Annotation panel. If available, the last annotation 

specification file will be loaded automatically. To load a new specification, click Open... and 

select the XML file in which the annotation specifications are defined. 

An annotation specification file consists of one or more annotation sets. In the annotation panel, 

an individual tab is opened for every annotation set. Every annotation set consists of categories 

within categories that are presented in the form of a tree. Categories can be equipped with a tag 

and a description; however, this is not a requirement. Tags are displayed in bold in the tree and 

descriptions of the selected category are displayed in the text window below the tree. Double 

clicking on a category with a tag adds the tag to the current cursor position in the musical score. 

 

http://www.exmaralda.org/pdf/How_to_Use_the_Annotation_Panel_EN.pdf


EXMARaLDA Partitur-Editor – Manual  IPA panell 

 
26 

G. IPA panel 

The IPA panel supplies the symbols of the International Phonetic Alphabet. The symbols are 

organised by parameters, such as manner or place of articulation. The panel consists of three 

tabs: 

Vowels and Suprasegmentals: 

 

Consonants: 
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Diacritics: 

 

A larger version of the symbol will be displayed in the lower part of the panel, when hovering 

over the symbol with the cursor. Clicking on the symbol adds it to the current cursor position in 

the musical score. 



EXMARaLDA Partitur-Editor – Manual  Multimodal panel 

 
28 

H.  Multimodal panel 

The Multimodal Panel supports the systematic annotation of multimodal aspects of speakers’ 

behaviour such as the orientation of the head or the direction of gaze at any point in time. As of 

version 1.6 (April 2017), the panel is still work in progress. So far, the tabs for ‘Head’ and 

‘Eyes’ are functional, the tabs for ‘Brows’ and ‘Mouth’ are still empty. A detailed 

documentation will be provided once the panel’s functionality has been completed. 
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I. SVG panel 

The SVG Panel supports the creation of links between the transcription and an SVG graphics 

file. Typically, the SVG file contains annotations of a diagram, and the links from the partitur 

specify the points in the interaction where elements of that diagram were created or modified.  

As of version 1.6 (April 2017), the panel is still work in progress. A detailed documentation will 

be provided once the panel’s functionality has been completed. 
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IV. FUNCTION REFERENCE 

A. File Menu 

 

 

File > New... 

(Shortcut CTRL + N on Windows, ⌘ + N on Mac) 

Creates a new transcription. The new transcription consists of a timeline with two time points, a 

speakertable containing a speaker X, as well as a “T” tier that both the speaker and the category 

“v” (for ‘verbal’), are assigned to. To change the attributes of the configured speaker, go to 

Transcription > Speakertable…. To change other tier properties, go to 

Tier > Tier properties…. The tier contains a default format. To change the format, select 

Format > Format tier... or Edit > Preferences…. 
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File > New from wizard... 

Opens an assistant to create a new transcription step by step. The individual steps that are also 

explained in the assistant are: 

1. Metadata: Specifying Meta Data. If you're managing a corpus with the Corpus-Manager, the 

metadatacan be imported from the COMA file. The recording and speaker information of the 

COMA file will also be imported with the following steps. 

2. Recording(s): Assignment of Audio and/or Video Files 

3. Speakers: Defines/definition of Speakers 

4. Tiers: Defines/definition of a pattern to generate tiers for every speaker. 

 

 

File > New from speakertable... 

Generates a new transcription from a speakertable and a stylesheet (see also APPENDIX C: 

EXMARALDA AND STYLESHEETS). The stylesheet that is specified in the user settings (see  

 

Edit > Preferences…) in “Speakertable to transcription” will be used. If there is no entry, a local 

stylesheet with a tier of the type “T” and the category “v” per speaker will be generated. 

First, the window to edit a speakertable is displayed. Insert the desired speakers and edit their 

properties (see Transcription > Speakertable…). The stylesheet will be applied by clicking 

OK. A new, empty musical score will be created with the tiers defined by the stylesheet. 
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File > New from timeline... 

Opens a window, in which the timeline of a new transcription can be divided with means of an 

audio or video file before starting the transcription. Thus, prominent events within the recording 

(i.e. speaker change in interviews, change in camera settings in television productions etc.) can 

be inserted as time points. This can greatly simplify the transcription with certain recording 

types. First, you are asked to select one or more audio or video files (see 

Transcription > Recordings…). Then, the following window will appear and the audio or 

video file selected in the previous step will be opened in a new player: 

 

The maximum interval length for the resulting intervals can be defined via the “Maximum 

interval length” check box. For instance, if the check box is activated, the value is set to five 

seconds, and you insert time points at 11.0 and 25.0 seconds, additional time points will 

automatically be inserted between these two time points, so that no intervals of more than 5 

seconds are created. Click the “Start” button to start playback of the recording. Then hit 

SPACE,whenever you want to insert a new time point (i.e. at a speaker change). The list will 

show the time points, which you have inserted. 

 

Play the recording to the end and click OK afterwards. A new, (empty) transcription will open in 

the Editor and the timeline will contain the values, which you have set, they will be then 

transformed into events and time points. 
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File > New from silence detection… 

This function will automatically detect and annotate silence in audio files. The idea behind this 

function is that the process of segmentation is done automatically and the user can focus solely 

on transcribing. It is useful for large amounts of material to be transcribed. First, you are asked to 

select one audio .wav file andother audio or video files if desired/needed (see 

Transcription > Recordings…). This function only works with .wav files, but other media 

types can also be selected. After you have chosen the media files, the following window will 

open: 

 

Although you can change the function’s settings, the default values are considered to be “best 

practice”. If your recording does, however, exhibit significant background noise or significantly 

long/short non-silence intervals, you may adjust the parameters. 

 Threshhold Parameters: defines an interval on the ordinate, between and below which any 

noise is treated as silence. 

 Start: scales up the value to raise the interval’s starting point. The higher this value, 

the more average energy (sound) is required to be classified as non-silence. You 

should increase this value if your recording exhibits significant background noise. 

 End: scales up the value to raise the interval’s end point. The higher you set this 

value, the more average energy (sound) is required to be classified as non-silence. 

Please make sure that this value does not fall below the value of the starting point. 

 Step: defines the rate, by which the interval will be scanned, regarding the present 

value of average energy. The lower the steps, the more frequently the interval will be 

scanned for sound. 
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 Minimum Pause Length: defines the minimum duration of silence to be annotated as a pause. 

 Start: The higher the value is set, the longer must a stretch of silence be, to be 

annotated as a pause. Any stretch of silence below the set start value will not be 

considered as pause. You might increase this value if the speech rate is slow. 

 End: This value does not set the maximum length of a stretch of silence to be treated 

as a pause, but the interval size in which the silence will be scanned (cf. step). Please 

make sure that this value does not fall below the value of the starting point. 

 Step: Defines the rate of how frequently the set interval will be scanned for silence. 

 Iterations: Notifies the user of the number of iterations required to calculate the best result. 

The higher the number of iterations, the more calculation time will be required. 

 Score Parameters: Defines the ideal length of a non-silent interval. The values (seconds) set in 

T2 and T3 respectively represent the start and end point of the ideal non-silent interval (e.g. 

between 3 and 7 seconds). The values set in T1 and T4 represent the limits under/over which 

an interval is either too short (e.g. every interval under one second) or too long (e.g. every 

interval over 12 seconds) and thus inacceptable in terms of the algorithm.  

 Smoothing Parameters: Specifies two settings created to reduce the possibility of false or 

inaccurate silence detection  

 Minimum length of interval between pauses: Specifies how long a stretch of non-

silence must be at least to be followed by a pause. 

 Shrink Amount: All detected stretches of silences will be shortened by the set value 

(seconds) to minimise the possibility of early sound truncation. This is especially 

useful if the sound of the onset or coda drops below the threshold parameter. 

When you click OK afterwards, the detection will take some time and a new, (empty) 

transcription will open in the Editor that will contain the annotation of the length of the silence in 

a “sil” tier.  

 

If there wasn’t a .wav file selected in the beginning, you will get a warning instead: 

 

 

File > Open... 
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(Shortcut CTRL + O on Windows, ⌘ + O on Mac) 

 

Opens a saved transcription. A standard file window of the system will be displayed, as well as 

all files ending in “.exb” and “.xml”. Normally, the start directory is the one that was used for the 

last saved transcription/file. Additionally, information on the currently selected file can be 

displayed on the right.  

If the file is an EXMARaLDA basic transcription, its meta information will be displayed. 

Otherwise, a notification, stating that it is not an EXMARaLDA basic transcription, will appear. 

Select Show Info to see information of the selected file. Activate the option “Auto” to display 

information for every selected file automatically. 

Select the file to be opened and click Open. Thereafter, the entire musical score needs to be 

formatted. For larger transcriptions, this may take a few seconds. To open an associated format 

table, see Format > Open format table.... 

Hint: If you would like to work on two transcriptions simultaneously, open the EXMARaLDA 

Partitur-Editor twice. (Do not use File > New..., for the opening of a new file closes the current 

one!). 

 

File > Restore 

Opens the last saved version of the currently opened transcription. All changes since the last save 

will be discarded. This menu item will only be activated if a last saved version is available. 
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File > Save 

(Shortcut: CTRL + S on Windows, ⌘ + S on Mac)  

Saves the currently opened transcription under its set name. If the transcription does not have a 

name yet, the caption bar showing the name “untitled.exb”is shown automatically in the “Save 

as...” window (see below). 

File > Save as... 

Saves the currently opened transcription under a new name. A standard file window of the 

system will be displayed as well as all files ending in “.exb” and “.xml”. 

 

Normally, the start directory is the one that was used for the last save. Select the directory in 

which you would like to save the transcription, enter a name (the suffix “.exb” will be added 

automatically if you do not define one) and click Save. In order to save the corresponding format 

table, activate the option “Save formats”. 

 

File > Error list... 

Opens a window showing an error list (see graphic on the next page). To open an existing error 

list, click on the “file” symbol to open a standard file window of the system and choose the 

desired error list. 

It is written by the functions “Check for segmentation errors” and “Check for Structure 

Errors” of the Corpus Manager, among others. (Consult COMA Documentation for more 

information) 
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An error list is an XML file that points to specific positions in the existent transcription files, as 

presented in the graphic below: 

<?xml version=„1.0“ encoding=„UTF-8“?> 

<error-list> 

    <errors> 
        <error 

            file=„ENDFAS/Bilingual/Sezen_Aksu/EFE07dt_Sez_b_0408_f_100295/EFE07dt_Sez_b_0408_2_ENF.xml“ 

            tier=„TIE16“ start=„T41“ done=„no“>Annotation mismatch</error> 
        <error 

            file=„ENDFAS/Mono_tk/Guznur_Bayar/Selbtk_Guz_m_0222_t_121092/Selbtk_Guz_m_0222_1_ENF.xml“ 

            tier=„TIE11“ start=„T7“ done=„no“>Annotation mismatch</error> 
        <!-- [...] --> 

    </errors> 

</error-list> 

The error list can be used, for exaample, to comfortably edit systematic inconsistencies in the 

corpus. Double clicking on a list entry opens the corresponding transcription, should it not be 

open already, and places the cursor on the position in question.Entries that have already been 

visited are displayed in grey instead of black. 

 

File > Page setup… 

Opens a window to specify the side measurements to be used in the RTF output, or when 

printing. Appearance and functionality vary greatly, depending on the operating system. 

However, they comply with the appearance of the standard window. 
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File > Print…  

(Shortcut: CTRL + P on Windows, ⌘ + P on Mac) 

 

Opens a window to print the transcription. Appearance and functionality vary greatly depending 

on the operating system. However, they comply with the appearance of the standard window for 

printing. 
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File > Output...  

Opens a window for the output of the transcription in a format for presentation, used for the 

display in a browser or the integration in a word processing document (i.e. MS Word). 

 

 Range: allows you to define whether the output of the entire transcription is desired, or just a 

part of it. More specifically: 

 Everything: Issues the entire transcription 

 All visible tiers: Issues all visible tiers that have not been hidden via Tier > Hide tier 

 Selection: Issues the current selection in the musical score. 

 The drop-down list offers different formats: 

 

1. HTML Partitur (*.html): Select the directory, in which you would like to save the HTML 

output, and enter a name (the suffix “.html” will be added automatically if you do not define 

one). Select “Frames”, if you would like the transcription's existing links to be realised as 

hyperlinks in a separate frame. Select “No frames” if the transcription does not contain links, or 

if the hyperlinks should be opened in a new window. Then click Save to implement the output. 

Thereafter, the file can be opened in any browser. The meta information and speakertable output 

can be parametrised via  

 



EXMARaLDA Partitur-Editor – Manual  File Menu 

 
40 

Edit > Preferences… > Stylesheets as “Head to HTML”. See also: APPENDIX C: 

EXMARALDA AND STYLESHEETS. 

 

2. HTML Partitur + HTML5 Video/Audio (*.html): This option creates an HTML musical score 

(as in option 1). In addition, this output format integrates an audio and video player in the 

HTML5 file, allowing sections of the recording to be played by clicking on them. 

3. RTF Partitur (*.rtf): Select the directory, in which you would like to save the RTF output, and 

enter a name (the suffix “.rtf” will be added automatically, if you do not define one). Then click 

Save to implement the output. Thereafter, the file can be opened and edited in any word 

processor that can read RTF files (especially MS Word). 

4. HTML Segment Chain List (*.html): This option creates an HTML file in which the speaker 

contribution is organised in a segment chain list. Segment chains are defined as interrelated 

events in a transcription tier. This form of output is similar to the classic line notation used in 

conversation analysis, in theatre scripts or in printed interviews, among others. 

 

5. HTML Segment chain list + HTML5 Audio (*.html): This option creates an HTML segment 

chain list (as in option 4). In addition, it integrates an HTML 5 Audio Player that allows sections 

of the recording to be played by clicking on them. 

6. GAT Transcript (*.txt): exports a text file with a layout similar to the layout specifications of 

GAT transcription convention (Gesprächsanalytisches Transkriptionssystem: GAT, Selting et al. 

1998). 
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Requirement for this output option is that the transcription can be segmented with the GAT 

segmentation algorithm, i.e. the GAT transcription symbols have been used according to 

convention (see also APPENDIX B: SEGMENTATION ALGORITHMS). If segmentation 

errors have been made, an error message will appear and no output file will be created. 

 

7. GAT transcript + HTML5 Audio: This option creates an HTML file with a layout similar to 

the layout specifications of GAT transcription convention. In addition, you can also listen to the 

audio linked to the transcription. To define the starting point of the audio, click on the play 

button at the beginning of a new line.  

 

8. Simple text output (*.txt): This option creates a plain text file that can be opened and edited in 

any text editor.  



EXMARaLDA Partitur-Editor – Manual  File Menu 

 
42 

9. Free Stylesheet Transformation (*.html): Uses a stylesheet on a transcription (see also VIII) 

that is selected via  

 

Edit > Preferences… in the tab “Stylesheets” under “Free stylesheet visualisation”. 

10. HTML Partitur + Flash Player (*.html): This option creates an HTML musical score (as in 

option 1). In addition, it integrates a Flash Player that allows sections of the recording to be 

played by clicking on them. 

 

Requirements for the use of this option are: 

 that the transcription is linked to an MP3 file (via Transcription > Recordings…). Other 

audio or video recordings will not be played by the Flash Player. If there is no link to an MP3 

file, an error message will appear and the HTML musical score will not be created. 

 that the transcription is at least partially aligned. Hence, some time points on the timeline need 

to be equipped with absolute time values that refer to the recording. 

Take note that this option creates three additional files in the same directory, in addition to the 

HTML file that contains the musical score: 

 

The files “player.swf” and “seeker.swf” are Flash applications that serve the purpose of playing 

the recording. The file “seeker.html” is designed to integrate the Flash components into the 

musical score. 

11. SVG Partitur (*.html): SVG means “Scalable Vector Graphics” and is an XML-based format 

to describe vector graphics. Vector graphics can be edited in graphic software (i.e. Corel Draw, 

Adobe Illustrator). Furthermore, they can be used as high-quality print templates, due to the fact 
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that scaling does not damage sharpness or definition. Thus, they are probably the best solution to 

integrate musical scores into printed publications. 

If the Partitur-Editor creates SVG files from a transcription, it writes an SVG file for every 

musical score section that has been created due to a line break. These are saved in a shared 

directory and compiled in a superordinate HTML file, which refers to the SVG files in such a 

way, that they can be viewed with a browser capable of displaying SVG files. 

When choosing this output option, the following panel is shown on the side of the file dialog: 

 

In it, the following parameters for the output can be set: 

 Subdirectory for SVG files: sets the name for the directory in which the SVG files are 

supposed to be saved. This directory will be created in the same folder as the superordinate 

HTML file, if it is not available yet. 

 Base filename for SVG files: sets the base file name for the SVG files. The full name of an 

SVG file then consist of this base file name, followed by the number of the musical score 

section, followed by the suffix “.svg”. 

The above mentioned settings create files and directories as follows: 

 

 

 

 

The file “SVG-output.html” can be opened with any browser (e. g. Internet Explorer, Firefox) 

that possesses a suitable SVG plug-in (e. g. of Adobe or Corel). However, you can also open the 

individual SVG files with a suitable software (e. g. Adobe Illustrator) and edit them or save them 

in a different graphic format (e. g. WMF, which can be pasted into a Word document), if desired. 

12. XML Partitur (*.html): This option creates an XML-coded version of the musical score 

representation (“Interlinear Text”) of the current transcription. The settings chosen under 

Edit > Partitur preferences… and those of the current format table (see also 

Format > Edit format table...) will be used. The XML coding is compliant with the DTD 

(“interlinear-text.dtd”). The current version is available in the “Download” area of the 

EXMARaLDA Homepage (www.exmaralda.org). We assume that this function is not of interest 

Filename 
Subdirectory for SVG files 

Base filename 

http://www.exmaralda.org/
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to most users. It is intended for users that plan on developing their own visualisation (containing 

XSL stylesheets and the like). 

13. HTML Segment Chain List + Flash Player (*.html): This option creates an HTML segment 

chain list (as in option 5). In addition, it integrates a Flash Player that allows to listen to the 

sections of the recording, by simply clicking on a position in the list. For further explanation, see 

APPENDIX C: EXMARALDA AND STYLESHEETS. 

 

 

File > Import 

Opens a window for import in other formats. The drop-down list offers different formats: 

 

1. ELAN Annotation File (*.eaf): imports a transcription created in ELAN (EUDICO Linguistic 

Annotator). Select the file to be imported and click Open (normally the file ending is “.eaf”). 

After the conversion, a “Cleanup-Dialog” will allow you to clean the transcription up according 

to certain criteria (see Transcription > Clean up...). Thereafter, the transcription will appear as 

a musical score in the Editor. 

2. PRAAT Textgrid (*.textGrid): Imports a transcription created in Praat. Select the TextGrid 

you would like to import and click Open. Thereafter, the transcription will appear as a musical 

score in the Editor. Take into account that the Editor expects a “regular” TextGrid for the import, 

and not a “short” TextGrid. Please note that only tiers of the EXMARaLDA convention types 

“T(ranscription)”, “A(nnotation)” and “D(escription)” can be transferred correctly. In order to 

ensure an accurate transfer of your tier information, you need to manually adjust your TextGrid 

file as follows: 

Open your TextGrid file and change all occurrences of the attribute “name” that appear under 

“item []” in conformity with the sequence “speaker|tier_type|tier_category” to their 

corresponding values.  
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3. FOLKER Transcription (*.flk, *.fln): imports a transcription created in FOLKER (the FOLK-

Editor of the IDS Mannheim. 

4. CHAT Transcript (*.cha): imports files that have been created with the CLAN Editor of the 

CHILDES System. 

5. Transcriber file (*.trs): imports a file created with the Transcriber software (for more 

information visit: http://trans.sourceforge.net/en/presentation.php). 

6. Winpitch file (*.alg, *.xml): imports a file created with the Winpitch software 

(http://www.winpitch.com/). 

7. Anvil annotation file (*.anvil): imports all tracks created in Anvil into the musical score. 

Remember to check the tier properties since the Partitur Editor automatically assigns them the 

type “T(ranscription)”. In case the window “Stratify Tier” is displayed, please select the 

stratification method you want to employ on the overlapping events. 

8. TASX Annotation File (*.xml): Imports a file in TASX format. After the import, a window to 

clean the transcription up is displayed (see Transcription > Clean up...). Under certain 

circumstances, this window is displayed thereafter: 

 

This dialog states that some tiers contain events that overlap each other within the tier (“the tier 

is not stratified”). In order to display transcriptions as a musical score, overlapping events within 

a tier may not exist. Choose one of the following options: 

 Stratify by deletion: deletes one (the second) of two overlapping events 

 Stratify by distribution: distributes one (the second) of two overlapping events into a new 

tier. 

http://trans.sourceforge.net/en/presentation.php
http://www.winpitch.com/
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Subsequently, it will appear in the musical score in the Editor. 

9. Annotation Graph File (*.xml): Imports a file in the ATLAS-Interchange format, Level 0. The 

format can be used as an exchange format with a number of other tools (ANVIL, Transformer, 

MAVVissta, etc.). For this, see: 

T.Schmidt, S. Duncan, O. Ehmer, J. Hoyt, M. Kipp, D. Loehr, M. Magnusson, T. Rose & H. 

Sloetjes (2008): An exchange format for multimodal annotations. In: Proceedings of the 

Language Resource and Evaluation Conference 2008, Marrakech, Paris: ELRA. 

10. Simple EXMARaLDA text file (*.txt): A Simple EXMARaLDA file is a transcription in .txt 

format that has been created according to the “Simple EXMARaLDA” specifications. You can 

find these specifications in APPENDIX A: SIMPLE EXMARaLDA Conventions. If you have 

created a transcription according to these specifications in a text editor or a word processing 

software and saved it as “plain text” (either coded as Unicode or a standard coding specified by 

the system), you can import a text file to the Partitur-Editor. For this, search for the file and 

select the suitable coding in the drop-down list on the side. Then click Open. 

 

If the import is successful, a musical score representation will be visible in the transcription. If 

the import fails, an error message of the following kind will appear: 

 

The first line contains the line number of the original file, in which the error occurred. The 

second line contains the type of error (here: “no speaker separator”, hence the speaker 

abbreviation was not ended in a colon) and the third line presents the entire line containing the 

error. Open the text file in a text Editor, fix the error, save the file and reattempt the file importt. 

11. Rio de Janeiro style text transcription (*.txt): This is an importer written for a specific project 

in Brasil. It is maintained for backwards compatibility reasons but not meant to be used outside 

the project for which it was written. 

12. Plain text file: imports any text file into a single tier in the musical score. The window 

presents options as to according to which rule the content of the text file will be distributed into 

the events of the tier: 
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 This is illustrated in the following text file example: 

 

 The option “Split at paragraphs” creates a new event for every line of the original file: 

 

 The option “Split at non-word characters” creates a new event for every row of alphabetic 

signs (i.e. for every “word”) of the original file: 

 

 The option “Split at regular expression” allows the input of any desired expression, 

according to which text will be distributed into the events. For instance, the expression [\.\?] 

for the text above would deliver the following result: 

 

13. Audacity Label File: imports a text file of text labels created in Audacity into a single tier in 

the musical score. Everything that has not been labelled into a “[pause]” tier. 

14. Tree Tagger Output: imports a text file that contains Part-Of-Speech-Annotation, hence a 

word per line, as well as separated by tabs according to the Tree Tagger format 

(http://www.ims.uni-stuttgart.de/projekte/corplex/TreeTagger/) i.e.: 

http://www.ims.uni-stuttgart.de/projekte/corplex/TreeTagger/
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The data will be imported into two or three tiers (depending on whether the initial file only 

contains POS-Tags, or lemmas as well). One tier is used for the text (the words), the second for 

the annotation (the POS-Tags) and, if necessary, a tier for lemmas. The tiers will be assigned to a 

dummy speaker “X”. Every word is placed in a separate event: 

 

15. TEI file: imports a transcription that is coded according to the guidelines of the Text 

Encoding Initiative (TEI) in XML (see Schmidt, Th. 2005: Time based data models and the TEI 

Guidelines for Transcriptions of Speech. In: Arbeiten zur Mehrsprachigkeit [Working Papers in 

Multilingualism], Series B.). Select the transcription to be imported and click Open. After the 

conversion, a “Cleanup-Dialog” will allow you to clean the transcription up according to certain 

criteria (see Transcription > Clean up...). Thereafter, the transcription will appear as a musical 

score in the Editor. 

16. Import via XSL stylesheet: imports an XML file in any desired format by applying a suitable 

XSL stylesheet that transforms the original format into an EXMARaLDA basic transcription. 

After selecting the file to be imported, you will be asked to specify such an XSL stylesheet. The 

name of the stylesheet will be saved for the next import. 

17. HIAT-DOS file: “imports” HIAT-DOS files. Please note that the quotation marks around the 

word “import” are supposed to raise awareness to an important circumstance: 

 In essence, it is not possible to find a perfect EXMARaLDA correspondence for a given 

HIAT-DOS data. The “import” function only supplies a rough version that normally needs to 

be edited manually afterwards. 



EXMARaLDA Partitur-Editor – Manual  File Menu 

 
49 

 The function was developed for HIAT-DOS files at the Research Centre “Multilingualism” of 

the University of Hamburg. This explains the replacement rules for Scandinavian special 

characters, for example. The HIAT-DOS files created at the Research Centre neither work 

with intonation tiers, nor with underlining. Therefore, we have no experience as to what 

happens to these elements when “imported”. 

 

In order to “import” a HIAT-DOS file, fill in the following field: 

 Transcript file: This is the file with the actual transcription text. Normally, HIAT-DOS gives 

these files the file ending “.dat”. Click Browse... to look for the file with the file dialog. 

(Hint: The “import” result is a lot better, when using HIAT-DOS files that do not contain line 

breaks yet.) 

 Info file: This is the file that contains information from the transcription head. Normally, 

HIAT-DOS gives these files the file ending “.inf”. Click Browse... to look for the file with 

the file dialog. Even if no file is selected, the “import” can be carried out – the transcription 

head will simply remain blank. 

 Speakers file: This is the file that contains the names and abbreviations of the speakers. 

Normally, HIAT-DOS gives these files the file ending “.sig”. Click Browse... to look for the 

file with the file dialog. Even if no file is selected, the “import” can be carried out – the 

speakertable will be generated automatically, speaker abbreviations and names can be added 

afterwards in the Partitur-Editor. 

 Method for calculating synchronisation points: When calculating the synchronisation 

points, either only the left, or both the left and the right boundaries of entries in the HIAT-

DOS tiers can be used. Reliable synchronisation points are mostly the left boundaries. 

However, adding the right tiers may minimise the editing effort afterwards. 

 Remove holes (after manual wrap): This (time-consuming) method is recommended if you 

would like to “import” a HIAT-DOS file with an afterwards edited line break. 

 Replace symbols: HIAT-DOS uses a non-ANSI-compliant coding method for German 

special characters. These signs are replaced by default (as well as some substitute signs for 
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Scandinavian special characters). If you would like to change the characters that should be 

replaced, click Change..., to get the following dialog: 

 

This list contains all instances which were replaced, as glyph, followed by the corresponding 

decimal Unicode number. In order to delete a single replacement, select it in the list and click 

Remove. In order to delete the entire list, click Remove all. To only replace the German special 

characters and “ß”, click Standard. In order to add a replacement, enter the decimal Unicode 

into the fields “To be replaced” and “Replacement” and click Add!. Exit the dialog with OK, 

to save the changes. 

18. Phon transcription: imports files that have been created with the Phon Editor of the 

Phonbank-System. 

19. Transana XML file: in order to import a Transana XML file, please note that the applicable 

XML file can only be imported if it was created in Transana via File > Save Document As 

XML. Files ending in “.tra” cannot be imported. After the XML was imported, a musical score is 

generated which automatically attributes three tiers types – “Transcription (v)”, “Description 

(nv)”, “Annotation (de)” – to each speaker. 

20. ExSync file: imports files that are read from syncWRITER output (“ExSync Data”). 

21. TCF file: imports an XML document where, depending on the number of annotation layers 

stored, at least two tiers of the type “Transcription” are created. Any further annotations stored in 

the document generate additional tiers of the Type “Annotation”. 

 

File > Export  

Opens a window for the export into different formats. The drop-down list “Save as type” offers 

different formats: 
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1. ELAN Annotation File: The exported file can be opened and edited in ELAN. Please note that 

such an export is only useful, if at least some of the points on the timeline have been equipped 

with absolute time values (non-existing times will be interpolated). Furthermore, you should 

have specified the underlying media file (see Transcription > Recordings…). 

2. PRAAT Textgrid: The exported file can be opened and edited in Praat. Please note that such 

an export is only useful if at least some of the points on the timeline have been equipped with 

absolute time values (non-existing times will be interpolated). 

3. FOLKER Transcription: Exports the current transcription into the format of the FOLKER 

Editor. Take note that for every speaker only the first tier of type “T(ranscription)” will be taken 

into account. Contents of annotation and description tiers will thus be lost during export. 

4. TASX Annotation File: The exported file can be opened and edited in the TASX-Annotator. 

Please note that such an export is only useful, if at least some of the points on the timeline have 

been equipped with absolute time values (non-existing times will be interpolated). 

5. Annotation Graph File: Exports the current transcription into the Atlas Interchange format, 

Level 0. The format can be used as an exchange format with a number of other tools (ANVIL, 

Transformer, MAVVissta, etc.). For this, see: 

T. Schmidt, S. Duncan, O. Ehmer, J. Hoyt, M. Kipp, D. Loehr, M. Magnusson, T. Rose & H. 

Sloetjes (2008): An exchange format for multimodal annotations. In: Proceedings of the 

Language Resource and Evaluation Conference 2008, Marrakech, Paris: ELRA. 

6. TEI file: exports a file that is coded according to the specifications of the Text Encoding 

Initiative (TEI) in XML. Different export options are offered: 

 Generic: In this option, a TEI file is created that transfers the text into events without 

alterations. This is the most basic form of exporting. It results in practical data for most 

results. 

 Based on Modena method: This option is used in a project at the University of Modena. 

Requirement for a practical result is the compliance with the conventions in reference to the 

event text.  

 Based on AZM method: see Schmidt, Th. 2005: Time based data models and the TEI 

Guidelines for Transcriptions of Speech. Arbeiten zur Mehrsprachigkeit [Working Papers in 

Multilingualism], Serie B. 

 Based on HIAT segmentation: this variation contains the TEI document mark-up for units of 

the HIAT system (words, pauses, non-phonological items, utterances etc.). The export 

requires a successful segmentation according to HIAT. If the segmentation fails, an error 

message will appear. 
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7. TCF file: exports a transcription in an XML-based format that can be opened and edited with 

the automatic annotation tool WebLicht. It contains an XML header, a meta data section, and a 

TextCorpus section including the linguistic data’s language specification, tokens and sentences. 

To define the language specification of your TCF file, you can either choose from the drop-down 

list or change the attribute in the XML file according to its ISO 639-1 code.  

8. CHAT transcript: Exports a file in the CHAT format that can be opened with the CLAN-

Editor of the CHILDES-System. 

 

Different variants are offered: 

 Based on CHAT segmentation: The requirement for this type of output is that the 

transcription can be segmented with the CHAT algorithm, i.e. the CHAT transcription 

symbols have been used according to the convention (see also APPENDIX B: 

SEGMENTATION ALGORITHMS). If segmentation errors have been made, an error 

message will appear and no output file will be created. 

 Based on HIAT segmentation: The requirement for this type of output is that the 

transcription can be segmented with the HIAT algorithm, i.e. the HIAT transcription symbols 

have been used according to the convention (see also APPENDIX B: SEGMENTATION 

ALGORITHMS). If segmentation errors have been made, an error message will appear and 

no output file will be created. 

 Based on events: This option does not use a segmentation algorithm, but single events in tiers 

of type “T(ranscription)” are transformed into CHAT utterances. 

9. Audacity Label File: Exports a text file that can be read in Audacity. 

10. Tree Tagger Output: This export format creates a text file in which each event corresponds to 

a single line. Note, that the export is not bound to the timeline but to the utterance sequence of 

each tier. 

11. F4 transcript: exports the transcription tiers into an .rtf file which thereinafter can be opened 

and edited in MAXQDA. 
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File > Exit 

Closes the current transcription and exits the Partitur-Editor.  

If the changes have not been saved, you will be asked, whether you would like to save the 

changes. 
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B. Edit Menu 

 

 

 

Edit > Undo 

The “Undo” feature was introduced in version 1.5. It reverses the last action that has been 

carried out. The action itself is named in the menu item (e.g. “Edit event”). Up to 20 actions are 

saved, which can be undone again. In the case of some actions, the musical score needs to be 

reformatted after calling up the menu item. This can take a few seconds in larger transcriptions. 

 

Edit > Copy 

(Shortcut: CTRL + C on Windows, ⌘ + C on Mac) 

Copies a selected text into the clipboard. From there, the text can be copied into any other 

application that has a “Paste” function. Texts in different tiers are separated by Enter.  

If the selection includes all tiers (see also second example below), a RTF representation of the 

specific section of the musical score is copied into the clipboard – instead of text only. This can 

be copied as a musical score into RTF-enabled applications (esp. WORD) by using “Paste” 
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Examples: 

 

Edit > Paste 

(Shortcut: CTRL + V on Windows, ⌘ + V on Mac) 

Inserts the text from the clipboard at the current cursor position. 

 

Edit > Cut 

(Shortcut: CTRL + X on Windows, ⌘ + X on Mac) 

Cuts the currently selected text and puts it into the clipboard. 

 

Edit > Search in events... 

Opens a dialog in order to search events for specific characters or character strings: 

Selection in the Editor  Content of the clipboard after “Copy text” 

 
 

Stimmt ja gar nicht. 

 
 

RTF representation of the selection of 

the musical score 

 

fällst mir 
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The character or string to be searched for is entered into the field “Search string”. In order to 

enter characters that are not available on the keyboard, you can open a virtual keyboard by using 

the button below on the left. 

“Search area” indicates the tiers that are to be searched. When opening the search dialog, these 

include, by default, all the tiers that are not hidden. In order to change the search area, click 

Search area: You will get the following dialog: 

 

The tiers that are not to be searched are listed on the left (“Unselected tiers”). The tiers that are 

to be searched are listed on the right (“Selected tiers”). Click on the single arrow buttons (> or 

<), in order to transfer specific tiers from one list to the other. Click on the double arrow buttons 

(>> or <<), in order to transfer all tiers from one list to the other. Close the window by clicking 

OK (only then will the changes be saved). 
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Use “Case sensitive search” to determine whether the use of upper or lower case initial letters 

should be considered as well (If this option is ticked, the use of upper and lower case initial 

letters will be considered). 

Click Search in order to run the search according to the defined parameters. The result of the 

search is given in the “Result” list. The found occurrences are highlighted in red and are put in a 

frame. 

In order to jump to a search result in the musical score, mark the result in the list and click  

Go to. In order to save all the search results in a text file, click Save as.... You will then be 

asked to name the file. Afterwards, you will then be able to open this file with any Unicode 

enabled text Editor. In order to close the search window, click Close. 

 

Edit > Find next... 

Jumps to the next search result in a search conducted with Edit > Search in events.... 

 

Edit > Replace in events... 

Opens a dialog that allows searching and replacing specific characters or character strings in 

events. 

 

The character or string to be searched for is entered into the field “Search string”. The character 

or string to be replaced is entered into the field “Replace string”. The determination of the 

Search area is done as described above (Edit > Search in events...).  
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Searching and replacing always considers the use of capital and small initial letters. In order to 

jump to a search result in the musical score, mark the result in the list and click Go to. 

In order to replace specific search results, first click Search. The results are listed in the 

“Result” list. In order to replace a specific result, mark it and click Replace. 

In order to replace all of the results click Replace all. Please note: This procedure cannot be 

undone! It is therefore advisable to save the transcription before using the replace function, in 

order to be able to reverse the process by using File > Restore (see above). 

 

Edit > Go to... 

By using the “Go to...” dialog, you can navigate to specific positions in the musical score. You 

can either specify an absolute time value (“Go to time”) or a position on the timeline “Go to 

timeline item”.  

 

By using the button Apply, you can jump to the specified position. Clicking OK also closes the 

dialog. 

 

Edit > EXAKT search... 

Opens a dialog for an EXAKT search: 

 

To see how the EXAKT search works, see Working with EXAKT. 
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Edit > Selection 

This submenu includes features that concern a previously selected part (“Selection”) of the 

transcription. In essence, this selection is made up of all displayed tiers. It can be reduced in two 

ways (which can also be combined): Entire tiers can be removed from the selection by 

dismissing them with the function Tier > Hide tier. If only specific time points are to be 

selected, mark the section on the timeline by using the mouse (click and drag). 

Example: 

 Initial transcription: The selection includes all time points of the seven tiers. 

 

 After hiding the non-verbal tiers and translation tiers: The selection includes all time points of 

the remaining three tiers. 

 

 After selecting a section on the timeline: The selection only includes the time points 4 to 6 of 

the three remaining tiers. 

 

The second step is to determine what will happen to the previously made selection. The Partitur-

Editor offers five different options for this: 

Edit > Selection > Selection to new 

Turns the current selection into a new transcription. For example third option named above: 

 

Edit > Selection > Left part to new 

Divides the transcription at the current cursor position or selection and turns the part left to the 

position into a new transcription. 

 



EXMARaLDA Partitur-Editor – Manual  Edit Menu 

 
60 

Edit > Selection > Right part to new 

Divides the transcription at the current cursor position or selection and turns the part right to the 

position into a new transcription. 

Edit > Selection > Selection to RTF 

Turns the current selection into an RTF musical score output (see File > Output...). 

Edit > Selection > Selection to HTML 

Turns the current selection into an HTML musical score output (see File > Output...). 

Edit > Selection > Print selection… 

Prints the current selection (see also File > Print…). 

 

Edit > Preferences… 

Opens a window to determine user-defined settings. To reset all preferences, click the Reset… 

button.  

 

For the changes to take full effect, the Partitur Editor will automatically restart if you click 

choose Yes. 
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The preference menu is divided into eight subitems. 

1. Fonts: The tab “Fonts” allows the assignment of default fonts and methods for underlining: 

 The “Default tier font” is the standard font, which is automatically assigned to new tiers or 

into which an opened transcription is formatted. 

 The “Default general purpose font” is the font which is used by default for the characters on 

the virtual keyboard, as well as for the text box above the musical score. For this you should 

pick a font that covers as many Unicode areas as possible. Currently, the best font for this 

purpose is “Arial Unicode MS”. A freeware alternative, even though it is still incomplete in 

some Unicode areas, is “Gentium”, which was developed by the “Summer Institute of 

Linguistics” (see also: http://www.sil.org/~gaultney/gentium/). 

Click Change… in order to open a window in which you can choose a different font.  

 

In order to save your changes, click OK. (The settings will be saved when closing the Editor and 

are loaded again at the next start.) 

There are two options for selecting the method of underlining: 

 The option Underline in a separate tier of category […] underlines a selected passage in an 

annotation tier below the respective tier. This corresponds to the method recommended in the 

HIAT handbook for the marking of special intonations. 

 The option Underline in the same tier (using a diacritic) results in the underlining of a 

selected text in the same tier by diacritics after every sign.  

For particulars about underlining, see also Format > Underline. 

2. Stylesheets: Different stylesheets are defined in the tab “Stylesheets” (see also VIII). 

http://www.sil.org/~gaultney/gentium/
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In particular, these are: 

 Head to HTML: The stylesheet that is used in the HTML output to display meta information 

and the speakertable. The entry can be left empty; an internal default stylesheet will be used. 

 Speakertable to transcription: The stylesheet that is found under the menu item File > New 

from speakertable... generates a new transcription from a speakertable. The entry can be 

left empty; an internal default stylesheet will be used. 

 Transcription to format table: The stylesheet that is found under the menu item 

Format > Apply stylesheet is used to format the transcription. The entry can be left empty; 

an internal default stylesheet will be used. 

 Free stylesheet visualization: This stylesheet is found under the menu item 

File > Output... and choose “Free stylesheet visualization” from the dropdown menu.  

 HIAT utterance list to HTML: This stylesheet is found in the tab “Segmentation”. 

In order to change the entries, click on the respective “Change...” button. A file window will 

allow you to select the particular stylesheet.  

3. Segmentation: In the tab “Segmentation” you can define settings for segmentation. These 

settings affect several menu items of the “Transcription” menu. In “Preferred Segmentation” 

you can set your preferred segmentation algorithm. In “Finite State Machines” you can define 

custom Finite State Machines for the segmentation algorithms.  
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In particular, these are: 

 GENERIC: The finite state machine that describes the segmentation algorithm for GENERIC 

files. These are used for various functions under “Segmentation” and “GENERIC” (see 

Section H Format Menu of the function references and APPENDIX B: SEGMENTATION 

ALGORITHMS). 

 HIAT: The finite state machine that describes the segmentation algorithm for HIAT files. 

These are used for various functions under “Segmentation” and “HIAT Segmentation” (see 

Section H Format Menu of the function references and APPENDIX B: SEGMENTATION 

ALGORITHMS). 

 DIDA: The finite state machine that describes the segmentation algorithm for DIDA files. 

These are used for various functions under “Segmentation” and “DIDA Segmentation” (see 

Section H Format Menu of the function references and APPENDIX B: SEGMENTATION 

ALGORITHMS). 

 GAT: The finite state machine that describes the segmentation algorithm for GAT files. These 

are used for various functions under “Segmentation” and “GAT Segmentation” (see 

Section H Format Menu of the function references and APPENDIX B: SEGMENTATION 

ALGORITHMS). 

 cGAT_MINIMAL: The finite state machine that describes the segmentation algorithm for 

cGAT_MINIMAL files. These are used for various functions under “Segmentation” and 

“cGAT_MINIMAL Segmentation” (see Section H Format Menu of the function references 

and APPENDIX B: SEGMENTATION ALGORITHMS). 

 CHAT: The finite state machine that describes the segmentation algorithm for CHAT files. 

These are used for various functions under “Segmentation” and “CHAT Segmentation” 

(see Section H Format Menu of the function references and APPENDIX B: 

SEGMENTATION ALGORITHMS). 
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 CHAT_MINIMAL: The finite state machine that describes the segmentation algorithm for 

CHAT_MINIMAL files. These are used for various functions under “Segmentation” and 

“CHAT_MINIMAL Segmentation” (see Section H Format Menu of the function 

references and APPENDIX B: SEGMENTATION ALGORITHMS). 

 IPA: The finite state machine that describes the segmentation algorithm for IPA files. These 

are used for various functions under “Segmentation” and “IPA Segmentation” (see Section 

H Format Menu of the function references and APPENDIX B: SEGMENTATION 

ALGORITHMS). 

Furthermore, you can use this dialog to choose the form of pauses that are inserted via 

Event > Insert Pause. Prefix states which characters precede the pause description. Suffix 

defines which characters follow.  

Via “Decimal” you can define whether a decimal point or a comma is used. “Round to” defines 

the number of digits behind the comma, to which the pause measurement is rounded. The 

settings automatically adapt to the transcription system that has been selected under “Preferred 

Segmentation”. 

4. Auto Save: In the tab “Auto save” you can choose if you would always like to create an 

automatic backup copy of the transcription you are working on.  

The automatically generated backup copy will save your data in case of a system crash, as you 

are able to restore your transcription from the backup copy.  

If this option is activated, a backup copy with a clear name is created for the session, every time 

the Editor is started.  

 

You can use the following settings: 

 Enable auto save: The generating of an automatic backup copy is activated. 
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 File name: Accept the suggested file name or change it. 

 Directory: Accept the suggested save location for the backup file or select Browse… in order 

to change the location. 

 Interval: The data is automatically copied into the backup copy in intervals. The shorter the 

saving intervals, the better protected your data is. However, the capacity of your internal 

memory is also used more frequently. The preset “ten-minute-interval” has proven itself to be 

a reasonable choice here. However, if required you may increase or decrease this time 

interval. 

 Enable undo: The undo function (“Undo”) in the “Edit” menu is activated 

5. Language: In the tab “Language” you can define the language in which you would like to 

work with the EXMARaLDA Partitur-Editor.  

Select the language that you would like to use from the drop-down list. Save your settings by 

clicking OK. Then you will have to close and restart the Partitur-Editor. After this step, the 

language change is activated. 

 

6. Media: In the tab “Media” you can define the player that you would like to use for playing 

audio and video files. 
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In order to prevent issues with while playing your audio and video data in the Partitur Editor, we 

highly recommend the following data formats and player choices: 

Audio files: Regardless of your operating system, please only use the WAVE (“.wav”) file 

format. If your transcription is solely based on audio files, please choose the BAS Audio Player 

as your media player.  

Video files: Regardless of your operating system, the file format MPEG-1 is considered as the 

most reliable. If you are operating on Windows, you also have the option to play MPEG-4 media 

files. The best media player choice when operating on Windows is the JDS Player. Mac and 

Linux users should select the JMF player. To visualise the oscillogram while playing the video, 

add the respective audio file (“.wav”) under Transcription > Recordings….  

Please note that in order to execute the change of media players, you will have to restart the 

Partitur-Editor. 

Furthermore, you can define different parameters for the behaviour of the timeline in the musical 

score: 

 Auto anchor transcription to media: if this option is selected, the transcription is automatically 

linked to an assigned recording. The first time point on the timeline has the value 0.0, the last 

time point has the value of the end of the recording.  

 Auto remove unused timeline items after merge: If this option is chosen, an automatic check 

searches for unused time points on the timeline after events have been merged. If there are 

any, they will be removed. 

 Auto interpolate when splitting: If this option is selected, the absolute time values for split 

events will be calculated and interpolated automatically. 

7. Paths: Here you can firstly define, into which directory the Partitur-Editor writes the Log file 

(the file with error messages etc.: “Log file directory”). Secondly, you can define in which 
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directory (“Praat directory”) the programs “praat.exe” and “sendpraat.exe” are located, which 

is necessary for using the Praat panel. 

 

8. Menus: Here you can show and hide project specific menus. 

  

 

Edit > Partitur preferences… 

Opens a window in which parameters can be defined for the output as a musical score on a 

printer, as an RTF file, as an HTML file or as an XML file (see also File > Output...).  

The window is divided into five subitems: “Break”, “General”, “RTF”, “HTML” and “SVG” 

(they are described in more detail below): 
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The tab “Break” allows you to set the parameters for line and page break: 

 Respect word boundaries: defines whether word boundaries (spaces, apostrophes, hyphens) 

should be taken into consideration at a break, meaning whether breaks in the middle of a word 

should be prevented. 

 Horizontal tolerance: defines a range of tolerance for the width of the break. The higher this 

value, the fewer small units will be fragmented at a break. However, there will be a bigger 

musical score section. 

 Vertical tolerance: defines a range of tolerance for the page brake. If you encounter problems 

with the page break (which can be the case, depending on the printer used), adjust this value. 

 Additional label space: determines an additional space between the tier labels and the first 

entry. 

 Remove Empty Lines: determines, whether empty lines that resulted from a page or line break 

should be removed.  

 Number partitur areas1: determines if the musical score sections (“partitur areas”) are 

numbered consecutively. 

                                                 

1 ”Partitur areas” is a literal translation from the German term “Partiturbereich”, however, for the purpose of better 

understanding, we will be further referring to “musical score sections”.  
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 Smooth right boundaries: defines whether the right musical score section’s boundaries should 

be smoothed out to one line (This only works for printer and RTF-output, not for HTML-

output). 

 Save space: determines, whether empty lines should be “reduced” at output after a break. The 

numbering of the musical score would be slightly indented in this case: 

 

Option “Save Space” deactivated: Option “Save Space” activated: 

 

 

In the tab “General” further parameters can be set, which apply to all forms of output (meaning 

printer, RTF, HTML and XML):  

 

 Include timeline in output: determines whether the entries on the timeline (numbering and/or 

absolute time values) are to be included in the output. 

 Put timeline outside frame: determines whether the entries on the timeline are going to be 

inside or outside of the musical score. 

 Frames: defines how the sections of musical score are framed. “Left”, “Right”, “Top”, 

“Bottom” determine whether the frame lines are drawn on the left, the right, at the top or the 

bottom. “Color” specifies the colour of the frame (click the button in order to open a window 

to choose a colour). “Frame style” specifies whether the framing lines are “Solid”, 

“Dashed” or “Dotted”. 

 Prepend meta information and speakertable: defines whether the meta information and the 

speakertable are to be included in the output or not (only valid for RTF and HTML output). 

Please note that it is relevant for HTML output which stylesheet is specified and if a 
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stylesheet is specified. These specifications are made under Edit > Preferences… in 

“Stylesheets” and “Head to HTML”.  

Examples: 

 
 

The entries on the timeline were included in 

the output (outside the frame). The musical 

score section is framed with a solid line. 

 
 

The entries on the timeline were included 

into the output (inside the frame). The 

musical score section is framed with a solid 

line. 

 
 

The entries on the timeline were not 

included into the output. The musical score 

section is framed with a dotted line. 

In the tab “RTF”, you can specify parameters which are specially used for RTF output. RTF 

output can be problematic, as the calculation processes of Java do not match those of MS Word 

entirely.  

 

Thus, displacement and missing characters may occur. Some of the here mentioned parameters 

serve the purpose of compensating those inaccuracies.  

 Critical size percentage: defines from what extend onward the size of an entry in a musical 

score’s line is considered critical. This means it states from which point onward the 

mechanisms for the compensation of inaccuracies are to be applied. The preset 95% has 
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proven to be a reasonable value here. You can, of course, increase or decrease this figure, if 

required. 

 Right margin buffer: defines a buffer area at the right margin of the musical score section. 

This can be done in order to compensate inaccuracies in the calculation. If the options “Glue 

adjacent IT elements” and “Glue empty IT elements” (see below) are deactivated, this 

value can be 0. Otherwise, it should be set to a value between 5 and 20. 

 Calculate page breaks: specifies whether page breaks are to be calculated for the RTF 

document. 

 Glue adjacent events: specifies whether adjacent events in the musical score’s line should be 

combined once the first one has reached the critical size. For MS Word 97 this option has to 

be selected. For MS Word 2000 it has the small disadvantage that synchronisation rate may 

possibly shift a little bit. However, it also has the advantage that words that have been “torn 

apart” due to synchronisation will be put back together. 

 Glue empty events: specifies whether empty events in the musical score’s line should be 

combined with the preceding element. Do not use this option if you are working with framing 

or underlining single elements in colour. 

 Use CellFit parameter: specifies whether the “CellFit” parameter is used. The activation of 

this option helps to prevent mistakes, which can occur when reading output RTF files in MS 

Word 2002 (= Word XP).. 

In the tab “HTML”, you can specify parameters which are specially used for HTML output:  

 

 Make links: specifies whether links that have been made in the transcription should be 

implemented as hyperlinks in HTML. 

 Make anchors: defines whether anchors should be assigned to the musical score section – 

meaning links for outside reference. In order to work with the wordlist output (see below), 

this option has to be checked. 

 Use JavaScript: specifies whether JavaScript functions are used (to link the tier labels with the 

speakertable). 
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 Don’t make line breaks: Checking this option creates an endless musical score, hence the 

musical score is not divided by line breaks. 

 Pixel width: When this option is checked, the musical score is wrapped at the set width (in 

pixels). A value between 400 and 600 is suitable for most common monitors. In order to work 

with the word list output (see below), the musical score needs to be wrapped in this manner.  

In the tab “SVG” you can specify parameters which are specially used for SVG output:  

 

 Pixel width: defines the line break width of the musical score. This means it specifies the 

width of specific sections of musical score in pixels. 

 Scale factor: specifies the scale factor (in percent). This value increases or decreases the 

musical score according to the value specified in the output. 
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C. View Menu 

 

 

View > Keyboard 

Defines, whether the keyboard is shown or hidden (virtual keyboard, see also Section III. 

PANELS). The keyboard can also be hidden by using the x in the top right corner of the 

keyboard window. 

 

View > Link panel 

Defines, whether the panel for creating links is shown or hidden (link tool). The link panel can 

also be hidden by using the x in the top right corner of the link panel window (see also Section 

III. PANELS). 

 

View > Audio/Video panel 

Defines, whether the panel for playing audio and video files is shown or hidden (audio/video 

tool, see also Section III. PANELS).). The audio/video panel can also be hidden by using the x 

in the top right corner of the panel window. 

View > Quick media open panel 

Shows or hides the Quick Media Open Panel (see Section III. PANELS). 
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View > Praat panel 

Defines, whether the panel for communication with Praat is shown or hidden (Praat tool, see also 

Section III. PANELS).). The Praat panel is only available on Windows computers. Therefore, 

this menu item should not appear when using other systems. 

 

View > Annotation panel 

Specifies, whether the Annotation panel (see also Section III. PANELS).) is shown or hidden.  

 

View > IPA panel 

Specifies, whether the IPA panel (see also Section III. PANELS).) is shown or hidden.  

 

View > Multimodal panel 

Specifies, whether the Multimodal panel (see also Section III. PANELS).) is shown or hidden.  

 

View > SVG panel 

Specifies, whether the SVG panel (see also Section III. PANELS).) is shown or hidden.  

 

View > Show toolbar 

Defines, whether the toolbar (as presented below) is shown or hidden. 

 

 

View > Show large text field 

Specifies, whether the large text field (for entering and displaying transcription text) is shown or 

hidden. 

 

View > Show grid 

Specifies, whether the grid on the musical score is shown or hidden. Using the grid makes it 

easier to navigate in the musical score and also makes the division of events more clear: 
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Hidden grid lines hide the table-like structure of the user interface. This makes the user interface 

look more like a “musical score”, especially if the background colour of blank events is set to 

“white” (see also sections: File Menu and View Menu): 

 

 

View > Show special characters 

Shows spaces in the musical score as little dots (similar to MS Word). For this, the musical score 

has to be reformatted. This may take a few seconds. Please note: If this option is activated, the 

musical score cannot be edited! In order to be able to edit again, deactivate this option by 

selecting the function from the menu or the toolbar once more. 

“Standard View” (musical score can be 

edited): 

“Show special characters” activated (musical 

score cannot be edited): 

  

 

View > Color empty events 

Defines, whether the blank spaces in the transcription that do not contain an event should have a 

coloured tint when viewed on the screen. The colour will not be included in the output. The 

shading colour is preset to “grey” and can be changed by using Format > Edit format table.... 

In the dialog, go to “EMPTY-EDITOR” and then click the Edit button beside the entry 

“Background color”, in order to pick your colour.  

The calculation of the coloured shading is time-consuming. Therefore, it is advisable to 

deactivate this option for larger transcriptions, as this will make the Editor work significantly 

faster. 
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Option “Color empty events” deactivated:      Option “Color empty events” activated: 

   

 

View > Change scale constant… 

Opens a dialog to change the scale constant. 

 

The scale constant is the value that is added to the set point size of the fonts for the display in the 

Editor. A scale constant of +5 will display a text which is formatted as 10 pt, with a font size of 

15 pt. Use the slider in order to change the scale constant and click OK. The musical score has 

to be reformatted afterwards. This may take a few seconds. 

Note: The font size in the text box above the musical score can be changed by using the “slider” 

at the right margin of the box: 

 

 

View > Text proportional / Time proportional 

In normal view, the width of “cells” within the musical score is calculated according to the width 

of the text inside them (“text proportional”). When switching to the “time proportional” view, 

the width is calculated according to the length of time of the interval. Furthermore, the 

oscillogram and the musical score are synchronised. This is equivalent to the view of tools like 

ANVIL, ELAN or Praat. 
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Text proportional view: 

 

Time proportional view: 
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D. Transcription Menu 

 

 

Transcription > Meta information… 

Opens a dialog in which the transcription's meta information can be saved and edited, i.e. 

information about the transcriber, the recordings, the conventions etc. The meta information is 

organised into a set of attribute-value pairs. Some of them are predefined: 

 Project Name: the name of the project. 

 Transcription Name: the name of the transcription. For HTML or RTF output, this name is 

used as the document name. 

 Transcription Convention: the transcription convention made use of. 

 Referenced media file(s): the associated digitised audio or video file, if available. The Edit... 

button next to this field opens a dialog with which this file can be located and assigned. 

 Comment: allows comments on the recording and transcription. 
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In addition, an unlimited number of user-defined attributes can be added. To add a new user-

defined attribute, click Add attribute”. A new attribute-value pair is added to the table. It can be 

edited in the corresponding text fields. 

Double clicking marks the content of a field in the table and allows the overwriting of the 

content. Conclude your input with Enter. 

If the space under “Value” does not suffice, click the button with the three dots (...) in order to 

get a larger window in which you can edit it further. 

In order to delete a user-defined attribute, select it in the table and click Remove attribute. 

In order to make use of a user-defined attribute from a different transcription, click Template… 

and browse for the transcription in the file dialog that appears. 

To change the order in which the attributes are listed, select the attribute you would like to move 

and click Up or Down. 

In order to save the changes made in the meta information, close the dialog by clicking OK. 
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Transcription > Speakertable… 

 

Opens a dialog for the input and editing of information on the speakers. In the upper section of 

the speakertable the speakers are listed.  

 Auto add one T tier for new speakers: if selected, this option will automatically create a 

transcription tier (type “T”) for every speaker you add to your list. Other tier types have to be 

added manually via Tier > Tier properties… 

 Speakers: In order to add a new speaker click Add speaker. In order to delete an existing 

speaker from the list, select the corresponding entry in the list and click Remove speaker. 

In order to add or change the information corresponding to a speaker, first select the speaker 

from the list. Under “Speaker properties” the already existing information is displayed. The 

speakertable consists of attribute-value pairs. Some of them are predefined: 

 Abbreviation: the speaker abbreviation that is also used for the tier labels (when activating the 

option “Auto”, see Tier > Edit tiers…). 

 Sex: the sex of the speaker. 

 Languages: the first (L1) and second (L2) language(s) of the speaker, as well as the languages 

the speaker uses in the transcription (“Languages used”). 
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 Comment: allows comments on the speaker. 

In order to change the entries under “Languages”, click Edit languages.... The following dialog 

will appear: 

 

To assign a language to a speaker, select it from the list on the left side. Then click the 

corresponding Add button. In order to delete a language, select it in the table on the right and 

click the corresponding Remove button.  

Please note: The languages codes available in the list have adopted from “Ethnologue” 

(http://www.ethnologue.com/. Look up the website should you require more information on this 

list. 

In addition, an unlimited number of user-defined attributes can be added for the speakers.  

To add a new user-defined attribute, click Add attribute. A new attribute-value-pair is added to 

the table. It can be edited in the corresponding text fields.  

Double clicking marks the content of a field in the table and allows the overwriting of the 

content. Conclude your input with Enter.  

If the space under “Value” does not suffice, click the button with the three dots (...) in order to 

get a larger window in which you can edit it further. 

In order to delete a user-defined attribute, select it in the table and click Remove attribute. 

In order to apply all the already defined attributes for the current speaker to other speakers in the 

transcription, click Collect attributes. 

In order to make use of a user-defined attribute from a different transcription, click Template... 

and browse for the transcription in the file dialog that appears. 

To change the order in which the attributes are listed, select the attribute you would like to move 

and click Up or Down. 

In order to save the changes made in the speakertable, close the dialog by clicking OK. 

  

http://www.ethnologue.com/
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Transcription > Recordings… 

Opens a dialog through which digital audio and/or video files can be linked to the transcription.  

 

Use the Add... button to add a media file to the list. Select an entry in the list and click Remove 

to delete that entry from the list. Select an entry in the list and use the buttons Top, Up and 

Down to change the order of the files. Please note the following: 

 For the oscillogram view, the Editor will search for the first file with the file extension “.wav” 

or “.WAV”. If the Editor finds such a file, the oscillogram will be calculated on the basis of 

this file. If the Editor does not find one, a timeline without an oscillogram is drawn on the 

basis of the first file in the list. 

 The player always loads the first file in the list. If you load a different media file with help of 

the Audio/Video Panel, it will be placed at the top of the list. 

 The “HTML Partitur + Flash Player” output (see File > Output...) searches for the first 

file with the extension “.mp3” or “.MP3”. If no such file is found, the corresponding error 

message will appear. 

 Normally, files in the list should only be distinguishable on the basis of their file format 

(Audio vs. Video, different Codecs). In particular, they should all be of the same length. 

 

Transcription > Structure errors… 

Displays a dialog for editing structural errors (see also the document Correcting structure and 

segmentation errors). 
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The following structural errors can occur: 

 Temporal anomaly: absolute time values in the timeline have to show a monotonous increase. 

 More than one transcription tier for one speaker: there may only be one tier of type 

“T(ranscription)” for every speaker. 

 Orphaned transcription tier: Tiers of type “T(ranscription)” have to be assigned to a speaker. 

 Orphaned annotation tier: Tiers of type “A(nnotation)” have to be assigned to a speaker. 

Furthermore, in addition to this tier there has to be a tier of type “T(ranscription)” that is 

assigned to the same speaker. 

 Annotation mismatch: for every event in a tier of type “A(nnotation)” there has to be an event 

or a chain of interrelated events in the associated tier of type “T(ranscription)” which has/have 

the same start and end point. 

Double click an element in the list in order to get to the section in the transcription where the 

error occurred. 

 

Transcription > Calculate annotated time… 

Opens a list displaying the total duration time of each tier as well as of each annotated label.  

 

 

Transcription > Auto annotate tiers… 

This function allows you to automatically annotate specified strings in selected tiers. 

Step 1: launch Transcription > Auto annotate tiers… and select, via the arrows, the tiers you 

want to automatically annotate. Tiers that are listed in the box “Unselected tiers” will be 

excluded in the annotation.  
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Step 2: in the pop-up window “Auto Annotation”, you enter the following settings: 

 Regular expression: Enter, via a regular expression (cf. Quickstart: Regular Expressions), 

the string you want to annotate. 

 Annotation category: Enter a label for the annotation tier 

 

 Annotation value: Enter a label that describes the string you want to annotate. 

Please note: In case you have already created an annotation tier manually, please check whether 

the label you want to use has already been assigned to a previous tier. If this is the case, you have 

two possibilities. 

 Click the box “Delete existing annotations (if any)” to agree that all previous annotations 

under this label will be deleted 

 Ignore the box and check all (possible) overlaps manually (cf. “Stratify Tier”). 

If you decide to check possible overlaps in your annotations manually, the window “Stratify 

tier” will open and asks you to choose from two options: 
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 Stratify by deletion: this function deletes all duplicate entries (in the automatically generated 

annotation tier).  

 Stratify by distribution: this function generates a further annotation tier including only the 

duplicates. 

 

During the auto annotation process, new (and therefore unaligned) timeline items might be 

generated. This happens if the string (regular expression) is not identical with the boundaries of 

the event, and often results in the dilemma that a requested regular expression is located, but 

cannot be assigned to its annotation value. If so, the following error message pops up:  

To correct the errors, please align the annotation to the string manually. If you double click on 

any error message, you will jump to the corresponding event in your transcription. 

 

Transcription > Segmentation errors… 

Opens a dialog with all segmentation errors of the current transcription. The segmentation 

algorithm set under Edit > Preferences… > Segmentation is taken as a basis. 
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In the table in the upper half of the dialog, all segmentation errors are listed that resulted from 

the segmentation of the entire transcription. For every error the following information is noted in 

four columns: 

 Tier: the tier, in which the segmentation error occurred. 

 TLI: the time point on the timeline at which the segmentation error occurred. 

 Error: the cause of the error.  

 Processed output: the output that has been processed up to the occurrence of the error. 

If an entry is selected in the table, the content of the corresponding column is shown in the text 

field in the lower part of the dialog. This can be especially useful for longer error messages or 

longer processed output. 

Select the errors you would like to edit by clicking on the corresponding column in the table. 

Click Go to to move the musical score to the position where the error occurred. 

Correct the error. The dialog can remain open. 

Click Refresh to have the remaining segmentation errors displayed. 

Should segmentation errors remain, repeat from the beginning 

Close the dialog by clicking onto the x in the top right corner. 

 

Transcription > Export Segmented Transcription… 

Applies the segmentation algorithm set under Edit > Preferences… > Segmentation to the 

transcription that is currently opened. If the segmentation runs successfully a dialog that allows 
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saving the transcription pops up. Note that the segmented transcription cannot be read by the 

Partitur-Editor. The purpose of segmenting the transcriptions is their integration into an 

EXMARaLDA corpus, and to use them for the work with EXAKT. Thus, during this process, 

you should not overwrite the existing basic transcription, but give the segmented transcription a 

new name. 

If the segmentation fails, the following dialog will appear: 

 

Click OK to have the dialog for editing segmentation errors displayed (see 

Transcription > Segmentation errors…). 

 

Transcription > Count Segments… 

Applies the segmentation algorithm set under Edit > Preferences… > Segmentation to the 

transcription that is currently opened. If the segmentation is successful, a dialog will appear that 

gives statistics for various units of the transcription in a table (the types of units are defined by 

the segmentation algorithm): 

 

 

Transcription > Word list… 

Applies the segmentation algorithm set under Edit > Preferences… > Segmentation to the 

transcription that is currently opened. If the segmentation is successful, a dialog will appear that 

shows all units segmented as words in a list: 
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Click the column heading “Word” or “Speaker” to sort the list alphabetically or speakers. The 

button Save as... allows you to save the word list as an HTML file. You have two options: 

 

 Simple word list (HTML): saves the word list as a simple alphabetically sorted word list. 

 Word list by speaker (HTML): first sorts the word list by speakers and then alphabetically. 

 

Transcription > Insert Utterance Numbers 

This function will only be shown if “HIAT” has been set as “Preferred Segmentation” under 

Edit > Preferences… > Segmentation. 

Adds an annotation tier of the category “no” for every speaker in which utterances are numbered 

in a temporal order, as compliant with the HIAT segmentation, e.g.: 

Before: 

 

After: 
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The requirement is that, first, the transcription can be segmented according to HIAT. Should this 

not be the case, an error message will appear that addresses the segmentation error. 

 

In this case, check and correct the segmentation errors with the function 

Transcription > Segmentation errors….  

Secondly, every utterance boundary has to coincide with an event boundary. Should this not be 

the case, as in the following example: 

 

... the following error message will appear: 

 

In this case, split the affected event into two at its utterance boundaries. 

 

Transcription > Transformation… 

Opens a dialog which allows flexible transformation of a transcription into different scenarios. 
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Based on the “Transformation Scenario” you choose to apply to your transcription, the optimal 

parameter settings will be modified automatically. If you, however, want to change the 

parameter settings, you have the following options: 

 Transform: What should be transformed? The basic transcription (i.e. the transcription that is 

edited in the Editor), a segmented transcription (i.e. a version of the basic transcription onto 

which a segmentation algorithm has been applied), a list transcription (i.e. a segmented 

transcription in which units have been sorted into lists) or the TEI guidelines.  

 Segmentation: Which segmentation algorithm should be used? This parameter is only 

necessary if a segmented or a list transcription has been selected under “Transform”.  

 List unit: Which unit is the basis of the list? This parameter is only necessary if a list 

transcription has been selected under “Transform”.  

 Stylesheet: Which (XSL) stylesheet should be applied to the transcription? If you leave the 

field blank no stylesheet will be used and the output will be in XML. Suitable stylesheets can 

be found on the EXMARaLDA website under “Download”. 

 Output: Which file type should the output be? You can choose between HTML, XML, TXT, 

self-transformation and “other”. 

Various transformation scenarios are available. These make use of stylesheets that are integrated 

in the code (EXMARaLDA.jar).  

 

Transcription > Clean up... 

Opens a dialog that offers options for the automatic cleanup of the transcription: 
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 Remove empty events: Activate this option if you would like to remove empty events from all 

tiers: that is, events that do not contain text. 

 Smooth timeline with a threshhold of: Activate this option if you would like to combine 

timeline entries that lie very close together. With the help of a threshold you can define which 

entries are to be considered as “lying close together”. 

 Bridge gaps smaller than: Activate this option if you've provided timeline entries with 

absolute time values and would like to close the gaps in the timeline that are smaller than the 

predefined value in milliseconds. To set this value, move the scroll bar to the desired value. 

 Remove unused timeline items: is equivalent to the menu item 

Timeline > Remove unused timeline items (see below). 

 Remove gaps: is equivalent to the menu item Timeline > Remove gap and 

Timeline > Remove all gaps (see below). 

 Normalize IDs: Ensures that IDs for time points, tiers, speakers etc. are assigned consistently. 

 

Transcription > Glue transcriptions... 

Glues a second transcription to the end of the currently opened transcription.  

First, you are asked to select a file to be glued. Thereafter, a dialog will appear with which you 

can define the assignment of tiers in the current transcription (“Transcription 1”) and the 

transcription you intend to glue (“Transcription 2”). The tiers that have been assigned to each 

other are shown in the right text field (“Mappings”). 
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To assign the tiers individually (“by hand”), use the following functions: 

 Add: To carry out an individual assignment, select both of the entries in the left text fields and 

click Add to add this pair to the right text field. 

 Remove: In order to undo an assignment, select the entry in question in the right text field and 

click Remove. 

 Remove all: In order to delete all assignments, click Remove all. 

There are two ways to assign the tiers automatically: 

 Auto (Position): Assigns the tiers according to their position, hence the first tier in 

transcription 1 will be assigned to the first tier in transcription 2, the second tier in 

transcription 1 will be assigned to the second tier in transcription 2 etc. 

 Auto (Properties): Assigns the tiers according to their properties, hence tiers with the same 

speaker abbreviation and the same category are assigned to each other. 

It is possible to combine both manual and automatic assignment with each other.  

“Timeline Method” allows you to choose whether time points should be sorted according to 

their absolute time values when they are being glued, (“Merge timelines”, is recommended for 

fully aligned transcriptions) or whether the two timelines should simply be stringed together 

(“Append timelines”).  

Once you have completed the assignment of the files click OK to glue the transcriptions. 

 

Transcription > Merge transcriptions… 

This option allows you to combine two or more transcriptions into one. It is especially useful if 

two or more people work on the same audio/video file and you want to merge all 

transcribed/annotated tiers into one file.  

In order to merge transcriptions, choose under Transcription > Merge transcriptions… any 

EXMARaLDA Basic Transcription file and click Open. 
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You will find that the merged transcription is inserted unaltered below the present transcript, and 

will automatically align its events to the (if present) oscillogram. Notice that after merging the 

files, you need to rectify the timeline manually. Empty events can be deleted with 

Timeline > Remove all gaps. 

Transcription 1: 

 

Transcription 2: 

 

After merging Transcription 1 and 2 
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Transcription > Chop transcription… 

Divides the entire transcription into various partial transcriptions while keeping the original file. 

 

 Minimum number of timeline items: The minimum number of timeline intervals per partial 

transcription is set so that the original transcription is divided into ten partial transcriptions. 

(In this example the original transcription had a timeline consisting of 252 intervals.) You can 

change the value with the arrow keys to the right of the number at will. 

 Directory: Click Browse… to select a directory in which the new partial transcription should 

be saved.  

 Base filename: Then enter a base filename for the files that are then automatically numbered 

consecutively. 

 

Now the directory you previously selected will contain a set of new .xml files that each represent 

a section of the original transcription. 
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Transcription > Mask audio file… 

By using this feature, you can mask selected segments of an audio file. The subsequently altered 

audio file will be automatically saved as a new audio file and not overwrite the original file. 

Oscillogram before Mask audio file… 

 

Oscillogram after Mask audio file… 

 

Step 1: isolate the segment you want to mask into its own event. It is necessary that only the 

segment to be masked is audible in that event. 

Step 2: In order to mark this singular event, please add a tier of the type “(D)escription” directly 

below the speaker’s tier. Now go back to the event you want to mask, and annotate it in the 

newly added tier. (E.g. Personal Information, Name, Date etc.) 

Attention: If you do not add a new tier, the Partitur Editor will automatically also mask the 

previous and following event of the targeted event. 

Step 3: Mark the event you want to mask and click Transcription > Mask audio file… The 

window “Tier selection” will open.  
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To mask only the marked event, choose the newly added “(D)escription” tier. If you want to 

mask the previous, targeted and following event, you may choose the speaker tier.  

Step 4: The window “Audiodatei maskieren” will now be open.  

 

 Quelldatei: denotes the file path of your present audio file 

 Zieldatei: denotes where the new audio file will be saved at (you can recognise the mask file 

by its suffix “_mask.WAV”)  

 Methode: Here you can choose from three different settings to mask the respective event(s): 

 Silence: Events are substituted by complete silence  

 Brownian Noise (generated): Events are substituted by brown noise  

 Brownian Noise (copied): Events are substituted by brown noise  

Step 5: Finally, you need to link the new (“_mask.WAV”) audio file under 

Transcription > Recordings… to your transcription and place it on top of the media files list. 

 

Transcription > Chop audio… 

Divides a copy of the audio file of the musical score into a number of smaller audio files (“audio 

snippets”) 

Please note that the use of this function requires:  

 that you've assigned an audio file to the musical score via “Referenced media files”, 

 that the audio file is in “.wav” format (other audio formats cannot be processed) and 

 that the timeline has as many absolute time values as possible. 
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There are two ways to chop the audio file: 

 Based on the timeline: The audio file is chopped in accordance with the timeline. An “audio 

snippet” is created for every interval of the timeline.  

 Based on events in tier: The audio file is chopped in accordance with the events in the 

selected tier: For every event an “audio snippet” is created. 

Furthermore, you have the option of linking the newly created “audio-snippets” with the musical 

score in the same step: 

 Link to the selected tier: The created “audio snippets” are linked to the currently selected tier 

automatically. 

 Link to a new tier: The Partitur-Editor automatically generates an additional tier in which the 

“audio snippets” are linked to the musical score. 

 Don’t link: The “audio snippets” are only generated without being linked to the musical score. 

In the lower section of the dialog, you will then be asked to enter a name and a location where 

you would like to save the file: 

 Directory: Is the directory on your computer where you would like to save the newly created 

audio files. In order to change the directory click Browse…. 

 Base filename: Is the base filename for the files that are to be created. 

 Append event description: The first symbol of the associated text will be added to the 

filename of the “audio snippets” that are to be created. 

The “chopping” may take a few seconds. Upon completion, a dialog will inform you whether the 

chopping has been successful or whether errors occurred: 
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In the following example the audio file is divided in two ways, and linked to an additional tier: In 

the “Timeline” tier, the audio file was chopped on the basis of the timeline (the option “Based 

on the timeline”), in the “Tier” tier, the audio file was only chopped based on the tier of the 

speaker “Fichte”. The assigned “audio snippets” can only be played directly from the musical 

score. 

 

The newly generated files are saved in the previously defined directory. A consecutive number 

and the first symbol of the associated event were automatically added to the previously chosen 

base filename: 

 

 

Transcription > ExSync Event Shrinker 

Shrinks the events automatically after the import of ExSync-documents in accordance to their 

typographic expansion (see also Manual for the conversion of legacy data: Importing 

syncWRITER data). 
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E. Tier Menu 

 

 

Most of the functions in the tier menu are only accessible once you have marked a tier. In order 

to select a tier, click on the corresponding speaker label at the beginning of the tier: 

 

 

Tier > Tier properties… 

Opens a dialog that allows editing properties of the currently selected tier. 
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Four attributes are defined: 

 Speaker: the assigned speaker. All defined speakers are listed as options in the ComboBox. If 

it is not useful to assign the tier in question to a speaker, choose “no speaker”. 

 Type: the tier type. Choose “T(ranscription)” for verbal tiers, “D(escription)” for nonverbal 

tiers, “A(nnotation)” for tiers with annotations (translations etc.), “L(ink)” for tiers that 

contain links to files and “U(ser) D(efined)” for other tiers. The correct assignment of the tier 

type is especially important for segmentation functions. 

 Category: the tier category. It can be defined freely or remain empty. A category should be 

defined, if you set up more than one tier for a speaker. For example, enter “v” for “verbal”, 

“nv” for “nonverbal”, “c” for “comment” or “ENG” for an “English Translation”. 

 Display: the name of the tier that should be used for the tier for the output in the Partitur-

Editor. If the option “Auto” is activated, this name is automatically generated from the 

abbreviation and the category. In order to enter a different tier name, deactivate the option 

“Auto” and enter the desired name.  

 User defined attributes: allows the additional input of user-defined attribute-value pairs for the 

tier. 

 

Tier > Edit tiers…  

Opens an overview of the following information  
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 Display Name: the name that is displayed in the musical score at the beginning of every tier 

 Category: the tier category 

 Type: the tier type 

 ID: the ID tier assigned by the program 

 Speaker: the speaker abbreviation assigned to the speaker 

 Speaker ID: the speaker ID assigned by the program 

 Number of Events: the number of events within this tier 

 Parent Tier: for tiers of the type “A(nnotation)” the software checks, whether a tier of the type 

“T(ranscription)” that is linked to the same speaker exists. If this is the case, an OK will 

appear, otherwise “#Error”. For tiers of type “T(ranscription)” or “D(escription)”, “n.a.” for 

“not applicable”, is displayed. 

 Annotation mismatches: for tiers of the type “A(nnotation)”, the software checks whether all 

events have a corresponding event in the respective tier of type “T(ranscription)” (see also 

Transcription > Structure errors…). If this is the case, “OK” will appear, otherwise the 

number of faulty annotations will be shown. For tiers of type “T(ranscription)” or 

“D(escription)”, “n.a.” for “not applicable” is displayed. 

 

Tier > Add tier…  

 (Shortcut: CTRL + A on Windows, ⌘ + A on Mac) 

Opens a dialog to add a new tier at the end of the transcription. 
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The entries under “Speaker”, “Type” and “Category” are equivalent to the ones described above 

in Tier > Tier properties…. If the option “Copy events from” is selected, empty events will be 

inserted into the new tier, wherever the copied tier also contains entries (this can be especially 

useful for annotation tiers). 

 

Tier > Insert tier… 

  (Shortcut: CTRL + I on Windows, ⌘ + I on Mac) 

Opens a dialog to insert a new tier above the currently selected tier. The dialog is identical to the 

Tier > Add tier… dialog described above. 

 

Tier > Remove tier… 

  Removes the currently selected tier.  

A confirmation prompt is then carried out. In order to hide a tier, rather than deleting it 

permanently, use Tier > Hide tier. 

 

Tier > Move tier upwards… 

  (Shortcut: CTRL +  Windows, ⌘ +  on Mac) 

Moves the currently selected tier upwards. 

 

Tier > Change tier order… 

  Opens a dialog that allows changing the tier order: 

 

Select the tier that you would like to move, click Up to move it up or Down, to move it down. In 

order to save the changes made, close the dialog by clicking OK.  
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Tier > Hide tier 

  Hides the currently selected tier. 

 

Tier > Show all tiers 

  Shows all hidden tiers again. 

 

Tier > Remove empty events 

Removes empty events, hence events that only contain spaces, from the currently selected tier. 
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F. Event Menu 

 

 

Event > Event properties…  

(Shortcut: CTRL + Enter on Windows, ⌘ + Enter on Mac, as well as by right clicking into 

the corresponding event) 

Opens a dialog to edit the currently selected event: 
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The event text can be edited via “Event description” – this may be of convenience especially 

when writing extensive descriptions. “User defined attributes” allows the entry of user defined 

attribute-value pairs for the event (how to operate this field can be found under  

Transcription > Meta information…). 

 

Event > Remove  

  (Shortcut: CTRL + D on Windows, ⌘ + D on Mac) 

Removes the currently selected event. 

Before: 

 

After: 

 

 

Event > Shift characters to the right 

  (Shortcut: CTRL +  + R on Windows, ⌘ +  + R on Mac) 

Shifts the characters to the right of the current cursor position into the next event. 

Before: 

 

After: 
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Event > Shift characters to the left 

  (Shortcut: CTRL +  + L on Windows, ⌘ +  + L on Mac) 

Shifts the characters to the left of the current cursor position into the previous event. 

Before: 

 

After: 

  

 

Event > Merge 

  (Shortcut: CTRL + 1 on Windows, ⌘ + 1 on Mac) 

Merges two or more selected events in a tier into one event. 

Before: 

 

Select: 

 

After: 

 

 

Event > Split 

  (Shortcut: Strg + 2 on Windows, ⌘ + 2 on Mac) 

Splits the current event into two at the cursor position. 

Before: 
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After: 

 

If the current event only includes a time span from one time point to the next, a new time point 

will be inserted on the timeline.  

If the event has a time span from one time point up to two time points thereafter, like in the 

example, it will be split at the interjacent time point.  

If the time span is greater, a dialog will open in which the time point at which the event is to be 

split can be selected: 

 

 

Event > Double split  

  (Shortcut: CTRL + 3 on Windows, ⌘ + 3 on Mac) 

Splits the current event according to the current text selection in three events. 

Before: 

 

After:  
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If the event in question covers more than one time interval this function is deactivated. In this 

case apply the function Event > Split twice. 

 

Event > Extend to the right 

  (Shortcut: CTRL +  +  on Windows, ⌘ +  +  on Mac) 

Extends the currently selected event to the right by one time point. 

Before: 

 

After: 

 

 

Event > Extend to the left 

  (Shortcut: CTRL +  +  on Windows, ⌘ +  +  on Mac) 

Extends the currently selected event to the left by one time point. 

 

Event > Shrink on the right 

  (Shortcut: Strg + Alt +  on Windows, ⌘ + Alt +  on Mac) 

Shrinks the currently selected event by one time point from the right. 

Before: 

 

After: 
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Event > Shrink on the left 

  (Shortcut: CTRL + Alt +  on Windows, ⌘ + Alt +  on Mac) 

Shrinks the currently selected event by one time point from the left. 

 

Event > Move to the right 

  (Shortcut: CTRL +  on Windows, ⌘ +  on Mac) 

Moves the currently selected event to the right by one time point. 

Before: 

 

After:  

 

 

Event > Move to the left 

  (Shortcut: CTRL+  on Windows, ⌘ +  on Mac) 

Moves the currently selected event to the left by one time point.  

Event > Find next event  

(Shortcut: CTRL+ ALT + N on Windows, ⌘ + ALT + N on Mac) 

Jumps right to the next (filled in) event within a tier. 

 

Event > Insert Pause  
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  Inserts a pause into the selected event with the length of the current selection in the 

oscillogram.  

The specific notation of the pause can be set via Edit > Preferences… > Segmentation.... 
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G. Timeline Menu 

 

 

Timeline > Edit timeline item... 

  Opens a dialog to edit the absolute time value of the currently selected event: 

 

The absolute time value can either be entered as a decimal number (i.e. in seconds) or as 

hh:mm:ss.xxx. The absolute time value is equal to the starting point of the event. 

 

Timeline > Insert timeline item 

  Inserts a new time point to the left of the currently selected time point. 

Before: 
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After: 

 

 

Timeline > Remove gap 

  Removes the currently selected gap from the timeline.  

A gap is a space between consecutive time points that does not contain an event. When calling 

up this menu item, the first of these two time points is removed and thereafter the rest of the 

transcription is moved to the left by one time point. 

Before: 

 

After: 

 

 

Timeline > Remove all gaps 

  Removes all gaps from the transcription. 
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Timeline > Remove unused timeline items 

Removes all unused timeline items from the transcription. A time point is unused when no event 

starts or ends on it. 

Before: 

 

After: 

 

 

Timeline > Make timeline consistent 

Checks the timeline for inconsistencies, i.e. after absolute time values. Absolute time values that 

do not fit into a monotonously growing sequence are removed. 

 

Timeline > Smooth timeline... 

Interpolates the timeline, i.e. calculates an absolute time value for all time points that have not 

been assigned an absolute time value. Please note that the values calculated in this manner are 

only an estimate of the actual absolute time values of the time points in question. If more time 

points have been defined with an absolute time value, the value of the interpolation will be more 

accurate. 
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Timeline > Interpolate timeline... 

 

Interpolates the time axis, i.e. calculates an absolute time value for all time points that have not 

been assigned an absolute time value. Please note that the values calculated in this manner are 

only an estimate of the actual absolute time values of the time points in question. If more time 

points have been defined with an absolute time value, the value of the interpolation will be more 

accurate.  

There are two methods of interpolation. For this, consider the following transcription in which 

no absolute time value is available at time point 2: 

 

 Linear Interpolation: inserts missing absolute time values according to the number of time 

points that lie between the previous and the next time point with an absolute time value. In the 

example above time point 2 receives the value 1.0 + (4.0 – 1.0)/2 = 2.5: 

 

 Character Count Interpolation: on the other hand, inserts missing absolute time values 

according to the symbols in the events in question. Events with longer descriptions are 

assigned to intervals of a longer duration: 

 

The second method leads to better results in most cases. Interpolated time values are marked 

with an Asterisk [03.3*] in the timeline of the musical score. 

 

Timeline > Remove interpolated times 

Removes absolute time values from the timeline that have been created by interpolating (see 

above). 

Timeline > Remove times 

Removes all absolute time values from the timeline). 
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Timeline > Confirm timeline item(s) 

Confirms the absolute time values of all currently selected time points, i.e. sets their status from 

“interpolated” to “confirmed”, if applicable. The Asterisk will then disappear and the time 

points in question will no longer be removed when executing “Remove interpolated times”. 

 

Timeline > Modify absolute times... 

Please save a copy of the current version of your musical sheet before you change the absolute 

time values. 

 

 Absolute Zeitwerte verschieben: Shifts all absolute time values by the value (seconds) 

specified in the box. In the example above, all time values will be postponed by 1 minute and 

54.3 seconds: 

Original absolute time values: 

 

Postponed absolute time values: 

 

Click Anfang auf 0.0, to set the absolute time value of very first event (0) to [00:00]. Notice, 

that the time calculated for event 0 to be preponed to [00:00] will also be applied to all 

subsequent absolute time values. In our example below, the time calculated corresponds to -

00:01.7 seconds. Thus, all absolute time values will be preponed by 1.7 seconds 

Original absolute time values: 
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Preponed absolute time values: 

 

 Absolute Zeitwerte skalieren: Scales all absolute time values by the factor specified in the box 

.  

To modify the scaling factor, you can either enter the desired scaling factor directly into the box, 

or change and apply the target value of a previously chosen measuring point. Regardless of the 

option you choose, any factor below 1, respectively below the currently aligned time (“Aktuelle 

Zeit”), will result in a compression of the time values while any factor above 1 will result in a 

stretching of the time values. 

If you opt to modify the scaling factor by changing the target value, first choose an event in your 

musical score. This event’s currently aligned time can be now changed to the desired target time 

(i.e. starting point of an event). The time calculated between the current and changed time will 

then be transformed into a scaling factor and subsequently applied to all absolute time values. 

 

Timeline > Fine tuning mode 

Activates or deactivates the mode for fine tuning the absolute time references. If the mode is 

turned on the behaviour of the Editor will change as shown in the following: 

 By scrolling, the absolute time value of a selected time point can be increased or decreased by 

0.1 seconds. 

 By pressing F1 only the first second of the currently selected time intervals is played. 

Timeline > Easy alignment… 

Opens a window that allows you to simultaneously listen and align your transcription with your 

recording.  

To start the alignment, click into your first event and open the function Timeline > Easy 

alignment. You will now see two main sections, one black, one grey, where the current and 

upcoming events are displayed. Notice that only if an event is of the tier type “T”, will the 

transcribed text be displayed. The grey screen section displays the upcoming event. 

Click the “Play” button to start the playback of the recording. After you have heard the currently 

displayed text, hit SPACE on your keyboard (or press the align button  ). 

To stop the playback, press the stop button. 
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Timeline > Add bookmark… 

Adds a bookmark to a point on the timeline or allows the renaming of an already existing 

bookmark. A bookmark can facilitate finding significant sections of a transcription again (see 

Timeline > Bookmarks…). Select the time point in question by clicking into it on the timeline. 

Then choose Timeline > Add bookmark. 

 

Enter a name for the bookmark in the window that appears or rename the bookmark and click 

OK upon completion of your entry. The name of the bookmark will appear in the timeline 

thereafter: 

 

 

Timeline > Bookmarks… 

Opens a window with the selection of all set bookmarks.  

 

Select the section in the transcription that you would like to access and click Go to…”. 
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H. Format Menu 

 

 

With the format menu, the font type, font size, text and background colors etc. can be changed. 

The format options change both the way the musical score is displayed on the screen, as well as 

the way the output is displayed (Print, RTF, HTML or SVG document).  

Font size and bold print should not be used as carriers of linguistic information. In 

EXMARaLDA, these are exclusively coded with the used symbols or symbol chains (see also 

APPENDIX B: SEGMENTATION ALGORITHMS). Formatting is thus not an integral 

component of the actual transcription, but is treated like additional information that is only 

relevant for the presentation in the Editor and the output. Furthermore, it is saved as a separate 

file and not in the actual transcription.  

The system architecture ensures that only whole tiers or all tier labels or all timeline labels can 

be formatted. It is not possible to format individual sections of a tier, e.g. to underline single 

words in the transcription, to print them in bold or change their font. The reason for this is that 

this kind of formatting can only be transformed into other file formats with some limitations. It is 

not possible, for example, to import underlining or bold print into a data base.  

If you would solely like to use these features for display purposes, you can later apply the 

desired changes to an exported RTF document. If they are part of your transcription conventions, 

however, (e.g. emphasised speech needs to be underlined according to your conventions) you 

should consider whether you can express the marked phenomena with the help of symbolic 

means. 

The default format is automatically applied to every transcription made with the Editor (to 

configure the default font see Edit > Preferences…). Editing the format of a tier (or of the 

speaker labels or the timeline) is done by calling the dialog via Format > Edit format table.... 
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Format > Apply stylesheet 

Generates a new formatting for the current transcription from a stylesheet (see also VIII). The 

stylesheet that is specified in the user settings (see Edit > Preferences…) in “Transcription to 

format table” will be used. If there is no entry, a local stylesheet will be used. 

 

Format > Open format table...  

  Opens a saved format table and applies it to the currently opened transcription. 

 

Format > Save format table as... 

Saves the current format table as a separate file with a new name. 

 

Format > Edit format table...  

  Opens a dialog for editing numerous tier formats: 

 

Choose the format from the list that you would like to edit and choose your required settings in 

the lower half of the dialog. You can enter sample text in the field “Test Area”. Close the dialog 

by clicking OK to apply changes. 
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 Font: sets the font. 

 Font style: sets the font type (“Plain”, “Bold” or “Italic”). 

 Font size: sets the font size (in points). 

Example: 

 

Labels: „Times New Roman, Bold, 10 pt“ 

Tier 1 and 3: “Times New Roman, Plain, 12 pt” 

Tier 2: “Courier New”, Italic, 8 pt” 

 

 Text color: sets the color of the text. 

 Background color: sets the background color of the text. 

Choosing the color is done by selecting it from the dialog: 

 

Examples: 

 

Tier 1 to 3: Red, blue and green as text colors 

 

Tier 2: grey as a background color 

(to emphasise the expansion of non-verbal events 

for example) 



EXMARaLDA Partitur-Editor – Manual  Format Menu 

 
121 

 Alignment: sets the alignment of the text within the event description. This setting only takes 

effect in the Editor. For the output the font is always aligned to the left. 

Example: 

 

Tier 2:  “Centre” 

 

 Border sides: defines whether the events should be framed. 

 Border color: sets the frame color. 

 Border style: defines the style of the border (“solid”, “dashed” or “dotted”). 

Examples: 

 

Tier 1 and 3: grey solid border lines on the right  

 

Tier 2: blue dotted border lines on the left, right, 

above and below 

(to emphasise the expansion of non-verbal events 

for example) 

 

 Height calculation: defines by which method the tier height should be calculated. There are 

three alternatives: 

 Generous: This is the default setting. The tier height is adjusted to the biggest symbol 

of the chosen font as a guideline, much like in text processing. 

 Miserly: If this option is chosen the tier height is adjusted to the biggest symbol 

actually used in the tier in question. 

 Fixed: If this option is chosen, the tier height can be set by the user. The unit are 

Pixels (is equivalent to the font unit “points”). 

 

Format > Format tier...  

  (Shortcut: CTRL+ F on Windows, ⌘ + F on Mac) 

Opens a dialog to format the currently selected tier.  
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Format > Format tier labels...  

  Opens a dialog that allows formatting of the speaker label. 

 

Format > Format timeline... 

Opens a dialog that allows formatting the timeline. 

Format > Format timeline items... 

Opens a dialog to set the format of the time points on the timeline. The settings will be displayed 

in the Editor as well as used for the RTF or HTML output or when printing. 

 

 Show every n-th numbering: every n-th numbering in the timeline will be shown. Enter 0 to 

have no numbering shown at all. 

 Show every n-th absolute time: every n-th absolute time value on the timeline is shown. Enter 

“0” to have no absolute time values shown at all. 

 Absolute time format: defines whether the absolute time values are to be shown “Decimal”, 

hence in seconds, or as (“Time”) in the format hh:mm:ss.xxx. 183.21 (“Decimal”) and 

03:03.21 (“Time”) represent the same, namely “3 minutes, 1 seconds and 230 milliseconds”. 

 Miliseconds digits: defines how many post decimal positions should be used when displaying 

milliseconds. 

Examples: 

 

Show every n-th numbering: 1 

Show every n-th absolute time: 1 

Absolute time format:  Time 

Miliseconds Digits: 1 

 

Show every n-th numbering: 0 

Show every n-th absolute time: 1 

Absolute time format: Time 

Miliseconds Digits: 3 

 

Show every n-th numbering: 1 

Show every n-th absolute time: 2 

Absolute time format:  Decimal 

Miliseconds Digits: 1 
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Format > Set frame end 

Specifies the position of the frame of the musical score. The default setting is set in such a way 

that all tiers lie within the musical score frame. If you would like to change this, reorder all the 

tiers so that the tiers you would like to be placed into the frame are on top (for this see also 

Tier > Change tier order…). Select the last tier that is supposed to be below the frame by 

clicking the tier label. Only choose the menu item hereafter. 

(The position of the musical score frame can easily be seen by the tier labels on the screen: The 

tier labels outside of the musical score have a different frame.) 

Examples: 

 

no “frame end” 

 

“frame end” added after the third tier 

 

Format > Reformat 

  Forces a recalculation of the musical score format. This can be of use when you have 

manually adjusted some intervals on the timeline for example. 

 

Format > Underline 

Underlines the currently selected text. This underlining is not considered formatting in the 

conventional sense. The way it is executed depends on the settings found under 

Edit > Preferences… > Font > Underline. If “Underline in a separate tier with category 

XXX” is selected, the event in question is split and the entry is placed into an annotation in an 

associated tier. This complies with the recommended procedure for marking accents of the 

“HIAT Handbuch” (Rehbein et al. 2004). 

           

The settings “Underline in the same tier (using a diacritic)” on the other hand, insert suitable 

diacritics into the currently selected tier that form an underlining. 
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The latter method is more comfortable normally, but limits the systematic search-ability of the 

transcription. 
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I. CLARIN Menu 

 

 

CLARIN > Web MAUS 

The function “Web Maus…” features fully automated segmentation and annotation of natural 

speech into words – displayed orthographically and in SAMPA – and phonemes. 

To segment in your transcription, choose the event(s) you want to segment and launch CLARIN 

> Web MAUS. This opens a dialog where you are asked to set the following parameters: 

 

 Language: Select the language that corresponds with your transcribed text. 

 Selection: Choose which part of your selected text you want to pass to MAUS:  

 Events of the current selection : “events” are units takes as reference points 

 Segment chain around the current selection: “segment chains” are units taken as 

reference points (in accordance with the segmentation algorithm)  

 Segmentation: Select how you would like your transcribed text to be segmented: 

 Use the transcription as is: i.e. no segmentation algorithm is applied 
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 Use a segmentation algorithm: i.e. any selected segmentation algorithm is applied 

 Annotation Levels: Select the annotation levels you want to apply to your transcription: 

 Words (orthographic): a new annotation tier (“[w-orth]”) will be created, displaying 

each segmented word in a single event. 

 Words (SAMPA): a new annotation tier (“[w-sampa]”) will be created, displaying 

each segmented word in a single event while being transcribed in SAMPA 

 Phonemes: a new annotation tier (“[p-sampa]”) will be created, displaying each 

segmented phoneme in a single event while being transcribed in SAMPA.  

 Output: with regards to the output, following options are available: 

 Open it as a new file: the output will be displayed as a new file 

 Merge it with the existing transcription: The about-to-be generated annotations 

appear as additional annotation tiers in your present transcription. 

 

 

CLARIN > WebLicht 

In order to work with “WebLicht…”, you need a WebLicht account. If you do not have an 

account yet – but you are a member of a University – you can register and create your account 

here. 

Start WebLicht and upload a TCF file. This file will automatically be opened in the so called 

“Advanced Mode”.  

To create a TCF file: you can, for example, save your transcription via File > Export as TCF 

file (cf. File > Export as “TCF”).  

Before you click Save please make sure to specify the language settings in correspondence to 

your input. This setting will, in the further course, be applied by WebLicht. 

Define your desired Processing Chain.  

http://weblicht.sfs.uni-tuebingen.de/weblichtwiki/index.php/FAQ#How_do_I_log_in_to_WebLicht.3F


EXMARaLDA Partitur-Editor – Manual  CLARIN Menu 

 
127 

 

This “Chain” executes a set of tools which, at this point, include tools to annotate: 

 Lemmas 

 POS  

 Named Entitites  

 and Morphology  

Please notice that the listed annotation tools apply only to German. Other languages will, 

therefore, take different (and at the moment fewer) tools. 

Download and save your Processing Chain by clicking Download Chain at the bottom right half 

of the website 

Go to the website “WaaS” (Weblicht as a Service) and generate an “API Key”. This key helps 

WebLicht to identify who you are and can be compared with a password. To receive this key, 

please open the tab “API Key” and click on the button Generate. Now you can copy your 

personal API Key and save it (as a string) on your computer. 

 

Open your transcription in the Partitur Editor and launch  

CLARIN > WebLicht. Enter the following parameters into the pop –up window  
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 Language: Please specify the language of the input and toolchain. 

 Segmentation: please specify which algorithm to use for segmenting (=tokenizing) the input. 

 Chain definition: Click on Browse… to choose the Processing Chain you defined earlier 

 API key: Click on Browse… to enter the API Key you created 

 Output: Choose the output format you want to save your file as (one of the three specified), 

and click Browse… to define its location.  

Example: HTML Output  
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J. Help Menu 

 

 

Help > EXMARaLDA on the web 

On our EXMARaLDA homepage (www.exmaralda.org), you can find an extensive assistance 

via the menu item “Help&Support”. In particular, you will find a vast collection of examples 

for the practical work with the Partitur-Editor.  

 

Help > About… 

Displays an information dialog that lists the version of the EXMARaLDA Partitur-Editor you are 

currently using. Furthermore the “Java version” and the “OS version” are listed here, too: 

 

The button Copy debug info… allows the copying of the log file content (the error messages 

etc.) into the clipboard. This is especially useful if you encounter errors in the software and 

would like to send the error messages to the developers.  

http://exmaralda.org/de/
http://www.exmaralda.org/
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Help > Check version… 

Shows you a web page that informs you whether the currently used version of the Partitur-Editor 

is the newest. 
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V. APPENDIX A: SIMPLE EXMARALDA CONVENTIONS 

 

1. Every line starts with a speaker abbreviation of the speaker making the utterance followed 

by a colon. Two speakers are not allowed to share the same abbreviation. Capitalization is 

relevant (i.e. “Tom” and “TOM” will be treated as two different speaker abbreviations): 

TOM: ..... 

TIM: ..... 

2. Per line, an utterance is transcribed. Every line is ended with an end-of-line symbol 

(carriage return). Spaces are allowed for a clear structure. 

TOM: Hallo, Tim! 

TIM: Hallo, Tom.  

3. A transcription of non-verbal actions that accompany the utterances (i.e. that happen 

simultaneously), can be placed in square brackets before the utterance. 

TOM: [winkt] Hallo, Tim! 

TIM: [winkt] Hallo, Tom. 

4. An annotation of the utterance (e.g. a translation) can be placed in curly brackets behind the 

utterance. It is placed into the same line as the associated utterance. 

TOM: [winkt] Hallo, Tim! {Salut, Tim!} 

TIM: [winkt] Hallo, Tom. {Salut, Tom!} 

5. Overlapping parts of the utterances of different speakers are placed into angle brackets. The 

closing angle bracket is followed by any desired string that indexes the overlapping of the 

utterances, followed by another closing angle bracket. Indexing should be done with 

numbers to simplify the readability. These numbers do not need to be in ascending order (it 

is necessary, however, that they are unambiguous). For an improved readability overlapping 

utterances can be indented with the help of tabs or spaces. 

TOM: [winkt] Hallo, <Tim!>1> {Salut, Tim!} 

TIM: [winkt] <Hallo>1>, Tom. {Salut, Tom!} 

6. Square, curly and angle brackets may only be used as specified above. They should not 

occur within the transcription in any other way. 
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VI. APPENDIX B: SEGMENTATION ALGORITHMS 

 

General information on Segmentation 

Segmentation is an operation that is normally applied to the transcription after it has been 

completed. Segmentation can be used for numerous purposes which can be summarised with the 

following keywords: 

 The automatic generating of additional representations for a transcription for example the 

output of a transcription as an utterance list (cf. e.g. Transcription > Transformation… or 

File > Output... > GAT transcript). 

 The splitting of the transcription into relevant (linguistic) analysis units that are used in the 

computer-assisted evaluation of a transcription or a transcription corpus. The analysis 

instrument “Alphabetic Wordlist” (cf. e.g. Transcription > Word list…) requires the 

transcription to be segmented into words, and the counting of segments (cf. e.g. 

Transcription > Count Segments…) requires the prior segmentation of the units to be 

counted. 

This introduction sheds light on the general segmentation functionality. For a detailed 

description of individual menu items, see the respective section in Chapter IV: FUNCTION 

REFERENCE. 

 

What to segment? 

Firstly, it should be noted that the material to be segmented is normally only located in the tiers 

of type “T(ranscription)”, i.e. there, where the verbal action of a speaker is transcribed 

orthographically or literarily. Neither tiers of type “D(escription)” for non-verbal action, gestures 

and facial expressions etc., nor tiers of type “A(nnotation)” for annotated elements such as 

translations and comments, are to be segmented. In the following transcription extracts, only the 

first and third tier are considered for segmentation, while the second and fourth tier (that are of 

type “A” because they are translations) are not considered: 

 

Within a tier of type “T”, segmentation is a step-by-step process along the segment chain unit. 

Such a segment chain is defined as a chain of events without temporal interruptions. These 

segment chains can easily be observed in the Editor: By default, they are highlighted in white 

between two sections highlighted in grey. The example above thus contains four segment chains: 

KLA: Oh, da kommt einer. Kommt noch einer. ((hustet)) Wa/? 

ERW: ((hustet)). 

ERW: Och nee, dat jiwet ja nich. 

KLA: Oh, dat kann ja nich wahr sein. 
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How to segment? 

The actual segmentation takes place by applying a “Finite State Machine” onto the tiers to be 

segmented. This is a simple algorithm that recognises utterance end symbols and word separators 

etc. and by using this information, splits segment chains into smaller units. Due to the fact that 

both, name and meaning of these units, differ from one transcription system to the next (e.g. 

“utterances” in HIAT vs. “phrasing units” in GAT) and every transcription system makes use of 

different utterance end symbols for its units (e.g. the five utterance end symbols in HIAT vs. the 

five phrase-final symbols in GAT), the Partitur-Editor has a number of different finite state 

machines for different transcription systems. Which of these the Editor should use can be set via 

Edit > Preferences…. 

The finite machine uses the regularities of the individual transcription systems to split segment 

chains into smaller units. As shown in the given example, a splitting of the segment chains into 

utterances can take place with the HIAT segmentation by means of the full stops and question 

marks (that complete an utterance according to HIAT): 

KLA: Oh, da kommt einer. 

ERW: ((hustet)). 

KLA: Kommt noch einer.  

KLA: ((hustet)) Wa/? 

ERW: Och nee, dat jiwet ja nich. 

KLA:  Oh, dat kann ja nich wahr sein. 

In the same way, it is recognised that the embedded chain of symbols in the double brackets 

describes non phonological material: 

KLA: ... 

ERW: ((hustet)). 

KLA: ... 

KLA:  ((hustet)) Wa/? 

 

Troubleshooting and Segmentation 

Due to the fact that the segmentation algorithm relies on the regularities of the transcription 

system, segmentation problems may arise when these regularities are not adhered to while 

transcribing, i.e. when certain transcription symbols are not used as specified by the convention. 

In the following example the non-phonological unit “hustet” is not marked as defined by the 

convention, i.e. with a pair of round brackets at the beginning and at the end, as specified in 

HIAT. Here the brackets at the end of event in the transcription tier are missing: 

 

Menu items that require a segmentation (e.g. Transcription > Count Segments…) will prompt 

the following error message:  
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This contains information on the cause of the error – “Only close parenthesis allowed”, means 

that at the position in question only one closing bracket may be inserted and allows the editing of 

all segmentation errors in one dialog (see Transcription > Segmentation errors…). 

 

Segmentation: “GENERIC: Words” 

With a transcription segmented with the “GENERIC” algorithm, you can create word lists and 

segment chains. The GENERIC segmentation discriminates between words and punctuation 

(including spaces). Note, that no segmentation errors will be reported. 

 

Segmentation: “HIAT: Utterance and Words” 

All signs that are not listed in the following table will be treated as parts of words in the 

EXMARaLDA Partitur-Editor (as long as they are part of a non-phonological entry).  

 
Name Standard Values Explanation 

UtteranceEndSymbols . | ! | ? | … | ˙ | Mark the end of an utterance 

(followed by a space if desired). 

SpaceSymbols | Marks the end of a word or is 

placed after an Utterance End 

Symbol or  

“other punctuation”. 

Quote „ | Marks the beginning and the end 

of reported speech. Utterance End 

Symbols within reported speech 

are ignored. 

OpenParenthesis ( | A double occurrence marks the 

beginning of a non-phonological 

segment.  

A single occurrence is treated like 

“other punctuation”. 

CloseParenthesis ) | A double occurrence marks the 

end of a non-phonological 

segment.  

A single occurrence is treated like 

“other punctuation”. 
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MiscellaneousPunctuation ' | : | ; | , | - | _ | ‿ | — | / | Marks intra-segmental phenomena 

and is segmented like punctuation. 

PauseSymbols • | · | Marks pauses and it will be 

segmented like non-phonological 

data. 

Example: 

The second segment chain of speaker A is segmented with the Segmentation: “HIAT: Utterance 

and Words”... 

 

... into utterances, words (W), punctuation (IP) and non-phonological segments (Non-Pho): 

 

Segment chain 

Utterance Utterance 

W IP Non-

Pho 

IP W IP W IP W IP W IP Non-

Pho 

IP W I

P 

Wie  •  geht  es  Dir ? Alles (( hustet )) klar ? 

 

 

 

Possible errors 

Cause Example Error message 

Speaker’s utterance starts 

with closing parentheses. 

) Ich mache eine Äußerung Error: No parentheses 

closing, No utterance end 

symbol, No end of input 

allowed 

Speaker’s utterance starts 

with an utterance end 

symbol. 

! Ich mache eine Äußerung Error: No parentheses 

closing, No utterance end 

symbol, No end of input 

allowed 

Utterance end symbol is 

followed by closing 

parentheses. 

Ich mache eine (Äußerung.) Error: No closed 

parenthesis, no further 

utterance end symbol 

allowed 

Utterance end symbol 

followed by utterance end 

symbol. 

Ich mache eine Äußerung.! Error: No closed 

parenthesis, no further 

utterance end symbol 

allowed 

Utterance end symbol and 

space are followed by closing 

parentheses. 

Ich mache eine (Äußerung. ) Error: No close 

parenthesis, no utterance 

end symbol allowed 
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Possible errors 

Cause Example Error message 

Utterance end symbol and 

space are followed by 

utterance end symbol. 

Ich mache eine Äußerung. ! Error: No close 

parenthesis, no utterance 

end symbol allowed 

Pause symbols in double 

round parenthesis. 

Ich ((geht • zur Tür)) hau ab. Error: No end of input, no 

open parenthesis, no pause 

symbol allowed 

A third opening parentheses. Ich ((geht (oder rennt) zur 

Tür)) hau ab. 

Error: No end of input, no 

open parenthesis, no pause 

symbol allowed 

Speaker’s utterance ends 

without the double 

parenthesis having been 

closed. 

Ich hab Husten ((hustet. Error: No end of input, no 

open parenthesis, no pause 

symbol allowed 

After a double opening 

parentheses only one has 

been closed followed by 

another symbol. 

Ich ((hustet)mache eine 

Äußerung. 

Error: Only close 

parenthesis allowed 

Reported speech begins 

within a word. 

Ich mach“e eine Äußerung.“ Error: No opening quote 

allowed 

Utterance ends without 

reported speech having been 

ended by quotation marks. 

Und er sagt: „Ich mache eine 

Äußerung 

Error: No end of input 

allowed 

 

Segmentation: “DIDA: Words” 

All signs that are not listed in the following table will be treated as parts of words in the 

EXMARaLDA Partitur-Editor (as long as they are part of a non-phonological entry). 

Name Standard value Explanation 

CAPITALS A | B | C | D | E | F | G | H | I 

| J | K | L | M | N | O | P | Q | 

R | S | T | U | V | W | X | Y | 

Z | Ä | Ö | Ü | 

Only for the description of 

non-morphemised 

utterances, not as part of a 

word. 

PLUS + | Marks a quick connection 

to the beginning of a 

segment chain. 

NUMBERS_AND_COMMA 0 | 1 | 2 | 3 | 4 | 

5 | 6 | 7 | 8 | 9 | , | 

Only as part of time 

reference (as part of a 

pause or an 

incomprehensible section). 
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PAUSE * | Marks the beginning and 

the end of a pause. 

WORD_SEPARATORS → | ↟| ↑ | ↓ | < | > | - | / | Symbols for 

suprasegmental 

phenomena, are not part of 

words. 

EQUALS_SIGN = | Marks an elision or is 

placed into a non-

morphemised utterance. 

SPACE | Space can occur in various 

places, often marks the 

beginning or end of a 

segment. 

OPEN_PARENTHESIS ( | Marks the beginning of an 

incomprehensible section or 

one that is difficult to 

comprehend. 

CLOSE_PARENTHESIS ) | Marks the end of an 

incomprehensible section 

or one that is difficult to 

comprehend. 

OPEN_SQUARE_BRACKET [ | Marks the beginning of an 

ellipsis. 

CLOSE_SQUARE_BRACKET ] | Marks the end of an 

ellipsis. 

AMPERSAND & | A double occurrence marks 

the reference section in the 

speaker tier. 

PERIOD_OR_ELLIPSIS . | | … | Only within 

incomprehensible sections. 

COLON : | Either within a word (to 

characterise the length) or 

as part of time reference. 

Example: 

The second segment chain of speaker X is segmented with the 

segmentation: “DIDA: Utterance and Words”… 

 

... into utterances, words (W), punctuation (IP) and non-morphemised utterances (NMU) and 

pauses (PAUSE): 

 



EXMARaLDA Partitur-Editor – Manual  Segmentation Algorithms 

 
138 

Segment chain 

W IP NMU IP IP W IP IP W IP PAUSE IP W IP 

ja:“  HUSTET  ( was )  denn  *1,5*  sonst ↑ 

 

Possible errors 

Cause Cause Error message 

Capital letters within 

words 

jA Error: Nicht erlaubt: 

Großbuchstabe, offene 

Klammer, geschlossene 

Klammer, Punkt oder Ellipse, 

Zahl oder Komma 

Small letters within non- 

morphemised utterances 

Ich mache] eine Äußerung. Error: Nicht erlaubt: offene 

Klammer, geschlossene 

Klammer, Zahl oder Komma, 

Doppelpunkt, Punkt oder 

Ellipse, Pausenzeichen, 

Prosodiezeichen, 

Wortbestandteil 

Segmentation: “GAT: Intonation Units” 

Name Standard value Explanation 

IU_END_SYMBOLS ? | , | - | ; | . | Marks phrase-finals of a phrasing unit. 

OPEN_PARENTHESIS ( | Marks the beginning of a pause or of a 

section that is difficult to understand. Full 

stops in between round brackets will not be 

considered utterance end symbols of a 

phrasing unit.  

CLOSE_PARENTHESIS ) | Marks the end of a pause or of a section that 

is difficult to understand. Full stops in 

between round brackets will not be 

considered utterance end symbols of a 

phrasing unit. 

CLOSE_ANGLE > | Marks the end of a commentary annotation  

(e.g.: <laughing< what?>) and can occur after 

the final symbol of the phrasing unit. 

SPACE | Can occur after end symbol of the phrasing 

unit. 

EQUALS = | Marks elision of two phrasing units. If it 

occurs twice, the first symbol will be 

assigned to the phrasing unit and the second 

symbol will be assigned to the second 

phrasing unit. If it occurs once, the use of the 

space determines which phrasing unit the 

symbol will be assigned to. 
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Example: 

The following segment chain of speaker S1 is segmented into phrasing units (PU) with the 

segmentation: “GAT: Intonation Units”... 

 

... will be segmented as follows: 

Segment chain 

PU PU PU PU 

ja:; (.) die VIERziger 

generation so;= 

=das=s: !WA:HN!sinnig viele 

die sich da ham SCHEIden 

lassen.= 

=oder scheiden lassen 

ÜBERhaupt. 

 

Segmentation: “cGAT_MINIMAL: Words” 

Using the cGAT_MINIMAL segmentation algorithm, you can segment your segment chain in 

words instead of intonation units. Please note that capitalization and the use of apostrophes, 

hyphens and any diacritics will result in an error.  

 

  

Name Standard 

value 

Explanation Example 

UNDERSCORE _ indicates elision  let_s 

PLUS_SYMBOL + marks unintelligibility +++++ 

PARENTHESIS ( ) A double occurrence 

marks a non-verbal 

segment. A single 

occurrence marks time 

specifications or 

segments difficult to 

understand 

((laughs))  

(.) 

(0.35) 

(think) 

(great/late) 

 

END_SYMBOL . Micro pause yes (.) I am  

DEGREE_SYBOL ° Inhalation and 

exhalation 

°hhh 

  hhh° 
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Segmentation: “CHAT: Utterance” 

Name Standard value 

PERIOD .  

QUESTION_MARK ?  

EXCLAMATION_MARK !   

SPACE  

Explanation: All CHAT utterance end symbols (both the “Basic Utterance terminators” as well 

as the “Special Utterance Terminators”, cf. MacWhiney 2000: 60 and 66 ff.) are combined from 

symbol chains that end in a full stop, a question mark or an exclamation mark. In addition, the 

segmentation algorithm allows one (optional) space after the utterance end symbol. 

Example: 

The following segment chain of speaker CHI is segmented into utterances (U) segmented with 

the segmentation: “CHAT: Utterance”... 

 

... will look following when segmented into utterances (U): 

Segment chain 

U U U U 

Mummy! I want something+... Something to drink. Can I? 

 

Segmentation: “CHAT_MINIMAL: Utterances and Words” 

The CHAT_MINIMAL segmentation allows not only a segmentation into utterances, but also 

segments the transcription into words. The segmentation values allowed match those of the 

CHAT segmentation algorithm. 

Segment chain 

U U 

W P W W W 

Mummy ! I  want  something 
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Segmentation: “IPA: Words and Syllables” 

The IPA segmentation algorithm segments a transcription done according to the IPA conventions 

into words and syllables. Details on these conventions were presented by 

Thoma, Dieter & Tracy, Rosemarie (2005): L1 and Early L2: What's the difference? Vortrag, 

DGfS-Jahrestagung in Köln. 

A written and published version of these conventions is currently not available. The conventions 

in respect to the symbols relevant for segmentation are relatively simple: word endings are 

marked by spaces, different syllables of a word are separated from another by full stops. Marking 

syllable boundaries is optional, i.e. word segmentation will take place independent of further 

separation into syllables. 

As opposed to the other segmentation algorithms, with IPA segmentation, tiers of type “T” will 

not be segmented by default. Only those “T” –type tiers that have been additionally assigned the 

category “v-pho” (please note the lower case) will be segmented. 

Name Standard value 

WordBoundaries <SPACE> 

SyllableBoundaries . 

Explanation: Words are separated from each other by spaces, syllables (optional) are separated 

from each other by full stops.  

There is no additional check whether the transcription symbols have been applied according to 

convention. In particular it is not checked, whether the symbols used are part of the IPA 

inventory. All symbols except for spaces and full stops, are interpreted as words or syllables. 

Example: 

The following segment chain of speaker X is segmented with the segmentation: “IPA: Words 

and Syllables”... 

 

... into words (w), syllables (sl), word boundaries (wb) and syllable boundaries (sb): 

Segment chain 

hɜns.xen klain giŋ a.lain ɪn di: wai.tə wɜlt hi.nain 
w wb w wb w wb w wb w wb w wb w wb w wb w 

hɜns.xen  klain  giŋ  a.lain  ɪn  di:  wai.tə  wɜlt  hi.nain 
sl  sl sl  sl  sl  sl sb sl  

... hɜns . xen  klain  giŋ  a . lain 
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Possible errors 

Cause Example Error message 

Two syllables or word 

boundaries come after one 

another. 

hɜns..xen 

hɜns .xen 

Error: No syllable or word 

boundary, no end of input 

allowed 

A segment chain begins 

with a word or syllable 

boundary. 

.hɜns.xen 

 

Error: No syllable or word 

boundary, no end of input 

allowed 
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VII. APPENDIX C: EXMARALDA AND STYLESHEETS 

 

What is a Stylesheet? 

A stylesheet is an XML document that contains instructions that can be “understood” and 

implemented by a given software (a stylesheet processor) designed to implement it. Normally a 

stylesheet is used to create a new XML or HTML document from a given XML document. Due 

to the fact that EXMARaLDA data is always XML-based data, the stylesheet technology is most 

suitable in data processing to establish a high flexibility with a relatively low amount of 

programming involved. It is not necessary to fully understand this technology in order to make 

use of stylesheets in the Partitur-Editor effectively. Therefore, no detailed explanation is 

delivered in this manual. Should you be interested to take a deeper look at this technology we 

recommend the following as an introductory work:  

Michael Fitzgerald (2003): Learning XSLT. O’Reilly. 

 

What is the purpose of Stylesheets? 

Within EXMARaLDA the purpose of the stylesheet is to take on reoccurring transcription tasks 

that are regular enough to be automated, yet the exact procedure relies on parameters that differ 

from user to user. Due to the fact that it is not possible to predict and integrate all potential 

parameters for these tasks into the Partitur-Editor, the Editor is equipped with a number of 

functions that allow for user defined parameters to be set for stylesheets. 

Examples of this tasks are: 

 When setting a new transcription, a specific number of tiers should be added for every 

speaker automatically. The parameters for this task can depend on the transcription 

conventions used, for example, for instance, if a transcription is made according to the HIAT 

conventions, every speaker needs a verbal tier, a tier for special pronunciation and a tier for 

comments. For a DIDA transcription, only a verbal tier and a comment tier are required per 

speaker, as well as a global comment tier. By using a suitable stylesheet in combination with 

the function File > New from speakertable..., this task can be automated: 
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 An existing transcription is to be formatted automatically subject to the tier types e.g. all tiers 

of category “v” should be formatted in “Arial, 12pt, bold” and all tiers of category “nv” 

should be formatted in “Times, 10pt, italic”. 

 A HIAT utterance list should be issued as an HTML file, the individual utterances should be 

numbered and all annotations and descriptions should be hidden. 

 

Where to get Stylesheets? 

There are three ways to get stylesheets for the use in the Partitur-Editor: 

 Download of a ready-to-use stylesheet from the EXMARaLDA website: The EXMARaLDA 

website offers a number of ready-to-use stylesheets to download. The majority of these 

stylesheets is designed for transcriptions with the transcription systems HIAT and DIDA. 

 Adapting an already existing stylesheet: The actual purpose of a stylesheet – i.e. the user-

dependent setting of parameters as an automated task – can only be fulfilled if the user creates 

the stylesheet in question by himself. For many users creating a stylesheet “from scratch” 

would be of too much effort. It often suffices to adjust a simple already existing stylesheet to 

the needs of the user (e.g. one of those found on the EXMARaLDA website). The following 

example illustrates why this option can be easier than learning the entire stylesheet language: 

The section to the left is a part of a stylesheet from the EXMARaLDA website. It assists in 

generating a format table. It defines that a tier of category “v” should be formatted in “Arial, 

normal, 16pt, black”. A modification of the stylesheet (see the section to the right) can leave 

the majority of the instructions unaltered and only change the sections highlighted in yellow: 

 

<!-- Format für verbale Spuren --> 

<xsl:when test=„@category='v'„> 
 <xsl:element name=„tier-format“> 

  <xsl:attribute name=„tierref“> 

   <xsl:value-of select=„@id“/> 
  </xsl:attribute> 

  <property name=„font-name“>Arial</property> 

  <property name=„font-face“>Plain</property> 
  <property name=„font-size“>16</property> 

  <property name=„font-color“>black</property> 

  […] 

 </xsl:element> 

</xsl:when> 

 

 
<!-- Format für verbale Spuren --> 

<xsl:when test=„@category='v'„> 

 <xsl:element name=„tier-format“> 
  <xsl:attribute name=„tierref“> 

   <xsl:value-of select=„@id“/> 

  </xsl:attribute> 
  <property name=„font-name“>Times</property> 

  <property name=„font-face“>Italic</property> 

  <property name=„font-size“>12</property> 
  <property name=„font-color“>blue</property> 

  […] 

 </xsl:element> 
</xsl:when> 

 

Arial Times 

 Creating own stylesheets: Creating own stylesheets is both the most complex and the most 

extensive method. A knowledge of the code of the Partitur-Editor is not required, it suffices to 

be familiar with the structures of EXMARaLDA XML files. 

 

Using Stylesheets in the Partitur-Editor 

To be able to use stylesheets in the Partitur-Editor, the stylesheets that you would like to make 

use of need to be defined under Edit > Preferences…> Stylesheets. Thereafter the functions 

in question can be called. There are five functions in the Partitur-Editor that allow their 

parameter to be set with stylesheets: 
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1. File > New from speakertable... 

This is the option illustrated above, it allows tiers in a new transcription to be generated 

automatically from the speakertable. 

2. File > Output... > HTML partitur 

Here, a stylesheet can be used to issue meta information and speakertables (the so-called 

“transcription head”) in a user-defined way. For example, different stylesheets can be used to 

issue the attribute name in different languages: 

Without stylesheet: 

 

With “Head2HTML_de.xsl”: 

 

3. File > Output... > Free stylesheet transformation 

Here the stylesheet is applied to the entire basic transcription. In this manner, representations of 

the transcription in musical score or column notation or as a list of events for example are 

generated: 

With “BT2ColumnHTML.xsl”: 
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With “BT2PartiturHTML.xsl”: 

 

With “BT2EventListHTML.xsl”: 

 

4. Format > Apply stylesheet 

Here, a format table is created from the transcription with the help of a stylesheet and used in the 

Editor afterward.  

5. Segmentation > HIAT segmentation > Utterance list (HTML) 

Here, a stylesheet is applied to an utterance list – this is a “list transcription” that is segmented 

into utterances in accordance to HIAT: 

Without stylesheet: 
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With “HIAT_PlainUtteranceList_Tbl.xsl”: 

 

With “HIAT_PlainUtteranceList_Txt.xsl”: 

 

With “HIAT_ColoredUtteranceList.xsl”: 
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VIII. APPENDIX D: SHORTCUT OVERVIEW 

 

Note to Macintosh users:   For most shortcuts, CTRL corresponds to ⌘. 

Note to German users:   For German keyboards, CTRL corresponds to STRG. 

 

1. Audio / Video Player 

CTRL + SPACE Play selection 

CTRL + SHIFT + SPACE Play last second of selection 

CTRL + F4 Play 

CTRL + F5 Pause 

CTRL + F6 Stop 

2. Waveform display / selection 

 MOUSE WHEEL move left selection boundary (when near left 

boundary) 

move right selection boundary (when near right 

boundary) 

move selection (when near selection centre) 

ALT + SHIFT +  Decrease selection start 

ALT + SHIFT +  Increase selection start 

ALT +  Decrease selection end 

ALT +  Increase selection end 

CTRL + SHIFT  + S Shift selection 

CTRL + MOUSE WHEEL Zoom waveform in/out 

CTRL + SHIFT + MOUSE WHEEL Vertical zoom for waveform 

3. File menu 

CTRL + N New transcription... 

CTRL + O Open transcription... 

CTRL + S Save transcription... 

CTRL + P Print transcription... 
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4. Edit menu 

CTRL + Z Undo 

CTRL + C Copy 

CTRL + V Paste 

CTRL + X Cut 

CTRL + F Search in events... 

CTRL + W Find next 

CTRL + H Replace in events... 

CTRL + G Go to... 

CTRL + SHIFT + F EXAKT search... 

5. Tier menu 

CTRL + A Add tier... 

CTRL + I Insert tier... 

CTRL +  Move tier upwards 

CTRL + ALT + H Hide tier 

6. Event menu 

CTRL + ENTER Event properties... 

CTRL + D Remove event 

CTRL + SHIFT + R Shift characters to the right 

CTRL + SHIFT + L Shift characters to the left 

CTRL + 1 Merge events 

CTRL + 2 Split event 

CTRL + 3 Double split event 

CTRL + SHIFT +   Extend event to the right 

CTRL + SHIFT +  Extend event to the left 

CTRL + ALT +   Shrink event on the right 

CTRL + ALT +  Shrink event on the left 

CTRL +  Move event to the right 

CTRL +  Move event to the left 

CTRL + ALT + N Find next event 

7. Format menu 

CTRL + U Underline 

 

 


