How to get started with EXMARaLDA on the basis of the
Demo Corpus

This document explains how to install the EXMARaLDA tools and how to use the
EXMARaLDA demo corpus to get a first impression of the EXMARaLDA system.

More documents and literature can be found in the section “Help & Documentation” at the
EXMARaLDA homepage (http://www.exmaralda.org/en_hilfe.html).
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A. Installation of the tools

1. Download

You can download the EXMARaLDA tools from www.exmaralda.org/en _downloads.html.
The versions you find there are the most recent releases. Previews of upcoming versions can be
found at www.exmaralda.org/previews2.html.

Which and how many files you download depends on your operating system:
=  Windows: one installation file which contains all EXMARaLDA tools

= Macintosh: three icons each of which contains one EXMARaLDA tool

= Linux: one gnuzipped tar ball containing all EXMARaLDA tools

2. Java Runtime installation

In order for the tools to work, your computer needs a Java Runtime Environment (JRE). On
Macintosh, a JRE is preinstalled. On Windows or Linux, you can find out whether a JRE is
installed by typing "java -version" in a terminal window.

et C:\WINDOWS\system32\cmd.exe

Microsoft Windows XP [Uersion 5.1.26081]
(C)> Copyright 1985-2001 Microsoft Corp.

java version
Java(TM> SE Runtime Environment <(build 1.6.0_11-hB3)

Java HotSpot(TM> Client UM <(build 11.8-b16,. mixed mode, sharing?
C:\>_

http://java.com/en/download/manual.jsp. Please note that some Linux distributions come with a
preinstalled JRE which is not Sun/Oracle's JRE. EXMARaLDA does not work well with these =
preinstalled JREs. Replace them with the most recent Sun/Oracle JRE.

If no JRE is installed, you can freely download the newest JRE from Sun/Oracle at O
L/

3. Installation

Once you've downloaded the files appropriate for your system, installation should be

straightforward:

= Windows: double click "setup.exe" and follow the instructions

= Macintosh: mount the disk images and drag the included application file to some appropriate
place on your system

= Linux: unzip the tarball to some appropriate place on your system


http://www.exmaralda.org/en_downloads.html
http://www.exmaralda.org/previews2.html
http://java.com/en/download/manual.jsp

B. Demo corpus

A good way to get a first impression of the EXMARaLDA system is to have a look at the
EXMARaLDA demo corpus at http://www.exmaralda.org/corpora/en_demokorpus.html.

EXMARaLDA
Downloads
Tools
= Paritur Editor
= Corpus Manager

EXMARaLDA Demo Corpus

n EXAKT

o pus (71P-file, 39MB)
= TEI Dio Browse demo corpus Download demo corpus (ZIP-file, 39MB

The EXMARGLDA demo 2 small corpus with Wgich you carf functionality of the EXMARaLDA system.
Corpora
- - -
= Demonstration Gesprachstyp Machel 1 2 B 1o, SR ((aspice))
= SFB 538 Transcription Rudi e
project-name EXMARSTORT=m P! .

Users " HIAT EXMARaLDA: [Transcription] [Se B 20 SR Cenlest pas vrai
Ry — 0 L \isualisation: [Partiture] [RTF] [FI B21.. SR Cenlestpasvrai
nelp & ocumentalion cription-name  Pear Story = ((1,58))then | just left school and | sf
FAQS . ’ =i [E [ A1 E i [ B2 NS Cestfax Madame.
— Transkribent Annette Schnieder 1 ¢
HIAT documentation The dema corpus contains metadata for Al data are available in several Transaiptions are linked to the audio The demo corpus is multilingual (English,
Training communicetions and speakers transaription and presentation fermats German, Turkish, French, Spanish)
Publications The demo corpus contains the following recordings and transcriptions:
Linquistic Annotation Wiki
Contact =« Beckhams - An English talk show excerpt with David Beckham and his wife

Wonty Pythan: My Theory - An English franscription of Miss Elk presenting her theory on the brontosaurus (Any ressemblance with living linguists is purely

_ = coincidentialy
i 5! ?ﬁ = Paul McCartney: Interview - an English transcription of an interview with young, ambitionless Paul McCartney
= « Pear Story - An English transcription of a retelling of Wallace Chafe's Pear Story
=« Rudi Véller: Wutausbruch - a legendary fit of rage by the manager of the German national football team
Deutsche « Helge Schneider: Tropfsteinhdhle - a short audio play by the German artist Helge Schneider which contains many speaker overlaps
Forschungsgemeinschaft « Hubert Fichte: Interview - an interview which was conducted by the German writer Hubert Fichte in Hamburg's St.Pauli district
DFG = Helge Schneider: Arbeitsamt- another short audio play by Helge Schneider
« Studio Braun: English Translator - a telephone conversation between an unsuspecting seller of erasers and members of Studio Braun
L « Deutsche Bahn: Rossau - a telephone conversation between a man from saxony and the Deutsche Bahn railway timetable computer
* [Bﬁ':“aﬂif:':""'g'm"""‘ « Studio Braun: Forum Waffenrecht - another telephone conversation from Studio Braun
und Forschung « Hart aber fair - an excerpt from the TV talk show ‘Hart aber fair'
« Anne Will: Halbes Wahlrecht - an excerpt fram the TV talkshow "Anne Will"
- « Seriflssi Expertenauskuntt - a Turkish transcription of a telephone conversation between an expert on social matters and a somewhat confused caller
Universitit Hamburg i -
DER FORSCHUNG | AR LML | DER BLOUNG: I] » Royal: Deébat - a French transcription of an excerpt of the TV debate between Micolas Sarkozy and Ségolene Royal
() IhsTmur FOR = Savater: Hermandad - a Spanish t tion of tof a radio int ih the writer Fernanda Savat
\0S) DEUTSCHE SPRacHE « Savater: Hermandad - a Spanish transcription of an excerpt of a radio interview with the writer Fernando Savater
I I « Gasperini: Calcio - an Italian transcription of an excerpt of a TV interview with footballer Christian Panucci

SOURCEFORGE.NET*

You can start by browsing the online version of the corpus (1) — there are transcription examples
in several languages (see also "How to use an EXMARaLDA corpus™). You can then also
download a ZIP archive of the demo corpus (2). In the following three sections, it will be assumed
that you downloaded the demo corpus and unpacked it onto your system. The unpacked folder
structure (3) should look something like this:

@l\,j'l , « EXMARaLDA_DemoKorpus » Beckhams » - |¢, || Be
Organisieren « E Offnen = Brennen MNeuer Ordner
| EXMARELDA_DEWIDKDTFM\ o Name Anderungsdatum
. Almalls'MFreak o -
_ | export 12.01.201213:09
. AnneWill i R -
] | presentation 12.01.201213:09
. Arbeitsamt
. % Beckhams.exb 15.05.201210:13
. aussortiert = S
|| Beckhams.mp3 12.01.201212:58
. BatatasFritas & Beckh 08.07.2011 14:00
BC ams.m [NE- R Hii}
. Beckhams \ = P I
|| Beckhams.ogg 12.01.201212:59
. Buendnerfleisch / 3 - - -
. ¢ | Beckhams.wav 08.07.2011 14:00
. corpus-materials I .
) || Beckhams.webm 12.01.201212:37
. EnglishTranslator I -
) = Beckhams_s.exs 15.05.201210:13
. Fichte
. flashPlayer
. ForumWaffenrecht _
n / - 4 [ b
= Beckhams.exb Anderungsdatum: 15.05.2012 10:13
Exmaralda Basic Transcription GraBe: 20,5 KB




C. Partitur Editor

To get a first impression of the Partitur-Editor, start it...
... on Windows by selecting the appropriate entry in the start menu or by double clicking the

symbol on your desktop...

... on Macintosh by double clicking the application symbol

. on Linux by double clicking "partitureditor.sh” or by calling this shell script from a
terminal window (you may have to make the file executable before the first start...

. and open a basic transcription file from the demo corpus via File > Open (1). Basic
transcriptions can be found in all directories on the first level (i.e. 'Arbeitsamt’, EnglishTranslator'
etc.). They have the ending ".exb". For example, you could open "Beckhams/Beckhams.exb™ in
the Partitur-Editor:

¥ EXMARaLDA Partitur-Editor 1.5.2 [S\TP-Z2\DATEN\EXMARaLDA_DemoKorpus\Beckhams\Beckhams.exb] (o= ]=]
File Edit View Transcription Tier Event Timeline Format Help
B 3 ) & e ) e =) = + == +
&ﬁ[@‘uﬂ&.% mm-- IIIE‘=-3E--:|=-*£ EE*:—?_‘EQ J'u!f- 5
And\@t comes to as your determination 0
N\
\ 1 0:00 2.133 00:02.13
T T L ey
po:00 T 00:gz 00:03 00:04 00:05 00:06
S S T T T S S S S T T S I T T S S T S S T T S TSI T S S M
— S i

< [

s

v
ok Add event... ] [ E>] Append interval I 1] | B (™ [] Ep

0 [00:000] 1[0021] 2 [00:037] 3 [Q0:047] 4 100075

PAR B Jand what comes to as vour determination |at all cost (you) actually |((0,3s)) succeed. |I mean is that the sort of 2 message that you hope it comes accross to |((0,45)) to kis

VIC [v]

DAV ]

[nn]

4 |.m

‘ [14:04:59] Partitur-Editor started

Segmentation: HIAT Flayer: DirectShow-Player

To continue from here, have a look at following documents and videos:
Partitur-Editor video tutorial
Quickstart documents for the Partitur-Editor

Partitur-Editor Manual




D. Corpus Manager

To get a first impression of the Corpus Manager, start it (see above) and open the corpus file of
the demo corpus via File > Open Document (1). The corpus file is in the top level directory
and has the name "EXMARaLDA_DemoKorpus.coma”. After opening it, switch to the Data tab
(2) and browse through the lists on the left and right side to see meta-data about communications
(3) and speakers (4).

7 EXMARaLDA Coma | EXMARaLDA_DemoKorpus.coma | Corpus: DEMO-KORPUS (o= |[=]

File Edit View Tools Analysis Maintenance Help

N\,
.@ orpus| Data | { Basket (0}|

: Search 4 Filter
M
2 ons remove all filters |57 Speaker
/
o N *1|s sige Var
¢ communication Beckhams [#
ERW ERW -
1 Description (Communication)[ & Fichte Fichte
Background information Victoria und David Beckham sind zu Gast bei Parkinson :‘A :‘A
Helge S\neider: Tr Communication type  television interview WH WH
Studio Brun: EndglisH Project name EXMARaLDA DemoKorpus Ul Ul
Deutsche Bahn: Ros: 3 Source Parkinson Talkshow auf BBC 4 AT AMT
Studio Braun: Forum BS BS
g0l | Dé I ™
Ségolene Royal: Débat 2 Eﬁommunication {Lucation)M‘:' M M
Fernando Savater: Her... ?
Paul McCartney: Interview ? City London Gs Gs
Serif Issi; Expertenausk.., ? Country England e i
J J
pear Story ? PeriodStart 02.11.2007 20:30:00
Monty Python: My Theory ? BP BP
Hart aber fair 3 Description {Location) < SR SR
NTWschniki ? NS NS
Anne Wil: Halbes Wahlr... ? Languageﬁ‘%“ PP PP
Gasperini: Calcio ? = L - L AC AC
Nayuen Ngoc Ngan 3 ommunication (Language).< 3 =3 Fs
Telia-Telenor 2 LanguageCode eng (English) LR LR
s Majewski ? . INT INT
pedrame P Description (Language) ¥ pric pric =
— MOD MOD
Setting ANR ANR
Description (Setting)[<f : :
. _________________________________________________|
PRE PRE
o 1 Recording™® ELK LK
- . P P
Recording: Beckhams (00:04:25.636; 265636ms)= P rP
Description (Recording)[# FK FK
File: Beckhams/Beckhams.mpg Ei Ei
File: Beckhams/Beckhams wav HB HB
File: Beckhams/Beckhams.mp3 AW aw
File: Beckhams/Beckhams . webm E:‘; S:‘;
File: Beckhams/Beckhams.ogg aw aw
C C
oo
2 Transcriptions ™ P P
= b NN NN
Basic Transcription: Beckhams™= Rep Rep
Description (Transcription) < Sw205 Sw205
Nw202 Nw202
segmented false SzyM SzyM
File: (...Jeckhams/Beckhams_exb WojM WojM
. e Paw Paw
Segmented Transcription: Beckhams™ MagR MagR
Description (Transcription) & - SonB SonB -
& | 5 - .
ajs/ /| x-lae

To continue from here, have a look at following documents:
= Corpus Manager Manual
= Quickstart documents for Corpus Manager




E. EXAKT

To get a first impression of the query tool EXAKT, start it and open the corpus file of the demo
corpus via File > Open Corpus:

— The corpus file is in the top level directory and has the
oo korroe | 3 name "EXMARaLDA _DemoKorpus.coma”. Opening
e the corpus may take some seconds because EXAKT

13 transcriptions

620 seghweqt chains first creates an index, then a wordlist. The opened
\ 1 corpus (1) and the wordlist (2) will be displayed in the

section titled "Corpora” (3).

Waord lists

Word list for 0-KORPUS
2521 types 7870 s 2

A new concordance will be opened. Make a test query for the word 'the’ by entering the regular
expression \bthe\Db (1) in the text field beside the Search (2) button and hit enter to carry out
the query:

T EXMARaLDA EXAKT 12

o
=
g

File Edit View Concordance Columns Rows Regbx Help

R
Corpora DEMOORPUS (31 resuits) |
b
=] DEMO-KORPUS
SHTP.2,OA. Demokirpus.coms RegBe (1) - segas | ibthep - 8
21 transcripions.
e $ S Communicaton peaker  Left c(mh\ Match Right Context 35
63 am P hat's been isJowest, that's the marriage. what's been the lowest part of the of t ‘o
64 am t's the nice partofto-thre-marrig 1 lowest part of the of the marriage? There 1s ther
65 f'to the marriage what's been f the marriase? There is there is a piece in the B
66 am \__|e marriage. what's been the JoW marriage? There {s there is a pjece in the book w
(. (67 am \ | the of the eTe 1 ook which is quife quite moving actually. ((0.5
68 am oving actuall ) And 1t" e | the media accused David of having an affair, ((0
TEHEE 69 3 2 d it's 1t" e | media accused David of havine an affair. ((0.6s)) i
jord list for DEMO-KORPUS 70 am: [wasn't true. e torv? . . .
4836 types 15953 tokens 71 am But noneth 1t W e | papers it wa urm(ed and it affected vour relati W
72 am . You were looking out e | window and thinkin: ((0.8s))
it's it's it's ve/ yerv interesting e | book. ] hove vou, EDI time to finsh this book. vo
VIC ecause 1 know what I wanna do e | end of the day. I know that I'm puttine mvselfup
VIC ow what I wanna do I love wha, e | dav. [ know that I'm putting mvself uo for criti ]
71C mean | knew as son as [ met hi e one of the most attractiye things I found with D
VIC as soon as I met him. I mean (( e mu it attractl e thines [ fuund with David is that @,
/ 2s | fo W e a ou kno
Concordances c blv one of Ear dlﬂicul things to 11 @,
the C of the mo; tdlﬁis:ult thmz to act e | book, Obviou lv it 10 elv writing all the nice
DEMO-KORPUS C e in the book. Obviouslv. 1t's lo e |nice thines that' d but that was verv di
91 tokens C th of us. ((0.35)) Ehm vou know. e [time AndI thlnk that a few Ell’] wanted to laun i
bovpes) C hat thev want about me. ((0.4s)) e | one person and Brooklvn ((0.5s)) that is mine. Yo
34 VIC Actuallv, T took that out e [ book but .., ((laughing)) That ch veah. ((laughing)
85 AV [know. I didn't even have to mee e | telly and I just wanted to meet her. You know. I Types:
86 AV FEhm well we ran awav for e | weekend after that. And eh obviouslv the worst th E
87 AV awav for the weekend after that. e | worst thing for me was seeing Victoria hurt (in) [fokens o
38 AV ['s nothine that's gome on, ((0.6; e | hardest thine. And then vou know we tried to get clected:
89 AV there was times where ((0.4s)) e | room and it was verv depressing and then ((0.3s)) 51()
90 AV Eh w/ w/ we was on e | edge of eh ((unv.)). So it was eh verv temuted bu Time:
91 AV She got to that part veah in | k. -] 2
That was probably one of the most difficult things to actually write in the book. Obviously, i's lovely writing all the nice th “
v
m | Pertr
PR
inthe book. Obviously, its lovely writing all the nice things that've happened but that was very difficult | mean itwas really a (dramatic) time for ((0,4)) for hoth of us. (0,3¢)) ERM you knaw | was pr
DAV [v]
[nn]
« i '
@ Partiur () Lst ©) HIML

To continue from here, have a look at following documents:
e EXAKT manual
e Document “Quickstart Regular Expressions”



