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INTRODUCTION 

EXAKT – the “EXMARaLDA Analysis and Concordancing Tool” – is a tool for searching and 

analysing corpora of spoken language transcriptions as created by the EXMARaLDA Partitur-

Editor and the EXMARaLDA Corpus Manager.  

EXAKT’s base functionality is that of a concordancer – like WordSmith, MonoConc etc., it lets 

you enter a search expression and outputs all the instances which match this expression plus a bit 

of the preceding and the following context.  

On top of this base functionality, EXAKT enables you to: 

 display more interactional context as encoded in the transcription (e.g. things that other 

people said around the same time as the utterance matched by the search expression), 

 display situational context in the form of metadata about the communication in question, 

 display speaker metadata, 

 listen to the corresponding part of the transcribed (audio or video) recording,  

 filter your search results according to various criteria, 

 add one or more analyses to your list of search result, 

 save, retrieve, combine, output search results and export them to other applications (e.g. 

Excel, SPSS) for further analysis 

This document explains the functionality of EXAKT.  

Please note: If you are new to EXAKT (and maybe to EXMARaLDA and/or concordancers in 

general), we recommend that you download the EXMARaLDA demo corpus from 

(https://corpora.uni-hamburg.de/) and experiment with that before using EXAKT with your own 

data.  

Be advised that we now offer a few short English documents and video tutorials in the 

“Help&Support” menu on the EXMARaLDA website (www.exmaralda.org), which elaborate on 

the individual steps while working with EXMARaLDA (References to these documents have 

been marked in green in this user manual) 

https://corpora.uni-hamburg.de/drupal/en/islandora/object/spoken-corpus:demo
http://www.exmaralda.org/
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 OPENING OR GENERATING A CORPUS 1

1.1 Opening an existing corpus 

If you want to use EXAKT, you need an EXMARaLDA corpus which contains segmented 

transcriptions (you can create these in the Partitur-Editor with various options, go to Edit > 

Preferences> Segmentation, please consult the Partitur-Editor Manual for more 

information regarding this functionality).  

Maybe you are already using the EXMARaLDA corpus manager (CoMA) to manage your 

corpus and know what a “segmented transcription” is (otherwise consult Coma Manual). In that 

case, all you have to do in order to get started is to go to File > Open corpus… in EXAKT and 

select your corpus file (usually a file with a “.coma” suffix).   

Please note: For the EXMARaLDA demo corpus, the corpus file is the file 

“EXMARaLDA_DemoKorpus.coma” in the top level directory. 

 

1.2 Opening a remote corpus 

Whereas choosing File > Open corpus... will open a corpus whose COMA and transcription 

files are on your local computer, you can use File > Open remote corpus... to access a corpus 

that is not located on your own computer, but on a remote server.  

Please note:  

 you will need a broadband connection for this feature to work satisfactorily (other 

connections are too slow).  

 Media playback for remote corpora currently works only on Windows.. 

 If you decide to browse through the corpora of the former SFB “Multilingualism” available 

at www.corpora.uni-hamburg.de (Section “Resources”), you will need to check/register for 

access permission. EXMARaLDA demo corpus is not password-protected. 

Having chosen the latter option, the following dialog will pop up: 

 

http://www.corpora.uni-hamburg.de/
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Now, you have to click on the “book” symbol to browse through all available corpora from the 

SFB “Multilingualism”. A new dialog window will pop up. Here, choose an entry (left menu) 

and click OK – the correct URL will be entered for you. (Remember to check the access 

permission status). 

 

After you have chosen the corpus, a dialog with login request will appear. 

 If the corpus is password protected, you have to enter your username and password in the 

fields “Username” and “Password”, respectively, and then click OK.  

 If the corpus is not password-protected (as is the case with the EXMARaLDA demo corpus), 

tick the box “Anonymous login” to disable user authentication. Clicking on OK will open 

the remote corpus and display it in the corpus list in the left upper corner of the EXAKT 

window (compare also: screenshot in Section Generating a word list): 

 

You can then work with this corpus in the usual way, i.e. as if it was on your local computer. 

 

Click on the corpus to 

view the information in the 

right menu 

Click here to confirm 

your choice 
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1.3 Generating a word list 

After a corpus has been read and indexed, EXAKT checks whether the transcriptions in it have 

been segmented for words. This is the case if an appropriate segmentation algorithm has been 

used for the generation of segmented transcriptions. For instance, all HIAT corpora available 

from the SFB 538, including the EXMARaLDA Demo corpus, have this kind of word 

segmentation. If a corpus has been segmented for words, EXAKT asks you whether you want to 

create a word list for it. 

 

If you choose Yes, the word list will be created and displayed in the word list section of 

EXAKT. 

 

Double click on the word list to display it. See below for an explanation of how to use word lists. 

 

1.4 Generating a corpus from EXMARaLDA transcriptions 

If all you have is a set of basic transcriptions created with the Partitur-Editor, EXAKT offers you 

an easy way to turn those into a corpus.  

Step 1: “Coma file” 

First you have to make sure that all your basic transcriptions are underneath a single folder in 

your file system. Let’s assume this folder is called “c:\my_corpus”.  

You can then choose File > Generate corpus… from EXAKT’s menu. This will start the 

corpus creation wizard.  

Word list(s) 
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You will be asked to enter a name for your corpus (“Name of corpus”, in our example it is 

“test_corpus”) and to choose a path for the corpus manager file (“Coma file”). For the latter, 

choose the folder underneath which your corpus data can be found (i.e. “c:\my_corpus” in our 

example).  

The wizard will then automatically scan this folder for any transcriptions contained in it and its 

subfolders. 

 

As soon as the procedure is finished, you can click on next >, and thus the transcriptions will be 

displayed in a table. 

Step 2: “Transcriptions” 

 

The second column of this table contains the transcription’s name. The first column tells you 

whether or not it will be included in the corpus, and the last column tells you whether it is a 

segmented transcription (if it isn’t, it is a basic transcription). You can recognize which type of 
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transcription is in question based on its suffix: “.exb” for basic, and “.exs” for segmented 

transcription, respectively. You can change the selections in the first column according to your 

preference with regard to which transcriptions you want to include in your corpus. If you’re 

done, click on next >. 

Step 3: “Segmentation” 

The next dialog is about creating a segmented version of each of the selected basic 

transcriptions. 

   

If you want to keep things simple, you should choose the following parameters in this dialog: 

 Segment transcriptions…: tick this box and it tells the wizard that transcriptions are to be 

segmented; 

 segmentation algorithm: choose “default”; 

 on segmentation errors…: since the default segmentation algorithm never produces any 

errors, it is not important what you choose in this field; 

 target: choose “new directory”; this tells the wizard to write the resulting segmented 

transcriptions into a new folder rather than place them side-by-side with the original basic 

transcriptions; 

 suffix; finally, choose “_s” as a suffix for the newly created segmented transcriptions; 

choosing a suffix will make sure that basic and segmented transcriptions have systematically 

different names. 

When you’re done specifying the segmentation parameters, click next >.  

Step 4: “Metadata assignment” 

The next dialog is about metadata you have entered in your transcriptions (i.e. with the help of 

Transcription > Meta information in the EXMARaLDA Partitur-Editor). 
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For each such a metadata field (second column), the wizard asks you whether to include it in 

your corpus (tick the respective box in the first column), what to call it in the corpus (third 

column), and whether to assign it to a communication or to a transcription (fourth column). 

The most important field is at the bottom of the table: it lets you specify how the wizard 

determines the name of communications and how it assigns transcriptions to communications. 

Click on next > once you have specified everything.  

Step 5: “Speakers” 

The last dialog is about the speakers of the corpus. 

 

The wizard asks you for a “unique speaker distinction” at the bottom of the dialog. Usually, 

you will have chosen abbreviations in the EXMARaLDA transcriptions to be unique for each 

speaker (i.e. no two different speakers will share the same abbreviation). Only if this is not the 
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case, do you need to specify a different unique speaker distinction. Clicking on next > will get 

you to a summary of the parameters you have set for the wizard. 

Step 6: “Summary” 

 

If you now click on finish your corpus will be created, saved under the name you specified in 

Step 1 and loaded in EXAKT. 

 

1.5 Generating a corpus from FOLKER transcriptions 

Via File > FOLKER corpus... you can start a wizard for creating an EXMARaLDA corpus 

from a set of FOLKER transcriptions (FOLKER is a transcription editor published by the IDS at 

Mannheim, see http://agd.ids-mannheim.de/html/folker.shtml).  

The wizard is similar to the one described in the previous section. Since FOLKER does not store 

any transcription or speaker metadata, steps 4 and 5 are skipped.  

The wizard itself contains some additional instructions for each step in the corpus generation. 

Step 1: “Corpus file” 

Specify a .coma file for which the resulting corpus will be written. Click Browse… and choose a 

directory on you local computer, in our example it is “c:\mycorpus\test_corpus.coma”: 

http://agd.ids-mannheim.de/html/folker.shtml
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Click on next > once you have specified everything. 

Step 2: “Transcription(s)” 

Select FOLKER transcriptions to be included in the corpus. For this, tick/untick the trancriptions 

from the first colum “Include”: 

 

Click on next > once you have specified everything. 

Step 3: “Parameters” 



EXMARaLDA EXAKT – Manual  Opening or generating  a corpus 

13 
 

Select where EXAKT should write EXMARaLDA transcriptions (you can either have the file 

written “…to a separate directory” or “…to the same directory as the original file”, you can 

also “Generate Basic Transcriptions” it you tick the box).  

 

If you now click on finish, your corpus will be created, saved under the name you specified in 

Step 1 and loaded in EXAKT. 

 

1.6 Generating a corpus from CHAT transcriptions 

Via File > CHAT corpus... you can start a wizard for creating an EXMARaLDA corpus from a 

set of CHAT transcriptions (CHAT is the file format written by the CLAN editor from the 

CHILDES system, see http://childes.psy.cmu.edu/). The wizard works in a similar fashion to the 

one described in the previous section.  

 

1.7 Generating a corpus from ELAN annotation files 

Via File > ELAN corpus... you can start a wizard for creating an EXMARaLDA corpus from a 

set of ELAN annotation files (see http://tla.mpi.nl/tools/tla-tools/elan/). The wizard works in a 

similar fashion to the one described above.  

 

1.8 Generating a corpus from Transcriber files 

Via File > Transcriber corpus... you can start a wizard for creating an EXMARaLDA corpus 

from a set of Transcriber files (http://trans.sourceforge.net/). The wizard works in a similar 

fashion to the one described above. 

http://childes.psy.cmu.edu/
http://tla.mpi.nl/tools/tla-tools/elan/
http://trans.sourceforge.net/
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 WORKING WITH CONCORDANCES 2

2.1 Creating a new concordance 

Once you’ve successfully opened or generated a corpus, EXAKT will display this corpus in the 

left upper corner of the screen:  

 

 

It will also tell you how many transcriptions and how many segment chains the corpus contains. 

Please note: you can have several different corpora opened in this list. 

To create a new concordance for a given corpus, make sure that this corpus is selected in the 

corpus list, then click on Concordance > New concordance:  

 

Normally, one such concordance is created automatically after you’ve opened a corpus: 
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2.2 Understanding concordances 

You now have a concordance for this corpus which is also shown in the concordance list 

underneath the corpus list (see graphic above).  

Please note: you can have several concordances for one and the same corpus.  

In general, a concordance consists of 

 a part for entering search expressions (upper part of the concordance window) 

 a part for displaying the KWIC (keyword in context concordance) table (centre of the 

concordance window) 

 and a part for displaying additional context (lower part of the concordance window) 

To start, enter a simple, frequent word (e.g. “the” for an English corpus, “was” for a German 

corpus) in the field beside the Search button and hit the Enter key.  

You will be given a KWIC concordance displaying all the places in the corpus which match your 

word (in our example, it is “the”): 

Concordance 

window 

Search for i.e. 

Regular 

Expressions 

Concordance list 
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The KWIC concordance contains the following information: 

 column 1: “#” simply counts line numbers for better orientation 

 column 2. “S” tells you whether the search result in this row is selected or not 

 column 3: “Communication” gives you the communication in which the search result was 

found 

 column 4: “Speaker” gives you the speaker of the utterance in question 

 columns 5 and 7: “Left Context/Right Contex”t contain the left and right context of that 

search result 

 column 6: “Match” contains the actual search result, i.e. the transcribed text which matched 

your search expression 

 

You can sort the table by clicking on any column header. Text in the left context column will be 

sorted reversely so that words closer to the matched text get the priority. This makes it easier to 

discover similarities or patterns in the left context. 
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You can reduce or increase the amount of text in the left and right context columns by clicking 

on the buttons  and , respectively.  

Selecting one search result will also display the corresponding text in the lower left corner below 

the concordance window.  

 

 

2.3 Going from a search result to the transcription 

If you double click on a search result, the corresponding transcription will be opened in the lower 

part of the screen. You can choose to display the transcription as a “Partitur”, as a “List”, or as 

a “HTML” document generated through a stylesheet transformation.  

You make this choice by selecting the appropriate “radio” button from the list in the lower part 

of the screen: 

 

Option 1: If you’ve chosen the “Partitur”, the transcription will be displayed as a musical score, 

as in the Partitur-Editor. The event containing the search result is highlighted: 

 

You can freely navigate in this transcription to explore the context of the search result.  

If your transcription is aligned with an audio or video file, you can use the “Play” button to 

playback the corresponding part of the recording.  

Option 2: If you’ve chosen the “List”, the transcription will be displayed as a list of segment 

chains.  

Play button 

Search result 
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The segment chain containing the search result is highlighted: 

 

Double clicking on any line will playback media aligned with this line. A subsequent single click 

stops the media player. 

Option 3: If you’ve chosen the “HTML”, the transcription will be displayed as a list of segment 

chains according to the output: 

 

This option does not provide playback for audio files.  

 

2.4 Using the Praat Panel 

The Praat panel can be used to display and play single audio sequences of the search results in 

Praat (http://www.fon.hum.uva.nl/praat/).  

In order to use the Praat Panel in EXAKT, it has to be configured in the Partitur-Editor (for more 

information on how to configure the panel consult the section Praat Panel in the Partitur-

Editor Manual, the manual is available on www.exmaralda.org, Section “Help/Support”).  

Please note: Praat has to be opened in the background whenever you want to use its 

functionality.  

Choose the search result that should be displayed in Praat (1) and click the Praat button (2).  

The section of the event that contains the search result will be displayed in Praat (3).  

http://www.exmaralda.org/
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Praat will open in a new window (with usual functions):  

 

 

2.5 Outputting and saving search results 

In order to print your search results, use them inside a word processor (e.g. MS Word) or further 

process them in some other application (e.g. MS Excel), you have several options.  

Choose Concordance > Save Concordance as... in order to save the whole KWIC 

concordance to a file. The file dialog gives you a choice between “HTML” and “XML”.  

1 

3 

2 
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Saving as “HTML” enables you to open the resulting file in a browser, in a word processor or in 

any other application which reads HTML (e.g. MS Excel). By default, a built-in stylesheet is 

used to generate the HTML. In a browser, an exported HTML will look something like this: 

 

If you want to change the appearance, you can write a custom XSL stylesheet and tell EXAKT to 

use it, please apply appropriate settings via Edit > EXAKT Preferences... > Stylesheets > 

Concordance Output. 

If you want to copy and paste a selection of search results into your word processor, simply 

make the selection inside the concordance then choose Edit > Copy Selection or press the 

“Copy” button beside the concordance. The selected search results will be copied to the 

clipboard and you can paste them from there. 
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The graphic below offers a visualisation after pasting a selection of search results into the word 

processor: 

 

You can also use Ctrl + C on your keyboard, or the “Copy” button from the Partitur’s context 

menu (below concordance window in EXAKT) to copy a part of the transcription to the 

clipboard: Simply select the part you wish to copy, right-click on it and choose “Copy” or use 

the keyboard shortcuts: 

 

Copy button 
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The graphic below offers a visualisation after pasting a selection of search results into the word 

processor: 

 

Sometimes (especially if you have added manual annotations to a KWIC concordance), you 

might want to save a search result in order to re-open it in EXAKT itself.  

To do so, proceed as follows: 

1) Choose Concordance > Save Concordance as... 

2) Select the “XML” option and specify a filename 

3) To reopen the search result: first open the corpus from which it was derived 

4) Then select this corpus in the corpus list and choose Concordance > Open concordance... 

Of course, you can also use the exported XML file to do your own further processing of the 

search results (e.g. by transforming them via an XSL stylesheet). 
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 SEARCH EXPRESSIONS 3

EXAKT supports different forms of search expressions. The types of searches differ either in the 

type of the search method or in the area where the search will be conducted.  

The following two chapters will explain the main search methods that are used in EXAKT, 

whereas Chapter Fehler! Verweisquelle konnte nicht gefunden werden. will also discuss the 

different search areas. 

 

3.1 Regular Expressions 

Search expressions can be more than simple strings. In order to find complex patterns in the 

corpus, you can use regular expressions as search expressions (for more information, consult 

the Quickstart Regular Expressions available at www.exmaralda.org in Section 

“Help/Support”).  

A regular expression is a text pattern consisting of ordinary characters and meta-characters. This 

text pattern is then  matched against simple strings. Here are some examples: 

 The pattern [Ww]as will match the strings “was” and “Was”. 

 The pattern komm.{1,2} will match “komme”, “kommst”, “kommen”, “komma”, “kommun” 

etc. 

 The pattern ([Ii]ch|[Dd]u) will match “ich”, “Ich”, “du” and “Du” 

 The pattern \bge[A-Za-z]+?t\b will match “gemacht”, “gesagt”, “gewusst”, “geht” etc. 

 [Tt]h(is|at|ose|ese) will match the words “this”, “that”, “those” and “these” and 

their capitalized variants. 

 \bin[a-z]+abl[ey]\b will match words starting with “in-” and ending in “-able” or  

“-ably” like “indisputable”, “indescribably”, “ineffable”, “indistinguishable” etc. 

 (\b[A-Za-z]+\b){3,3}\? will match all sequences of three words followed by a 

question mark, i.e. the last three words of questions 

 \btou(s|t|te|tes)\b will match the French quantifier words “tous”, “tout”, “toute et 

toutes” 

 \b([MmTtSs](a|on|es)|[Ll]eur(s)?|[VvNn](os|ôtre))\b will match all French 

possessive pronouns (“mon”, “ma”, “mes”, “ton”, “ta”, “tes” etc.)  

 The pattern ^.*$ will match every event of the transcription 

By combining regular expressions in various ways, you can formulate rather complex queries 

with them. Useful as they are, regular expressions are not very easy to learn. There are many 

books and websites explaining regular expressions. We recommend that you consult at least one 

of those and use it as a reference when working with EXAKT.  

http://www.exmaralda.org/
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For those who are not afraid of formal specifications, the exact syntax and usage of regular 

expressions is explained at: http://java.sun.com/javase/6/docs/api/java/util/regex/Pattern.html.  

Moreover, EXAKT provides help in several places whenever you’ll be working with regular 

expressions. The simplest option is provides with the context menu in the Search: text field 

which lists some commonly used meta-characters.  

To open it, right click into the search expression text field. Choose any entry in that context 

menu to paste the respective character into the search expression text field: 

 

If you click on the Search: button on the left, a dialog will pop up that will helps you in 

formulating some commonly used types of regular expression. 

 

For example, if you want to look for all words starting with “in” or “on”, you could proceed as 

follows: 
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 Choose the “Alphabet:” you want to work with. The “Default” is the English alphabet with 

the letters a-z and their capitalized variants. Other alphabets have additional characters, e.g. 

German has the Umlauts “ä”, “ö” and “ü” and the “sharp s”, “ß”. 

 enter the string “in” in the field “Word starts with:” and press the button ! (exclamation 

mark) 

 press the button OR (situated in the top menu, second to the right) 

 enter the string “un” in the field “Word starts with:” and press the button button ! 

(exclamation mark) 

 press Enter to paste the whole search expression into the search expression text field of the 

concordance and close the help dialog 

The expression you constructed should then look something like this: 

\bin[A-Za-z]*\b|\bun[A-Za-z]*\b 

A third type of help is to be found under the menu item RegEx > Regex Library Dialog. This 

will bring up a dialog with different regular expression libraries.  

One of them – the “EXMARaLDA Regex Library” – is built into EXAKT. It contains some 

commonly used search patterns for different languages and different transcription systems.  

A second one – the “user-library” – can be used to store and describe your own regular 

expressions for reuse.  

Finally, one or more “remote libraries” which are stored under some URL in the WWW can be 

loaded by clicking on the Add library... button. 
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Libraries are organised into a “tree of folders”. Each entry in such a folder consists of the regular 

expression itself, a description saying what the expression will match, an explanation of how it 

will match it, and a few examples of matching strings.  

If you want to use the displayed entry, simply click on Paste to search expression text field 

button. In order to add your own entry to the user-library, enter an expression in the 

concordance, apply it to the corpus and then choose RegEx > Add to library.... 

The following dialog will come up in which you can enter a name (field: “Regular 

Expression:”, a “Description” and an “Explanation” for the new entry. 

Some examples taken from the current search result will be automatically provided. 

 

Clicking on OK will add the entry to the user-library. The user-library is saved when you exit 

EXAKT so that all entries you have added will still be available at the next start. 

 

3.2 XPath Expressions 

Besides Regular expressions, XPath expressions can be used to search the corpus. XPath (XML 

Path Language) expressions do not match strings, but find parts in .xml documents. In EXAKT, 

those XPath expressions will be applied to the .exs files of the corpus that is currently opened. In 

In order to work with XPaths in EXAKT, you should be familiar with the structure of the .exs 

files and the syntax of XPath expressions. 

Please note: that the XPath searches are restricted to the “segmentation” nodes. You can choose 

between the “SpeakerContribution_Utterance_Word” node and the "SpeakerContribution_Event" 

node via thedrop-down-menu. That means your search will only be applied to the node you 

chose. 
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Short overview of the syntax of XPath expressions:  

 start of the path: /  represents the absolute path to (only) one element 

 start of the path: // chooses every element that meets the XPath criteria 

 [ ] are used to specify the element further 

 @ is used to specify an attribute  

 /child:: chooses the (directly following) children of the context node, can also be shortened to 

just / 

 // (recursive descent operator) addresses every element that is located in a subordinated layer 

of the context node, regardless of the further branching 

For example, if you choose “SpeakerContribution_Utterance_Word” and enter the XPath  

//segmented-tier[@speaker='SPK0']//ts[@n='HIAT:u'] 

you will get every utterance of the HIAT segmentation of every speaker “SPK0” of the corpus. 

Please note that this will find different speakers of different transcriptions that just share the 

same, arbitrary speaker numbering. The XPath will search every .exs file for every “<ts>” 

element with the attribute “n = ‘HIAT:u’” (=that is an utterance) subordinated by a segmented-

tier node with the attribute “speaker =’SPK0’” (=that belongs to the speaker 0).  

 

 

(See also Section XPath Search over Transcription tiers [XPath (T)].) 
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 DISPLAYING METADATA 4

Once you have carried out a search, you can display metadata, i.e. data about speakers, 

communications or transcriptions in additional columns of your KWIC concordance.  

 

Click on the “Metadata” button or choose Columns > Metadata..... The following dialog is 

displayed: 

 

Metadata button 

Metadata attributes 
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It lists metadata attributes for different entities of the corpus – the speakers, the 

communications and the transcriptions. You can select any number of these attributes by 

double-clicking on them or by selecting them and clicking on the corresponding  button. 

When you close the dialog by clicking on OK, each selected metadata attribute(s) will be given 

an additional column in the KWIC concordance, and the corresponding values will be displayed 

in that column. 

 

These metadata columns can be sorted and filtered just like the other columns of the KWIC 

concordance. If you now select a search result, its metadata will also be displayed in the right 

text field below the KWIC concordance. 

 

To edit or remove the metadata columns, click the “Metadata” button again, remove the current 

metadata column with  and, optionally, add new metadata columns as explained before. 

 

Metadata columns 

Metadata display for the 

selected search result 
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 ADDING ANALYSIS COLUMNS 5

In order to classify or categorize your search results, you can add one or several analysis 

columns to the KWIC concordance. Click on the “Add analysis...” button on the right side of 

the application or choose Columns > Add analysis... 

 

This will display the following dialog (Please note that depending on which “Analysis type:” is 

chosen, the layout will differ) 

 

Enter a name for your analysis column in the “Analysis name:” field. Under “Analysis type:”, 

you can choose between three types of analyses: 

 Free analysis lets you enter an arbitrary text. This can be useful, for instance, for making free 

comments on individual search results. 

 Closed category list analysis lets you choose from a predefined set of categories. Enter the 

list of categories into the provided text field, separating individual categories with a comma. 

 Binary analysis lets you tick or untick a check box for each search result. This can be useful, 

for instance, to manually distinguish relevant from irrelevant search results. 

“Add analysis” button 
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When you close the dialog by clicking on OK, an additional column in the KWIC concordance 

will be created in which you can carry out your analysis: 

 

Analysis columns (i.e. “Mode” in the above graphic) can be sorted and filtered just like the other 

columns of the KWIC concordance. In order to edit, remove and calculate analysis columns, 

right-click on the desired column. You can change the type of the analysis via “Edit analysis”: 

 

If you click on “Calculate analysis”, the following window opens: 

 

You can use this function to calculate the age of a speaker at the time of a recording, for 

example. 

Analysis column 
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 ADDING ANNOTATION COLUMNS 6

Another possibility to add more information to your search results is to add annotations that were 

made in the corpus. To do so, open the menu Columns and choose Add annotation…. 

In the “Annotation category” drop-down menu, every annotation tier (that exits in the corpus) 

will be listed. Choose the desired “Annotation category” and select the appropriate “Overlap 

type”.  

 

The “Overlap type” depends of the sort of the annotation and the sort of the search results. For 

example, if an annotation corresponds to single words and your search was aimed at finding 

single words, you should choose “Exact” as overlap type. 

 

c 
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 FILTERING SEARCH RESULTS 7

Often, your list of search results contains some unwanted or irrelevant instances. In order to get 

rid of those you can have two options. 

Option 1: is designed to manually go through the KWIC concordance and unselect the unwanted 

instances in the column with the check boxes. 

 

If you then click on the “trash bin” button on the right side of the window, all unselected search 

results will be removed from the concordance. 

 

You will be asked for conformation, click 

OK.  

 

Remove unselected search results 

Select/Unselect column 
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Option 2: Herewith, you can automatically filter your concordance according to certain criteria. 

Click on the “Filter” button to the right of the search button. 

  

This will open the following dialog: 

 

Under “Column:”, you can specify the column in the concordance according to which you want 

to filter. Whenever you click Filter:, you can specify a filter in the form of a regular expression 

(see Section Regular Expressions). The example in the above screenshot shows a filter that will 

go through the “Speaker” column of the concordance and select all search results in which the 

value in that column matches the regular expression...  

HB|ELK|PMC 

...and unselect all search results which do not match the expression. In order to switch the roles 

of selected and unselected search results, tick the box “Invert filter”. 

Clicking on OK will give you a KWIC concordance in which the selection check boxes are 

ticked according to your filter. You can then throw away unselected search results as described 

above. 

A useful help for many filtering tasks is the token list, i.e. a list containing all distinct forms from 

a column. If you click on the Filter: button such a list will be displayed for the currently selected 

columns (this will not work for the left and right context columns, though). 

Filter button 
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The “Unselected” list displays all tokens found in the column. You can add tokens to the 

“Selected” list by clicking on >. Clicking on Add will produce a regular expression 

corresponding to the selected tokens. By pressing Enter, you can paste this expression into the 

Filter dialog. 

c c 
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 USING WORD LISTS 8

If you open a corpus which has been segmented for words (this 

depends on the segmentation algorithm used), EXAKT offers 

you the possibility to generate and use a word list. All word lists 

are displayed on the left hand side under “Word lists”. 

 

 

 

 

 

 

 

 

 

If you double click on an entry of that list, a dialog of the following type will be displayed: 

 

Word list(s)
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This lists all the word types occurring in the corpus together with their frequency. Click on the 

table header to sort words alphabetically or by their frequency. Click on “Save wordlist...” to 

generate a HTML version of the wordlist. You can filter the list using a regular expression. On 

the right side of the dialog, you have a list with selected words. Double click on any entry in the 

word list or click on the button with the plus sign to add a word to the selection.  

Clicking on the button Regex will copy a regular expression to the clipboard with which 

EXAKT can search exactly those word forms contained in the selection list.  

 

Click on the search expression text field and press Ctrl + V to paste that regular expression into 

the field. 

 

Above the selection list, you have three buttons for automatically extending the selection via a 

Levenshtein function.  

The Levensthein Distance between two strings A and B is defined as the minimal number of 

insertion, deletion or substitution operations necessary to get from A to B. For example, the 

Levenshtein distance between car and war or between run and runs is 1, because it requires one 

substitution or one insertion, respectively, to get from one string to the other.  

If you click the button ≤1, all words from the word list will be added to the selection whose 

Levenshtein distance to any one of the entries in the selection list is less than or equal to 1. The 

buttons ≤2 and ≤3 work in an analogous manner.  
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 DIFFERENT TYPES OF SEARCHES 9

So far, we have demonstrated all functionality with the example of a regular expression search 

over transcription text. As already mentioned, this is only one of several types of searches you 

can do with EXAKT. Which type of search is carried out is specified via the combo box beside 

the Search: button. The first element specifies the type of search method that is used while the 

letter in brackets specifies the area where the search will be conducted. In EXAKT these areas 

are the different tiers of the transcriptions of the corpus. With the “RegEx” method you can 

search the T(ranscription), A(nnotation) or the D(escription) tiers. The “XPath” method can 

only be used for the T(ranscription) tiers.  

 

 

9.1 Regular Expression Search over Transcription tiers [RegEx (T)] 

This type of search has already been explained in the previous chapters. It conducts a search with 

the regular expressions method in all the transcriptions tiers of every speaker of the corpus. It is 

the most common type of search and can be used for different analyses. 

 

9.2 Regular Expression Search over Annotation tiers [RegEx (A)] 

Another type of search is a regular expression search of the Annotation tiers. It searches the 

annotations made in the corpus. If “RegEx(A)” is chosen, you have to choose the annotation tier 

you want to analyse. All annotation tiers that are used in the current corpus are listed in the drop-

down menu. Note, that the search in annotation tiers is different from the search in transcription 

tiers, because typically, annotation tiers are filled with predefined tags.  

 

If you enter a RegEx expression, a new column for the chosen annotation tier will be created. It 

contains the search result for the regular expression you entered. The “Match” column will 

contain the content of the transcription tier at the position of the search result in the annotation 

tier. The “Filter” option can be applied on the new annotation column as usual (see Section 7: 

FILTERING SEARCH RESULTS). (The RegEx “^.*$” will search for every tag (=all the 

content) in the annotation tiers.) 

Annotation column

 

c 

Match column
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9.3 Regular Expression Search over Description tiers [RegEx (D)] 

The Regular Expression search can also be applied to the description tiers of the corpus. If 

“RegEx(D)” is chosen, you have to choose the category of description tiers you want to analyse. 

All description tiers that are used in the current corpus are listed in the drop-down menu. 

Descriptions tiers typically are filled with describing language, not predetermined tags.  

 

The search is very similar to the “RegEx(T)” search. The “Match” column contains the search 

results of the regular expression.  

 

9.4 XPath Search over Transcription tiers [XPath (T)] 

The “XPath” search has already been visited in the Search Expressions chapter. As already 

mentioned, it can only be applied to the transcription tiers. 

c 

Match column
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 A step-by-step example of a multilevel search with EXAKT 10

A step-by-step explanation on how to conduct multilevel searches with EXAKT will be given in 

the following. The HAMATAC corpus will be searched for this example.  

The goal is to research the German word “ja” (‘yes’) in the corpus. So the first step would be to 

find every instance of “ja” in the corpus. You might want to also find capitalized “Ja”. 

Step 1: Choose “RegEx(T)” and enter “\b[Jj]a\b”. 

Now you have a concordance with every instance of “ja” in the corpus. The HAMATAC corpus 

is annotated with a “pho” and a “disfluency” tier. To show possible annotations of the “ja” 

results, follow with Step 2. 

Step 2: Go to Columns > Add annotation… and choose the “pho” tier, overlap type “Exact”. 

Do the same with the “disfluency” tier.  

Now you have a concordance with more information. If you sort the annotation columns you can 

see how many of the “ja’s” are annotated in these tiers.  

 

Now you can research in which cases “ja” is used in an EDIT PHASE and how the phonetics 

are affected by it. For this follow with the next steps. 

Step 3: Filter the disfluency column for the type “EDIT PHASE” (pay attention to whitespaces 

in the tags!) and remove the unselected search results.  
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To get more information about the speakers, you can add metadata columns.  

Step 4: Add a new analysis “Age” with “Calculate Analysis” (see Section Add analysis).  

These metadata columns can also be filtered, so you can research, for example, if there is a 

difference between speakers under or over 30.  

 
 

Now you have a KWIC concordance you can analyze further. You can go from a search result 

to the transcription, use the Praat Panel or output and save the search results. 


